This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

WhatsApp Issue with Web Protection

hello everyone 


when ever i turn on web protection for a rule users who can use internet through this rule can use whatsapp application on there phones or web whatsapp

i tried to make a workaround for web whatsapp and created a top rule that allow access to web whatsapp and turned off web protection and that solved web whatsapp problem 

now my problem is with the application it self it wont work until i turn off the web protection 

although i made exception for it in the PROTECT>Web>Exceptions and checked the log viewer and it is all green and all http and https scan & Decrypt  are turned off 

is there any solution for this issue ?

thank you 

This thread was automatically locked due to age.
  • M.Hegazy,

    create a web exception with this urls:



    Here the image. In my case works. I use decrypt and scan on my XG.


  • Hi

    thank you for your reply

    i did exception as yours but unfortunately still not working

    i tried it without http scan and https decrypt option in the firewall rule 

    the strange thing is it was working before 

    it`s just stopped working 

  • i have added two more experision to your regex and now it is working for me

    now the QR code load without any problem

    one down and one to go ..

    still have whatsapp phone application issue

    i will update once i fix it


  • Hi

    i solved whatsapp application issue yesterday

    i dont use "Any" as service

    the problem solved when i added whatsapp application ports and both of them were working till this morning

    but couple hours ago the QR code came to the surface again

    any idea why this strange behavior from the firewall??

  • problem is finally solved

    it was related to "Enable Pharming Protection" option in web protection

    i had to diable it to get it work

  • We had a similar problem with Snapchat, where it was connecting to an IP using a hostname that did not resolve (pharming protection tries to resolve again).  We fixed it for unresolvable, but if an app actively lies about who it is connecting to....

    One solution (IIRC) is if you can debug the underlying host and IP that it is failing on you can create a Host-to-IP mapping that overrides DNS.  Then Pharming protection continues to work.


  • Finally I managed to reply in that Forum .. my first Post here :) I have the same problem. could you please instruct me what to do? I am not sure what you are meaning with IIRC and ceate a host-to-ip-mapping that overrides dns. where / how do I do it?

    Could you provide me some help? Would be greateful!

    Is it in DNS section or Hosts&Services?

    Thank you all


  • Hey guys, also had this issue and after adding the exception list i still did not work. i turned off pharming protection and still did not work. I finally got it to work by going into the web policy and adding a rule with the category voice and video calls and allowing it. Also move the rule to the top of the list as the web policy reads like a ACL. Also i have pharming protection enabled. I am running a 125 with 17.1.1 firmware. Hope this helps.

  • Depending on the situation there are two possible causes
    The application is trying to connect to an IP Address, and send a GET containing a hostname that does not resolve to the same IP.  I think that we have seen this on WhatsApp and SnapChat. 
    This caused a problem when Pharming Protection was enabled.
    There is a workaround by putting in your own resolution, under Network \ DNS \ DNS Host Entry
    If turning off Pharming Protection does not resolve the problem, then this is not the issue.
    If I recall correctly (IIRC) we put in a fix several months ago that should resolve this.  If you are running 17.1 and still have this issue which is related to Pharming Protection, please let me know.
    You have some other more common permission problem (like Christopher Moss).  Take a look at the logs and find out what is blocked and why.  For example maybe it is being blocked due to a File Type.  Modify the Web Policy to put in a higher level rule that allows it, or create an exception (see examples above) that bypasses policy.  Rules are implemented as ACL (Access Control Lists) and are read top to bottom.
  • thank you for response.

    as soon as I disable the pharming protection, things seem to work. Indeed for me it is whatsapp starting to delay extremely once I enable pharming protection again.

    I am still testing. I will test both above ways (Christopher Moss and Michael Dunn). It will take some days because I have to await user feedback and check on my own! Will get back to you for sure.

    Yes, I am running 17.1.1 MR-1


    edit: had the wrong name in () above...