Android enterprise don't install application after setup

Hi, i add device into my trial of sophos mobile.
when device is ready and configured,
i see that kiosk mode are not applied and
for the installed app , i see the status "installation request sent to google", but doesn't happen. 

Someone can help me with auto install app and kiosk??
 ty

my device is a CAT rugged phone with android 12



Edited TAGs
[edited by: Qoosh at 8:14 PM (GMT -8) on 20 Jan 2023]
  • Hi Alex,

    Thanks for reaching out to the Sophos Community Forum.

    Can you confirm that the Kiosk Mode configuration has "App group" specified, and the apps you're trying to install are included in the group you've selected? 


    Once the app installation reached this stage "App installation sent to Google" the device will need to check in with the Google Play Store for the download/installation to begin. The installation process is no longer immediately triggered by SMC but is pushed out by Google after Sophos has communicated the request.

    Kushal Lakhan
    Global Community Support Engineer
    Connect with Sophos Support, get alerted, and be informed.
    If a post solves your question, please use the "Verify Answer" button.
    The New Home of Sophos Support Videos!  Visit Sophos Techvids
  • The installation of all application made fine but i don't know when it installed the apps because these days it was weekend.
    But this trigger that you mean i can modify??? which is his its timing??
    for now the app are installed but the kiosk mode won't start, someone can help me for this??? thank you

  • I was not able to find this documented on Google's site, unfortunately. When trying out a new app install, I did the following.

    - Assign application to be installed from Sophos mobile Control
    - Open SMC Application locally on the device and refresh by pulling down on the screen
    - Open Google Play store and search for desired app

    While waiting on this screen, it only took about 3 minutes for the app to begin installing, even though I did not click the "Install" button.

    If the kiosk mode is not applying on your device, I suggest checking the "Last SMC synchronization" time. If the sync is very recent, try checking if the right policy is applied.

    Kushal Lakhan
    Global Community Support Engineer
    Connect with Sophos Support, get alerted, and be informed.
    If a post solves your question, please use the "Verify Answer" button.
    The New Home of Sophos Support Videos!  Visit Sophos Techvids