Exchange auto discover not working. getting some errors

So I was trying to get my exchange WAF rule working. Sofar I have OWA working mail deliverability is working just fine for email. But when using the Microsoft connectivity test tool I am getting some weird errors.  any ideas what it could be?

 

Testing HTTP Authentication Methods for URL https://mail.domain.com/Microsoft-Server-ActiveSync/.

The HTTP authentication test failed.

 

Additional Details

 

Exception details:

Message: The underlying connection was closed: An unexpected error occurred on a receive.

Type: System.Net.WebException

Stack trace:

at System.Net.HttpWebRequest.GetResponse()

at Microsoft.Exchange.Tools.ExRca.Extensions.RcaHttpRequest.GetResponse()

Exception details:

Message: The decryption operation failed, see inner exception.

Type: System.IO.IOException

Stack trace:

at System.Net.Security._SslStream.ProcessReadErrorCode(SecurityStatus errorCode, Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest, Byte[] extraBuffer)

at System.Net.Security._SslStream.ProcessFrameBody(Int32 readBytes, Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)

at System.Net.Security._SslStream.StartFrameBody(Int32 readBytes, Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)

at System.Net.Security._SslStream.StartFrameHeader(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)

at System.Net.Security._SslStream.StartReading(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)

at System.Net.Security._SslStream.ProcessRead(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)

at System.Net.TlsStream.Read(Byte[] buffer, Int32 offset, Int32 size)

at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)

at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)

Exception details:

Message: The specified data could not be decrypted

Type: System.ComponentModel.Win32Exception

Stack trace:

 

Elapsed Time: 524 ms.