weird behavior that I expect not a VPN problem but need to ask

First I don't believe this is a VPN problem but making sure I cover all bases.

 

Recently our VPN users have start to see a problem when VPN in to our network.  They are accessing files on a Linux server via a editor on their laptop that is VPN in.  Some use notepad++ and other use notetab light to access the files.  When they make either changes and save the file, the file on the Linux server either gets blanked out or corrupt that you can't open it any more.

 

So for testing I first tried modifying a test file on my desktop on the inside network (no VPN).  Works like it should saving does not corrupt file and everything is good.  I then VPN in from outside  on a laptop using the same editor and file and the file gets corrupted.  I tried MS notepad, notepad++ and notetab light - all cause the file on the Linux side to go bad.

 

My guess is the windows and or Linux side is causing the problem.  Has anyone else seen something like this?  I don't see how the VPN would be causing it but I'm no expert.

 

I can't pin point time frame but looks like this started to be a problem with in last two months. 

 

John

  • In reply to KingChris:

    got this from Sophos. Your case number is [#9685143] .

     

    john

  • In reply to KingChris:

    Sophos support email say Your case number is [#9685143] . 

     

    john

  • In reply to JohnAdamski:

    Sophos support found the problem.  needed to allow packets for "SERVER-SAMBA Samba write andx command memory leak attempt" .

     

    something to do with samba 1 the tech things and the Linux server currently doesn't support smb2 or above.  Waiting on ERP to release version of ERP that can run on newer OS (with smb2).

     

    so working now and once we can upgrade Linux OS can remove.

     

    john