XG SFOS 17.5.6 MR-6 SSL VPN with macOS Mojave AUTH ERROR for all users

Checking all related topics around here I am not able to find a proper solution for this.

I have followed the KB entry https://community.sophos.com/kb/en-us/122769 configuring my SSL Remote Access and installed Tunnelblick 3.7.9a on macOS Mojave.

Importing the configuration from the portal (other OS) using OpenVPN Version 2.4.7 with OpenSSL 1.0.2r the connection will be initiated (warnings for decrecated compression options in XG Config are well known I assume). Entering username and password just simply won't lead to success.

I have tried with AD users aswell as with local users.

Any ideas?

  • Hi, i use Tunnelblick 3.7.9 (build5320) without issues, after update to this version, there was a warning that the following versions will not work with the configuration file.

  • In reply to Dirk Polzius:

    Hi Dirk,

    thank you for your quick reply. I am afraid, this does not solve. I have already downloaded several Tunnelblick versions and tested on different Macs aswell.

    I assume this needs fixing within SFOS somehow...


  • In reply to Martin R DE:

    Did you delete the last line in the ovpn-file?


    "register-dns"  its for windows and makes errors in OSX

  • In reply to Dirk Polzius:

    I have downloaded the "other OS" Config file.

    So there ist no register DNS in my file, already checked this ;)

  • Let me push this. 

    In the meanwhile I have replaced the Tunnelblick installation with a clean install. The Connection comes up until GET_CONFIG in the logfile. Afterwards another Authentication failed error appears. 

    I have tried the recommended setup in the Sophos KB.


    Is there anyone having setup SSL VPN with macOS successfully?