V17 hanging a lot and it's not stable, all my issues fix after return to V16

i have 3 Device XG 125 and yesterday morning i have updated 3 devices to V17 and after 3 hours, a lot of issues happened like the following :

 

1- VPN site to site not connection, from the log it say failed ( no more details in log )

2- suddenly when i try to logon to sophos main page , after enter the username and password, it will not login, even no message password is wrong or any message, it just stuck ( fix by hard restart, then it appear 2 time more then fix by hard restart)

3- it's not responding to SSH, mean i enter username and password and i choose to restart or shutdown but, nothing happened 

4- after restarting then login to firmware page to check the current version, it will stuck and nothing appear

 

 

all of this issues appear in all of my XG ( 3 devices in 3 different location ), and all working back normally after back again to firmware 16, so is 17 tested or not ? i'm always doing update for the new firmware and no issue at all, this the 1st time, and this effect my organization for 2 hours, 

 

and can any one advice me the following :

1- is there any support hotline of sophos in UAE?

2- what is benefit of having Enhanced Support, and what different between it and Enhanced plus Support ?

3- what is the backup solution you can advice if one device (hardware or software failed ) ?

 

  • KhaledMaged,

    you should never upgrade production systems without a change management process. So, test the upgrade in a test environment.

    Also, open a ticket with the Sophos support and let us know.

    Thanks

  • In reply to lferrara:

    Can you please explain what do you mean by(production systems) and (a change management process ) ?

  • In reply to KhaledMaged:

    KhaledMaged,

    in any environment, any one, yoour Organization should adopt a change management process, where changes are handled in a certain way that in case of failure, systems can return to an operational state. The primary goal of change management is to keep the security level at what the policy request.

    This is a security concept and not a Sophos One.

    So, test every solution (Sophos, New HW, New SW, Changes,etc...) in a test environment and then move to production with particular attention.

    Regards

  • In reply to lferrara:

    Thanks for your clarification, regarding testing the update in test environment, so i have 3 branches with 200 Users, how to test the update between 3 branches with 200 active users !!

  • I have also experienced similar performance issues on the XG125 and also have noticed an extreme throughput bottleneck with IPS.

    I have a 300/20 connection coming into the Sophos and when doing a speed test with the ISP with IPS policy turned on within the policy I only get about 50-100Mbps.

    Set IPS policy to None and my speeds reach about 290Mbps, finally stop IPS Engine service and speeds are up to 350+ Mbps. (connection is 300Mbps but ISP allows burst speeds for periods of time)

    These problems did not exist in V16.05.8

    I will be opening a case to have this reviewed and will report back here.

  • In reply to hjherron6:

    Any replay from technical team ? is it not compatible with XG125 or what ?

  • Hi Khaled,

    For such high priority and on the fly support (immediate) , you can go to bellow support chat portal.

    You will be directly connected to support engineer where they take access os your system in less then 5 min.

    Regards, Ronak.

  • In reply to Ronak Sheth:

    I am having the exact same issues using version 17.0.0 GA. Switching back to SFOS 16.05.8 MR-8 solved the issues.

  • In reply to Ronak Sheth:

    i now now in 16V i can't risk by go to V17 then contact support, and i can see too many customers complain about that

  • I have a Qotom Core i5 system at home and it has locked up twice since v17 was installed. I haven't had 1 lockup at all during 16.05.  I got the login screen you couldn't do anything with.  I think it was just browser cache showing it.

  • In reply to RobertDavis:

    Same with my: I'm also running on a Qotom i5.

    Now I noticed there's a new update available: SW-SFOS_17.0.0_GA.SFW-80

    I'm hesitating to upgrade since I don't know if the hanging is solved in this version. Anyone can elaborate?

  • In reply to Maikel van Amelsfort:

    Same Problem here. XG230 with 16 all ok .. upgrading to v17 VPN Problems and slow internet with upstream Proxy. 

    Disable IPS, Scan Https and Sandstorm maks is a little bit faster.

     

    Now back on 16.8 all perfect.

     

  • In reply to Christian Binder:

    I had a nasty experience with an iPhone and v17. Something wasn't working correctly (IPS?) and blocking traffic. But the iPhone had 'wifi assist' turned on so it silently switched to 4G! I transfered some big files and used my months data allowance in 3 hours. What's best, turning off IPS entirely or downgrading to v16?
  • In reply to hjherron6:

    Same problem with IPS. 
    Even with NO rule using it, it eats way too much CPU and must be stopped (XG105 with a 60/30 VDSL access).

    Plus other problems such as: https://community.sophos.com/products/xg-firewall/f/vpn/97773/sfos17ga---broken-failover-group
    Or the "clone" function in IPsec connection not working.

    The problem is not us who should "test" the product before using it in production.
    The problem is the product going GA while it's not working: "failover group" and IPS are basic features and should be properly QAed.

  • Hi  

    We have no issue's reported with XG-V17, Please do contact our Technical Support Toll Free: 1-888-767-4679 , International: 1-781-494-5800 our engineers are available around the clock to assist you.

    We would require the access of the device so that we can test it internally and see what could be causing the issue's you have reported. The best way to proceed further would be to have one of our engineers to have the devices checked. If you have already created a ticket, please DM the case number so that we could expedite it for quicker resolution.