Can't run Speed Tests

I am setting up an XG210 for the first time ever.  I have our fast 100mb network set up on port2 and our cable modem as a back up on port3.  I have 2 workstations plugged in and the XG is using DCHP to assign IPs to the workstations 10.20.20.100 and 10.20.20.101.

I am able to get to the internet fine (but it seems a little slow), so I tried going to speedtest.net to see what my speed is.

 

speedtest.net just sits there like this

All the settings on the XG210 are pretty much the default out of the box protection settings.

Any ideas what I need to do to get the speedtest results and possible speed things up?

I am run SFOS 16.05.7

 

TIA

  • Hi,

    what firewall rules do you installed?

    You will need to finetune IPS even if you do not have it enabled on your firewall rule.

    Ian

  • Take a moment and confirm that the interfaces are all coming up at the right speed and duplex. I have see the symptom of slow speed due to speed and duplex mismatch.

    Check - Configure - Network - Interfaces - to see what they negotiated.

    Change them to what they should be under - Advanced Settings - Interface speed

  • In reply to Shaun Sturby1:

    The settings are correct "100 Mbps - Full Duplex"

     

  • In reply to rfcat_vk:

    rfcat_vk

    Hi,

    what firewall rules do you installed?

    You will need to finetune IPS even if you do not have it enabled on your firewall rule.

    Ian

     

     

    I have the default out-of-box rules installed.

    I have tried opening ports 8080 and 5060 as I found some sites that say speed tests can use those ports, but still no good.

    What fine tuning to IPS would I have do to?

    TIA

  • In reply to Paul Dunn:

    Change both web policy and IPS policy to 'None' and try a different speed test site. Google it if you don't know any.

    Do you have Ad block addon? Speedtest.net does not like that but it should tell you.

  • In reply to Usbkey:

    Both web policy and IPS are set to 'None'

    don't know what most speed tests are not working, was able to find http://speakeasy.net/speedtest and that one does work

    very strange

  • In reply to Paul Dunn:

    Please open port 8080 for speed tests to work. This problem bothered me for many weeks. Nothing showed blocked in the logs. Finally, I decided to open port 8080 for outgoing traffic and the problem was fixed.

  • In reply to ArunGupta:

    One of the first things I tried is open port 8080.  That did not help

     

    The only speedtest I can get to work are https://www.speakeasy.net/speedtest/ , http://www.dslreports.com/speedtest and https://fast.com/

     

    http://beta.speedtest.net doesn't work, http://www.speedtest.net doesn't work, http://speedtest.xfinity.com/ doesn't work, https://www.verizon.com/speedtest/ doesn't work, 

  • In reply to Paul Dunn:

    Hi,

    I suspect you are having issues with the flash based speed tests, try speedof.me. I tried a couple of those sites and one reports I am using a proxy on port 3128 and then fails because my firewall does not support byte something and then further tells me I have a bad anti-virus (windows) on my mac to get a better one. Pity, no anti-virus on mac at moment.

    I also suspect you have enabled some additional application based rules which are getting in the road.

    Ian

    Extra stuff. Changing the IPS settings in your firewall rules to NONE does not disable IPS, you need to set the DOS flood rules to disable.

  • In reply to Paul Dunn:

    Very strange. I had exactly the same problem, same speed test websites not working and same ones working as you described.

    For me, port 8080 (both TCP and UDP) did the trick. Of course, I have other ports opened, these include DNS, FTP, HTTP, HTTPS, ICMP, IMAP, NTP, PING, POP3, SMTP, TCP 5228, TCP 5223, UDP 500, TCP 8245, TCP 587 and 465, TCP 8888, TCP 11371, IMAP SSL, GMAIL POP3, TCP 8080, UDP 8080, TCP 5060, UDP 5060 and VPN TCP 110.

    Please check if opening port 8080 for both TCP and UDP helps. I have all other protections like WAF, IPS, Web filtering, DoS etc. disabled.