Running Home Edition on XG85 Hardware

After doing some research, I recently purchased an XG 85 assuming I could use my home license on the appliance.  However, trying to install, I've been getting the "this is an appliance" error and the install won't go through.

I've read everything I could find on different websites as well as the Sophos forums and seen some people with similar issues but never any solution.  Part of the problem is that the XG 85 does not have VGA out and every partition tool ISO I have tried wont work via the serial console connection because they all require some sort of video out.  I've also tried some different linux commands to wipe the partition but it looks like one may not even exist on the /dev/mmcXXX card?

I'm running out of ideas on how to get this working and if its even possible at this point?  I purchased the firewall for this reason so I'd hate to be out the money if I cant get this working.

 

ideas.sophos.com/.../10754394-allow-xg-home-edition-run-on-sg-hardware

  • Patrick,

    this feature is not yet available. It is planned. So you have to wait. Use a spare computer or a VM.

    Thanks

  • In reply to lferrara:

    Thanks for the post.  Any idea when it is planned for?

     

    I purchased the XG85 when I read on the previous post that it would be allowed and other people seemed to have success with the XG hardware.  IF I had know the XG85 wasn't supported I wouldn't have spend the $300 to get it.

     

     
  • In reply to Patrick Brooke:

    Patrick,

    keep an eye on ideas.sophos.com

    Regards

  • What disappointing replies in this thread. I too have an xg85 and purchased because of information on these forums that said I would be able to run the home edition on the 85.

    This feature has been in planning since March 2016 Sophos. It's a simple change to the hardware check during the firmware load. 

  • Hi,

    I have the exact same need as you.

    I've managed to boot the gparted live usb over the serial interface and tried wiping the partitions, without success.

    The xg85 seems to have a flash memory for the system divided into mmcblk0, mmcblk0boot0, mmcblk0boot1 and mmcblk0rpmb. Normally i'd say boot0, boot1 and rpmb are partitions on mmcblk0. But I cannot edit/remove them. I can wipe/partition /dev/mmcblk0 but doing that still results in "Detected Sophos Physical Device".

    Really looking forward to a resolution of this problem. Right now it's just an expensive, simple firewall.