RED10 Connected can't ping devices

Hello, I have one of my RED sites connected, I can ping the RED device, but I cannot ping a device behind it.  Before I can try my other sites I need to figure out this mess I created.

I have probably messed up my FW rules or routing as no combination I have tried so far works.  If someone could show examples maybe?

this is how I have things set up...

My XG local LAN IP is 192.168.1.1  my RED local LAN IP is 192.168.4.1  I can ping the RED from my desktop behind the XG.

My RED is defined in ZONE (created by me) REDZONE, no tunnel compression (maybe after I get the pinging working)...

I defined a host for my RED subnet LOCATION4 and a host for my XG subnet LOCATION1

I have a FW rule RED2LAN - Source Zones: REDZONE, Source Networks: LOCATION4, all the time, Destination Zone: LAN, Destination Network: LOCATION1, Services ANY

2nd FW rule LAN2RED - Source Zones: LAN, Source Network: LOCATION1, all the time, Destination Zone: REDZONE, Destination Network: LOCATION4, Services ANY

Created a Policy Route Interface RED4, Source Network LOCATION4, Destination Network: LOCATION1, any service

2nd Policy Route Route Interface RED4, Source Network LOCATION1, Destination Network: LOCATION4, any service   (I tried LAN1 as well)

Routing GW for both is the same port that the RED connects to.

-------------

Lost for now...

Thanks in advance.