Cannot import Device Configuration to Template

Hi, I have two XG310 appliances in HA (Active-Passive) with all the rules and policies configured working in production, now I have to deploy 25 new XG115 to our remote offices, so I have installed a virtual SFM but when I try to create a new template importing the current configurations from my XG310 the template is created but with default settings, none of my objects are created.

 

SFM right now is 17.1.2

SFOS 17.5.9

Thanks.

  • Hi Rodrigo Silveira,

    In order to create template form the XG firewall, it has to be joined to the SFM. If firewall is already connected to the SFM and there is no issue with communication, i request you to Open a Support Case. This issue could be related to an ID NCCC-8159 that our support team is already investigating. 

    Please PM me the case number. 

    Thanks,

  • In reply to H_Patel:

    Hello H_Patel,

    I am currently testing Sophos XG and SFM with the goal of migrating about 100 firewalls to Sophos XG. I'm having the same problem with the device configuration on the XG not being read into the SFM. I have a current SFM (SFMOS 17.1.2 MR-2) and one SG 550 and one SG 125w (SFOS 18.0.0 GA-Build321) each in the test environment. The templates are a very important point for the migration.
    As we are still testing I don't have an XG license at hand to open a support case. I currently only have UTM licenses.
    When will the bug in the SFM be fixed? Or is a Workaround available?

    Regards,

    Ben

  • In reply to Ben@Network:

    Hi ben, I opened a support case but still waiting for a resolution, as soon as I have a fix for that I will share here.

    I will keep you updated.

    Thanks

  • In reply to Ben@Network:

    Ben, you have installed SFM in a hardware appliance or are you using a Virtual Machine? If you are using VM, what platform do you use? VMware?

  • In reply to Rodrigo Silveira:

    Hello Rodrigo,

    I installed a virtual SFM on out ESXi-Servers. 

    I found a workaround. For my setup I was able to import a Firewall configuration form an XG with Firmware 17.5-MR9 into the SFM.

    Ben

  • In reply to Ben@Network:

    What is the workaround, can you share it please?

     

    Thanks

  • In reply to Rodrigo Silveira:

    Hi,

    the workaround is I build a device configuration and sync'd into XG-Box with 17.5-MR9. Next I created a new device template and imported the configuration from the 17.5-Box. 

    The same workflow with the XG v18.0 does not work for me.

    Ben

  • In reply to Ben@Network:

    Hello Rodrigo,

    Currently I'm not able to install a template on the firewall with the XG 17.5-MR9 Firmware. I am of the opinion that this has worked in the past.
    This is my state:


    17.5-MR9:

    • Template can be created
    • Template cannot be published
    • Access via "Device Configuration" is possible

    18.0:

    • Template cannot be created and published
    • Access via "Device Configuration" is not possible

    Ben