Sophos Connect install detected IE version less than 11 on this machine

I'm trying to install the client on my machine but I keep receiving the following error;  Sophos Connect install detected IE version less than 11 on this machine.  I've tried installing using a different user but no luck either.  I assume I may have an earlier version installed but can't find it...Any guidance here would be greatly appreciated.  

  • I also receive the same exact error message. Would love to know the solution!

  • Hey  

    I would advise moving this thread over to: https://community.sophos.com/products/xg-firewall/f/sophos-connect 

    In regards to your question, have you checked which version you have installed?

  • In reply to Kirby Jimenez:

    I have version 1.1.11.1214 of the MSI on my computer, opening it up with Orca shows that it has a launch condition for IE version, it can be seen in the LaunchCondition table of the MSI:

    So the launch codition of the MSI is:

    Installed OR (IEVERSION AND IEVERSION >= "11")

    So if Sophos Connect is already "Installed" (https://docs.microsoft.com/en-us/windows/desktop/msi/installed) or IEVERSION is greater or equal to 11 it is fine to run.  If neither of these are true then you get the message in the "Description" column of the LaunchCondition which I guess is what you see. So the question then becomes, if you don't want to edit the MSI to remove/change the launch condtion, which I wouldn't advise, what is the IEVERSION property being set to on your install? 

    You could run the MSI and set the IEVERSION property on the command line but doing so will not help as it will get re-assigned later as the AppSearch action runs as shown below as passing it in on the command line is really just initialising the property.  E.g.
    msiexec /i SophosConnect.msi IEVERSION=12

    So in this case, in the MSI log (%temp%\MSI*****.LOG), you will see it get reset:
    PROPERTY CHANGE: Modifying IEVERSION property. Its current value is '12'. Its new value: '11.53.18362.0'.

    So that is no good, we need to find the source of the "11.53.18362.0" version string as it is in this case.

    Back to the MSI and specifically in the table AppSearch we see:


    So the "IEVERSION" property is set to be the value of "IEVer", so where does this come from? The answer lies in the RegLocator table:


    The values are:
    Root = 2
    Key =  \SOFTWARE\Microsoft\Internet Explorer
    Name = svcVersion
    Type = 2

    Where, Root and Type are defined here: https://docs.microsoft.com/en-us/windows/desktop/msi/reglocator-table

    msidbRegistryRootLocalMachine 0x002 2 HKEY_LOCAL_MACHINE
    msidbLocatorTypeRawValue 0x002 2 Key path is a registry value.

    So the verion of IE as used here is obtained from the string value svcVersion under:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\

    ...but if this is a 64-bit computer, as this is a 32-bit MSI, the value would come from:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\

    So I would first check the MSI log (%temp%\MSI*****.LOG) to see what value is being reported by searching for the line containing:

    PROPERTY CHANGE: Modifying IEVERSION property.

    Then check on a 32-bit computer the vaue of "svcVersion" under:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer
    and on a 64-bit computer check the value of "svcVersion" under:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\

    In the MSI log you should see something like:

    Action start 10:19:44: AppSearch.
    MSI (c) (80:D0) [10:19:44:867]: Note: 1: 2262 2: Signature 3: -2147287038
    MSI (c) (80:D0) [10:19:44:869]: PROPERTY CHANGE: Adding WIN10OS property. Its value is '#10'.
    MSI (c) (80:D0) [10:19:44:873]: Note: 1: 2262 2: Signature 3: -2147287038
    MSI (c) (80:D0) [10:19:44:875]: PROPERTY CHANGE: Adding IEVERSION property. Its value is '11.53.18362.0'.
    Action ended 10:19:44: AppSearch. Return value 1.
    MSI (c) (80:D0) [10:19:44:881]: Doing action: LaunchConditions
    MSI (c) (80:D0) [10:19:44:885]: Note: 1: 2205 2: 3: ActionText
    Action start 10:19:44: LaunchConditions.
    Action ended 10:19:44: LaunchConditions. Return value 1.

    Here AppSearch action has been called and it has retrieved the IE version number and set the IEVERSION property.  Windows Installer has then processed the LaunchConditions table and in this case as returned 1, so all is OK.  I assume that the LaunchCondition action is failing for you with value 3.

    As a test to prove all of this, on my 64-bit computer, if I set the value of "svcVersion" under:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\
    ...to be 1.0 rather than say "11.53.18362.0", then run the installer I get:



    In the MSI log for this install we then see:

    Action start 10:37:19: AppSearch.
    MSI (c) (94:44) [10:37:19:285]: Note: 1: 2262 2: Signature 3: -2147287038
    MSI (c) (94:44) [10:37:19:288]: PROPERTY CHANGE: Adding WIN10OS property. Its value is '#10'.
    MSI (c) (94:44) [10:37:19:295]: Note: 1: 2262 2: Signature 3: -2147287038
    MSI (c) (94:44) [10:37:19:298]: PROPERTY CHANGE: Adding IEVERSION property. Its value is '1.0'.
    Action ended 10:37:19: AppSearch. Return value 1.
    MSI (c) (94:44) [10:37:19:303]: Doing action: LaunchConditions
    MSI (c) (94:44) [10:37:19:306]: Note: 1: 2205 2: 3: ActionText
    Action start 10:37:19: LaunchConditions.
    MSI (c) (94:44) [10:39:54:982]: Note: 1: 2205 2: 3: Error
    MSI (c) (94:44) [10:39:54:987]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709
    MSI (c) (94:44) [10:39:54:989]: Product: Sophos Connect -- Sophos Connect install detected IE version less than 11 on this machine. First upgrade IE to version 11 to continue

    Action ended 10:39:54: LaunchConditions. Return value 3.

    I can only assume that if IE is really above 11 on these failing computers, then they are likley to be 64-bit, the "svcVersion" value under:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\
    is probably correct but the value under:
    HKEY_LOCAL_MACHINE\SOFTWARE\wow6432node\Microsoft\Internet Explorer\ 
    is probably wrong and wasn't updated for some reason.  I would just copy the correct version number from the native key to the wow6432node key and then re-run the installer.

    I hope this information helps people understand what might be going on and how Windows Installer works in this area.

    Regards,

    Jak

  • In reply to jak:

    Hi Jak

    I really hoped I'd found the solution here. That's a very thorough and helpful response.

    Unfortunately what I'm seeing is slightly different. In the MSI log, when it sets the IEVERSION property it says:

    MSI (c) (E8:E8) [10:09:55:191]: PROPERTY CHANGE: Adding IEVERSION property. Its value is '11.523.17134.0'.


    Later there's this:
    MSI (c) (E8:E8) [10:09:58:411]: Switching to server: WIN10OS="#10" IEVERSION="11.523.17134.0" INSTALLFOLDER="C:\Program Files (x86)\Sophos\Connect\" GUI="C:\Program Files (x86)\Sophos\Connect\GUI\" ARPINSTALLLOCATION="C:\Program Files (x86)\Sophos\Connect\" TARGETDIR="C:\" CURRENTDIRECTORY="C:\Users\joe.bloggs\Downloads\Sophos Connect" CLIENTUILEVEL="0" CLIENTPROCESSID="6120" PRODUCTLANGUAGE="1033" USERNAME="Windows User" SOURCEDIR="\\CompanyName-pdc\readonly\IT\Push\Sophos\SophosConnect\" ACTION="INSTALL" EXECUTEACTION="INSTALL" ROOTDRIVE="C:\" INSTALLLEVEL="1" SECONDSEQUENCE="1"  ADDLOCAL=ProductFeature

    Then this:
    MSI (s) (10:80) [10:09:59:144]: Command Line: WIN10OS=#10 IEVERSION=11.523.17134.0 INSTALLFOLDER=C:\Program Files (x86)\Sophos\Connect\ GUI=C:\Program Files (x86)\Sophos\Connect\GUI\ ARPINSTALLLOCATION=C:\Program Files (x86)\Sophos\Connect\ TARGETDIR=C:\ CURRENTDIRECTORY=C:\Users\joe.bloggs\Downloads\Sophos Connect CLIENTUILEVEL=0 CLIENTPROCESSID=6120 PRODUCTLANGUAGE=1033 USERNAME=Windows User SOURCEDIR=\\CompanyName-pdc\readonly\IT\Push\Sophos\SophosConnect\ ACTION=INSTALL EXECUTEACTION=INSTALL ROOTDRIVE=C:\ INSTALLLEVEL=1 SECONDSEQUENCE=1 ADDLOCAL=ProductFeature ACTION=INSTALL 

    Later this:
    MSI (s) (10:80) [10:09:59:184]: Ignoring disallowed property IEVERSION

    And near the end, this:
    Action start 10:09:59: LaunchConditions.
    MSI (s) (10:80) [10:10:55:725]: Note: 1: 2205 2: 3: Error
    MSI (s) (10:80) [10:10:55:725]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709
    MSI (s) (10:80) [10:10:55:725]: Product: Sophos Connect -- Sophos Connect install detected IE version less than 11 on this machine. First upgrade IE to version 11 to continue


    If I'm understanding this editor correctly, below should be the full MSI log:
    SCReInstallFail.LOG



    Any ideas on how to get past this point please?

    Win10 64 bit. Sophos Connect previously installed OK. Refusing to reinstall after uninstall.


    Many thanks

  • In reply to Roderick Pechey:

    Hello Roderick,

     

    Sorry you are having problems. Here is what I came across when I did a search for Ignoring disallowed property IEVERSION.

     

    Your machine must have had the EnableUserControl system policy set (applies to all MSIs, not just one), and your co-worker must have had that policy disabled. Was he on a domain controller perhaps? I am now seeing some issue with properties set via msiexec.exe command line from a non-elevated command prompt. The UAC prompt appears but the property settings are not passed to the msiexec.exe session 

     

    Hopefully that help to see why you are running into this problem. Also to verify IEVERSION is defined check your registry for it

    So the verion of IE as used here is obtained from the string value svcVersion under:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\

    ...but if this is a 64-bit computer, as this is a 32-bit MSI, the value would come from:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\

     

    Let us know what you find.

    Ramesh