Can't change gateway to backup status

Recently I decided to replace my existing LTE backup modem. As an aside I did so because my existing modem didn't have bridge mode, resulting in a double-NAT and some connectivity issues. For what it's worth, the new modem is a Netgear LB1120, which I had p

In any event, all I did was to unplug the existing modem and plug in the new one. I didn't shut off XG while I did so. I figured XG would just detect the new modem and adjust accordingly, given that the settings for the old modem were set to DHCP.

After waiting a few minutes, I go back to the admin web interface. I notice however that the gateway for the LTE modem (PortC) still shows the IP address for the OLD modem and now shows the status as red. OK fine, maybe it needs a few minutes to adjust. I wait about half an hour, check it again, and still the same thing. The old modem had shown as green and had been designated as a backup. So I figure that it might have to do with setting it as a backup. So I try changing it to active by clicking on edit, changing the radio button, and clicking Save. However, for some reason, XG just stays on the edit settings screen for the gateway. Still showing the old, incorrect IP address. I click on WAN Gateways and the gateway still shows as a backup and status red.

So, I figure maybe a reboot is needed for XG to detect the new modem. Nothing changes. I try changing it from backup to active again, again no dice.

So, I figure more extreme measures are needed. So I go to Network | Interfaces and edit the physical port on which the new modem was plugged in and set the Zone to None. I then reboot (just in case) and of course PortC is no longer there. I go back to Interfaces, edit Port3 to set it up in the WAN zone and success! PortC shows up in the list of gateways as Active and Green. Woohoo!

I figured all is good, so I just go back into the Settings for the PortB Gateway, and change it to Backup (and set the conditions for failover) and click Save. Little spinny thing and then... just back to the settings screen. I try it multiple times. Go back to the Gateway list. Still showing as Active, but now it's Red. Try rebooting the XG. No dice. Try changing it again. No dice.

Just in case, I check the firewall rules and changed all the ones that had WAN Link Load Balance to set PortB as Primary and PortC as Backup and once again try designating PortC as a backup. Also nope

So now I seem to be stuck, with no way to change PortB from Active to Backup, and Red status, which is somewhat frustrating. Any suggestions on how I could fix this would be most appreciated.

  • Just one follow-up. Apparently a few more related issues have cropped up: Starting to get connectivity issues - delays or failures in web pages loading, and regular notices that PortC is up, then down, then up, then down. <sigh>

  • In reply to dma0:

    dma0,

    check the arp-ip association for WAN gateway on XG using the command:

    system diagnostics utilities arp ping interface Port2 192.168.1.254

    In this example, we are using Port2 (XG WAN) to return the mac-address of 192.168.1.254 (Modem IP).

    Also check dgd.log from /var/tslog

    Because you changed the device but kept the IP, the old mac-address is still stored on XG.

    Let us know.

    Regards

  • In reply to lferrara:

    Dma0,

    if you want to flush the ARP table, from advanced shell use the following command:

    ip -s -s neigh flush all

    then compare the result using

    arp -n (before and after the flush operation).

  • In reply to lferrara:

    Thanks very much, but I wasn't able to figure out how to use the suggested command. I couldn't find anything resembling that either on the web UI or the menu when I SSH in. Trying to enter that command in the advanced shell also didn't quite seem to work.

     

    lferrara

    check the arp-ip association for WAN gateway on XG using the command:

    system diagnostics utilities arp ping interface Port2 192.168.1.254

  • In reply to lferrara:

    Thanks again. When I ran arp -n the MAC address seemed to correspond with the new modem (though each of the two digits was swapped for some odd reason). I flushed the ARP table but that didn't seem to change anything.

    lferrara

    if you want to flush the ARP table, from advanced shell use the following command:

    ip -s -s neigh flush all

    then compare the result using

    arp -n (before and after the flush operation).

  • In reply to dma0:

    OK so it was showing as RED because of the ping thing. I changed it to 8.8.8.8 (yes I know bad practice but will change it to something else shortly) and that problem went away.

    Unfortunately for some reason I still can't seem to change the gateway from active to backup.

  • In reply to dma0:

    FWIW I finally figured out how to change it to backup. When I shutdown the modem altogether, I was able to successfully change it back to backup, and then turned the modem on again.

    Unfortunately now it just keeps going up and down and up and down. Oh well.

  • In reply to dma0:

    Hi dma0, 

    Instead of doing a manual intervention as you did is not recommended. Simply use a free port on XG and configure it as a Second WAN interface and set it as a backup . By default, the failover condition is set to ping the gateway address. This does not indicate that there is an internet connection and may lead to a false interpretation. 

    Recommended settings

    Port A  LAN 

    Port B  WAN - primary 

    Port C  WAN - Secondary 

    Port D LAN

    Failover condition:  set to Ping 8.8.8.8 or 4.2.2.2. You may use another website public address which has a downtime >1% 

    Furthermore removing the Interface from the port and adding to another WAN device is simply not recommended as you may need to update the interface manually so the device will re-initiate the ARP request.

    The Mobile Broadband device should be set to backup and remained powered on at all times or during productive times.

    Test these settings and let us know if that would suit you.