AP55C on XG Firewall Home is Sloooooooow

Hi all,

Yesterday I installed an Sophos AP55C on my XG Firewall Home Edition. After about 3 hours of configuring, testing, and reconfiguring, the wifi is majorly slow. I already turned off all the network protection and scanning functions. I tried the 2.4 GHz and 5 GHz combined, and solo but still is very slow. My laptop and my phone have full coverage and the channels are free (checked with wifi analyzer). Does anyone have any more tips of how to speed up my wifi?

greets,

Jeffrey

  • Hi Jeffrey, 

    Are you facing the issue while using WIFI ? If so are you getting Performance issue while connected directly. ?

    If so are you getting Performance issue while connected directly. ?

    What are the CPU and Memory allocation to the Device in VM  ?

    Could you check via packet capture if there is a Latency with the connection when you ping you WIFI systems from XG appliance . 

    Thanks and Regards

    Aditya Patel | Network and Security Engineer.

     

  • In reply to Aditya Patel:

    Hi Aditya,

    Yes the performance is only dramatic when using WIFI. Using cable (1Gbps) everything is as fast as aspected. Below you can see the CPU usage and the memory usage and allocation. I have not yet tested the latency from and to my wireless device. I will try that. 

    Greets,
    Jeffrey

  • What encryption setting are you using for your wireless network?  Make sure it is set to AES only.

  • In reply to Aditya Patel:

    Hi aditya,

    I tested the wifi latency from my devices to the xg firewall and from the firewall to the devices, and it results in between 6ms - 14ms

  • In reply to axsom1:

    Hi axsom1,

    Thank you for the hint. I checked twice and yes I already set it to AES only

  • In reply to Jeffrey Jaspers:

    Hi Jeffrey,

    Check #4 in my guide here.

    Any help with that?

  • In reply to Jeffrey Jaspers:

    HI Jeffrey, 

    Do you have another Access point in place , We could use that to test the comparison as well. If this does now work I would advise you to log a Support Ticket and you may direct message me along with the Link to this forum for reference .. 

    Thanks and Regards

    Aditya Patel

  • In reply to Aditya Patel:

    Hi Aditya,

    Unfortinutly I don't have any other wifi accesspoint that can be compared to the AP55c. I only have an old wireless N router, but i don't think we can use that for testing.

    Greets,

    Jeffrey Jaspers

  • In reply to Jeffrey Jaspers:

    Hi Aditya,

    I tried to open a support ticket but I can because it is a home licensed firewall. Any advise?

    Greets,

    Jeffrey Jaspers

  • Hi Jeffrey,

    Have you try to change MSS on your WAN Interface to 1410?

    https://community.sophos.com/products/xg-firewall/f/sophos-xg-firewall-general-discussion/76768/unacceptable-guest-wifi-performance-regular-wifi-is-ok/302793#302793

    I have similar issue as you.

    After change WAN interface's MSS to 1410, it resolved my issue.
    (Not LAN, not Wifi, but WAN interface!)

    Shunze

  • In reply to ShunzeLee:

    Hi Shunze,

    Thank you for your reply, I have not tried this yet. What does the MSS setting do? I would like to understand why manually configuring the MSS setting will make the WiFi perform better. Im gonna try the setting tonight, so I'll let you know the outcome.

    Greets,

    Jeffrey Jaspers

     

    Edit*

    So I answered my own question. I anyone likes to know then read this: https://kb.cyberoam.com/default.asp?id=3098 

  • In reply to Jeffrey Jaspers:

    I have no idea about MSS.

    And don't understand why the MSS 1410 should be changed on WAN interface...

    But it resolve my WiFi slow issue.

    So I only can notice you the chance to try it.

    Good luck~

  • In reply to ShunzeLee:

    Hi Shunze,

    Yesterday I tried to override the MSS setting to 1410. Further testing needs to be done, but first impression tells me it does not solve the problem. 

    Greets,

    Jeffrey Jaspers

  • In reply to Jeffrey Jaspers:

    Hi Jeffrey,

    Did you check #4 in my guide as suggested in my previous answer?

    Post a picture of the output and the configuration done for AP.

    Thanks

  • In reply to sachingurung:

      Hi Saching,

    =======================================

    #4- If you have slow browsing/throughput and/or ifconfig (in advance shell) or show network interfaces (in device console) shows errors, collisions, dropped etc., try these steps, in sequence, until your problem goes away:

    1. Confirm that Quality of Service (QoS)' is not limiting bandwidth. QoS has never been setup
    2. When you discover Error on interface output, Edit the interface object, and in the 'Advanced Settings' drop down menu, set the MTU to 1350. If that works, check with your ISP to help find the largest setting that works. If this doesn't work, set the MTU back to its original value. There are no errors in the Interface Output and regarding the MTU setting, see my previous post
    3. If you discover Dropped packets, Change the Ethernet cable. Tried three different cables. No difference
    4. If connected to a switch, change the switch port. The switch is virtual (hyper-v) and I tried to change it to another port on the server. No difference
    5. If connected to a router or modem, change that device. Not connected to router or modem
    6. On the 'Hardware' tab in 'Interfaces & Routing >> Interfaces', experiment with different settings of fixed speeds and duplex. Make the same settings on the router/switch/modem to which the interface connects. Before testing the change, reboot both devices to force them to renegotiate their connection. In version 16.x i cant find the hardware tab
    7. At the end, place a non-manageable switch intermediate to the ISP and Firewall. its a virtual (hyper-v) switch

    ======================================

    the average troughput of my WiFi is currently 6-10MBps