Can't get EasyDNS to work

Hello,

 

I have a EasyDNS account with a domain, but it doesn't work with my Sophos XG dynamic DNS service.

 

I have set correctly the username and private key, after saving for the first time it update correctly my IP but found an error "Invalid Configuration or bad authorization".

And after the first scheduled refresh, it doesn't work any more and state "Unknown Error".

 

Am I the only one to have problems with EasyDNS ?

 

Thank for help.

  • Hi  

    Sorry to hear about this issue. For troubleshooting purposes, are you able to confirm that configuring DynDNS using Sophos as the provider works?

    Reference KBA

  • In reply to FloSupport:

    When I try to use Sophos dynamic DNS service, I've got an error immediatly after clicking "Save".

     

    "DDNS Service is temporarily unavailable"

  • In reply to karnalta:

    Hi  

    Would it be possible to share the details of your ddc.log with me? (Through PM if you prefer)

    Reference:

    Thanks!

  • In reply to FloSupport:

    Sorry for the late reply, I have been quite busy at work.

     

    DDC.log has given me more information about a configuration problem I had with my DNS service.

     

    Now Sophos update my EasyDNS record correctly but still show "Unknow Error", the problem seem that the XG cannot parse correctly the EasyDNS answer.

     

    See log below :

     

    Increase                                                                        
    Mar 18 11:33:31.424307: connect_to_server: members.easydns.com:80               
    Mar 18 11:33:31.523792: connect_to_server: connect(members.easydns.com) successf
    ul                                                                              
    Mar 18 11:33:31.523817: Connected with server - client_fd: 0 server_fd: 3       
    Mar 18 11:33:31.523847: write_server_socket:writen = 236, exerted = 0           
    Mar 18 11:33:31.821442: read_server_socket(): read bytes: HTTP/1.1 200 OK       
    Date: Mon, 18 Mar 2019 10:34:16 GMT                                             
    Server: Apache                                                                  
    X-Powered-By: PHP/5.4.45-0+deb7u5                                               
    Set-Cookie: easydns_language=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; pat
    h=/                                                                             
    Vary: Accept-Encoding                                                           
    Content-Length: 61                                                              
    Connection: close                                                               
    Content-Type: text/html                                                         
                                                                                    
    NOERROR                                                                         
    no update required for XXXXXX.com to XX.XX.XX.XX                            
                                                                                    
    parse_response: ERROR 

     

  • In reply to karnalta:

    Hi  

    Thanks for following up with your investigation.

    A couple of questions:

    • What Sophos XG Firmware version are you on?
    • Do you experience the same error when configuring DynDNS with Sophos as the provider?

    Thanks!

  • In reply to FloSupport:

    I am on SFOS 17.5.3 MR-3.

     

    With Sophos DDNS service I have sometimes trouble with an "Service Unavailable" error but otherwise it work fine without error.

  • In reply to karnalta:

    Would it be possible to please enable your Support Access Tunnel and PM me with your ID for follow up?

    Thanks!

  • In reply to FloSupport:

    Ok I send you that.