IPv6 not working between VLANs

I'm having trouble communicating over IPv6 between two VLANs. One device is my laptop, the other is the IPMI interface of a Supermicro server.

 

The first phase of our IPv6 project was to get IPv6 on our WAN interface. This has worked for us without issue. The XG can resolve ipv6.google.com and I can ping from outside the network the public IP of the XG device. Great.

The second phase was adding different /64 subnets to each VLAN on our LAN interface. My laptop was the first client with IPv6 and I can ping the XG gateway as well as reach the public Internet. Great.

Now I added IPv6 to another VLAN that the IPMI interface on the server exists on. However, I'm not able to ping it.

I've created both IPv4 and IPv6 firewall rules to reach the Internet. I've also created IPv4 and IPv6 firewall rules to communicate between VLANs/subnets. I can ping the server via IPv4 but not IPv6. I'm not sure if this is a misconfig on the server or XG firewall.

My guess is the server doesn't know the default gateway which is why my device can't ping it. It's using DHCPv6 stateless and a /128 IP as it doesn't let me fill in a gateway field. I've also tried using /64 as well and neither works.

With the laptop subnet, i'm using DHCPv6 and I had to create a router advertisement for it to work. Not sure if I need to do the same on the other VLAN.