Wifi not stable with AP55c

Hi all,

Last couple of week I repeatedly noticed some problems with the stability of my connections at home. I thought it was my ISP at first, but on further investigation it seems the WIFI connection is but very instable.

I got an AP55c connected to my XG firewall (Version 17.0.6 MR-6). With my laptop or phone connected to WIFI the connection goes from good to bad to gone to good again in seconds. The singal is 100% but the throughput is just bad. I have two SSID's configured. One dedicated to 5GHz the other to 2.4GHz. Nothing fancy is configured on it just WPA2 Personal with AES.

Anyone got the same?

  • Hi ,

     

    What is the  client traffic set to Separate Zone / Bridge to AP LAN / Bridge to AP VLAN? Have you enabled DoS setting under Intrusion Prevention?

     

    Also try to reboot AP once.

     

    Regards, Ronak.

  • Hi,

    the problem from my experience is caused by the connecting device going into power saving mode when traffic is very light. I have investigated to a certain level and found the 5ghz ssids the worst. Apple product are notorious for this and it takes awhile before the connection speed ramps up. My printers drop some connection speed but nowhere near what the macs do. The android on 2.4ghz used to do the same thing before I turned it off.

    If downloading for awhile the speed will ramp up. I am waiting for a after internet connection to run further tests.

    Also what are your IPS settings?

    Ian

  • In reply to Ronak Sheth:

    Hi Ronak,

    Thanks for the reply. The network is setup as "Bridge to AP LAN". I currently have IPS disabled (first thing I do when troubleshooting). A reboot of the AP temporary makes it a bit better but not much. The problem returns. after a few hours.

  • In reply to rfcat_vk:

    Hi rfcat_vk,

    The devices I tested on show the same problems after they booted up. So I don't think they are in power saving mode at that time, that being said you never know how Windows reacts and I'll setup my laptop to not use power saving on wifi. It is batter to have that turned off anyway. 

    Also in my case downloading big stuff (ISO files or something) does not make it better, some times the download even stops with a "no connection" message. 

    IPS it turned off.

     

    Greets

  • In reply to JeffreyJaspers:

    Hi Jeffrey,

    how does the same download behave when connected directly to the network?

    Ian

  • In reply to JeffreyJaspers:

    Hi Jeffrey ,

    Could you run the command in shell option 5 > 3

     

    Enable Debug.

     #service hostapd:debug -ds nosync

    Run the command and try to reproduce the issue.

    #tail -f hostapd.log

    Output:

    Disable Debug mode.

    #service hostapd:debug -ds nosync

     

  • In reply to Aditya Patel:

    Hi Aditya,

    I'll try to do this upcomming weekend

  • In reply to rfcat_vk:

    Hi Ian,

    Using the cable everything is as fast as it possibly can.

  • In reply to Aditya Patel:

    Well I tried this but the commands give no output. so i dont have any logging to share. But I found something. the problem only is on the 5 ghz network, 2.4ghz network is much more stable. I did a speedtest and the download was only 300mbps where it should be 400 mbps. And yes I had that 400mbps result in the past over the same configuration. My laptop is about 4 meter from the AP and there is nothing between it. 

     

  • In reply to JeffreyJaspers:

    Hi,

    you should be able to hit 866mb/s or at least 720mb/s that close the AP from my experience on the 5ghz channels. Also depends on low or high 5ghz channel. These APs are toys compared to home use ones that cost the same and have multi band mesh networking at greater then 500mb/s. It really is time Sophos brought their APs into the 21st century, there is no business reason for the poor performance.

    Ian

  • @Sophos got any reply on this matter?

  • Because of Sophos not responding I think I drop my patience with them. Time to move to fortinet.