a new BUG in V18 GA as well the original server time displayed on reports still broken.

Hi,

there have been a number of discussions about this bug over many releases of XG.

The XG reports do not understand daylight saving. I have started threads on this in the past and is obviously not important to Sophos. Not very professional looking when you can't get your report to generate at the correct time. The following screen shot is taken from the report this supposed to be generated at 1am Melbourne time.

The time the report wa ssent according to the XG.

The report scheduling settings.

The time the report was delivered to me.

Ian

  • In reply to rfcat_vk:

    Hi Ian,

    I should have explained more. I know it is a different issue but from your reports, it looks like the same underlying issue with DST. I could be wrong though. Just wanted to share my cases so it could be tracked.

     

    It has been a long time since I went through this with an engineer but if I recall, the OS and system had a different time that the services and processes Sophos uses. I will have to look back at my notes. This caused lots of issues and I had similar report issues as you describe.

     

    One workaround I remember was to change the timezone of the unit, reboot it, change it back, and reboot it again. That fixed it until the next DST change. This won't work with a cluster though.

    Mike

  • In reply to MichaelBolton:

    Hi MichaelB,

    the DST issue was supposed to be fixed, but hasn't been.

    I have had support look at my XG on this subject in the past and case was created.

    The report now arrive at the same time and according to the date in the reports within minutes of being generated except they are out by an hour and being generated the day before in some cases.

    If need be I can post report dates and associated delivery time/date.

    I originally started this thread in Dec 2017.

    Ian

  • In reply to rfcat_vk:

    Hi folks,

    I was too hasty with my post here...

    I tried the workaround by changing timezone to africa from europe, after reboot changing it back to europe.
    I set the report to the next hour, so I will have to wait and give feedback!

  • In reply to njabi:

    Hey folks!

    Changing timezone to any and back solved the problem, hopefuly for longer than a week ;)