Internal Ip's not as host names

In Reports , why all internal ip's not showing as hostnames ?

Or I have reservations in DHCP with hostnames-Ipadresses
Or I have DNS entries with hostnames-Ipadresses

So the information is available.....?

  • Hi Timoline,

    Greetings.

    This is not possible in XG, the reports you generate will be based on IP address. 

    This is because the host name and IP address association could changed.

    You can still raise a feature request on this regards and cast your vote, through:

    http://feature.astaro.com/forums/330219-sophos-xg-firewall

    Thanks

    Sachin Gurung

  • In reply to sachingurung:

    This was/is possible on UTM.  This certainly seems like step backwards.  I hate having to keep referring to an Excel spreadsheet to match hostname to IP address.

  • In reply to sachingurung:

    Sachin,

    are you sure about that?

    http://feature.astaro.com/forums/330219-sophos-xg-firewall/suggestions/12374352-dissolve-internal-ip-addresses-to-hostnames-in-rep


    The feature request is marked as "already possible" so creating a DNS Request Route as 0.168.192.in-addr-arpa should allow reports to have Names instead IP.

    I am missing something?

    Hmm

  • In reply to lferrara:

    Hi Luk


    I actually tried that prior to the maintenance release, but it did not convert names to IP.  If I do the DNS test, the names resolve correctly, but reports continue to show IP addresses.  I'll give it another try since I've upgraded to maintenance release and see if I have better luck.


    Thanks

    Corey

  • I too am wondering why all the reports list the IP addresses rather than the hostname. I have reservations setup for every mac address on my network, and have the hostname typed for each reservation. When I run the reports, I get the IP address but not the hostname, thus making it very difficult as I have to refer to an excel spreadsheet as another user is also doing. 

  • In reply to sachingurung:

    Sachin,

    can you check this internally? AlanT has marked the feature request as "Already possible" but other users complain that this is not working. I am not able to test it. Can you reply to us with a confirmation answer?

    Thanks.

  • In reply to lferrara:

    Has anyone seen this work?  I just logged into 5 different customers' XGs, all of which are pointing to their Internal DNS servers and have request route setup for the domain, but every report and ATP etc only show the IP.  

    This has actually caused a little hardship as one customer had an alert pop up in ATP and it only showed the IP Address, by the time he went to go check on that machine, the IP had changed so we weren't really sure which machine it was.  If it had showed the hostname of the PC it would have made it easier.

    Thanks

  • In reply to lferrara:

    Hi All,

    I request if anyone can raise a case with Support. I am unable to recreate this instance. Also curious to see what support has to say on this.

    Please DM me ticket# personally to keep a track on the case.

    Thanks

    Sachin Gurung

  • In reply to sachingurung:

    Hi Sachin, 

    I'm a home user but would be willing to provide whatever is needed to get this fixed. How do I go about creating a support ticket?

  • So, did anyone end up getting this working? I've got the same problem.

  • In reply to AlanI:

    I have not seen it work yet.  This was a great feature on the UTM, and I certainly do miss it.  I can't imagine why this would be this difficult or take this long to implement.  I hear what they're saying about IP/hostnames can change, but Sophos should leave that up to the admin to determine whether or not to turn the feature off or on.  

  • In reply to sachingurung:

    Hi  

    report by hostname is still not possible. Were you able to conduct some tests?

    A feature request for that has been opened:

    http://ideas.sophos.com/forums/330219-sophos-xg-firewall/suggestions/16036801-resolve-private-ip-addresses-in-reports-to-hostnam

    At the moment even on v16.01.1 is not working

    Thanks

  • Does anyone have this working, yet? Alan Towes has marked this feature request as "Already Possible" again, but I cannot get it to work.

  • In reply to sachingurung:

    So, I created a support case for this and I had the support engineer escalate this to the dev team, and then I found later my support case closed.

    I was then told that this is a new feature and that it won't be worked on until after v17 - yet Alan Towes has marked this feature as "Already Possible".

     

    Which one is it? Is it an existing feature that is broken, or is it a new feature? Cann you please advise your community as to what Sophos is doing about it, and mark the feature requests in the applicable way so that we can be clear on this?

     

    Thanks,

    Erik

  • In reply to ErikSzaks:

    This case looks like the Country blocking not working from wan to lan and Sophos did not give an official answer for more than 1 year.

    Another disaster's example. Dear Sophos, do not ask why people will move to another UTM product once the license expires.