SG 210 with software version XG Home License

Hello All, 

I've been stumbling around on this forum for a few months now but somehow i still didn't find a suitable solution for my issue:

I bought a SG210 for cheap - i was actually considering to buy a pc with double network cards in it but when i saw that SG210 online for $75 i thought i couldn't get any better deal. 
My intention is (and was) to install the software version of XG Home License on a device so i have a fully functional firewall with all the extra's to setup in my home automation system which is, to be honest, slowly overcrowded with IOT devices that 'need' internet access. I wanted to restrict that access (or limit it at least) to only the necessary functions.

I tried several steps and different solutions:

- gparted the internal HD of the SG210 and than use a bootable USB with the SW 17-5-9 ISO on it but on reboot all the LED's start blinking one after the other and beeps from high to low sounded from the SG210

- installed Ubuntu on the SG210 to be sure the partition was empty and again, after reboot, lights and noise from the SG210 but no installation possible

- reinstalled XG Hardware Appliance OS - which worked fine but was limited due to license limitations

So, my questions are: is it possible to run XG Software with a Home License on a SG210? And if 'yes': How do i get it to work?
I am aware that it is possible to run it on a SG115 and similar models - i just haven't found a way to get it to run on a SG210...

I know there could be a chance that these questions are already answered - if so: please move the post to the appropriate board or remove the post at all but please be so kind to refer me to the solution

  • In reply to rfcat_vk:



    if you are loading the software version you will need to connect via serial cable to the console port.



    ... i will try this than on monday, no way i can find a db9-RJ45 or an USB-RJ45 cable today.

  • For the time being I will have to put this one on hold here, simply because I haven't got any time in the next few days/weeks...

    At the moment the SG210 is running XG in basic mode in evaluating mode, no subscriptions, no advanced insights, just basic protection.
    I wanna thank all you guys who actively helped trying to solve this issue and if someone wants to take over for the time being: please do so ;)

    I didn't get my hands on a RS232 or com-cable to finish the last suggestion given, that's the disadvantage of living secluded in the mountains :D

  • The easiest way is to remove the hard disk from the SG 210 and install it in another computer, then install the system with the XG Software iso Image. After the installation and bevor the first start remove the hard disk immediately and install it back into the SG.

    That's how I did it with my SG230 Rev. 1 and it runs perfectly since then.

  • In reply to Koen Spierings:

    How are you making the bootable XG usb stick? If you use a utility like Rufus, then it's possible to choose the wrong options, and end up with a stick that won't boot. If you use something like Win32DiskImager, then it should "just work". 


    Short of that being the problem, watching the console for errors during install is your best bet for a clue. Either connecting a serial cable as already suggested, or a vga monitor, if the unit has a vga port on it, will give you a clue as to what is happening. 

  • In reply to AlanT:

    In Rufus you had to choose the DD-Mode for the Sophos Software Iso.

  • In reply to TimFranken:

    Thanks Tim!

    That did the trick!

    First i started with a 500GB new SSD - installed it in my old Dell Optiplex 3010 and booted from the USB drive with SW-17.5.9_MR-9-577.ISO on it - installation process took a while (size of disc?) and after installation asked for a reboot i powered down my pc, removed the SSD and installed it in my SG210. I could connect over but somewhere the installation choked so i repeated the process...
    I came a little further into the installation process but after a reboot the SG210 wasn't to be found on my network anymore.

    After fiddling a bit around i decided to take the original SSD out of the SG210, repeated the process, reinstalled it in the SG210 and i could run through all the steps!

    The SG210 is now sitting in it's place in my rack, connected to the network with XG Home license installed on it, finally!

    again, thanks a lot Tim!

  • In reply to Koen Spierings:

    Koen-- glad you got it working.


    Can you comment on how well the SW version works with your 210? What Rev? Are ports remapped? LCD working, etc?


    I currently am running XG on a Optiplex 9020 i7 but am pining for a rackmount solution.



  • In reply to kdub23:

    SW version is running as a charm, no difference to the previous HW version. 
    It's a REV 1 SG210, an oldy

    Ports are exactly is written on the SG210 

    Port 1, 2 and 6 are being used - failover works fine as well - LCD is lit but it's only saying "SOPHOS PROTECTION", no additional info and, i must be honest, i didn't try to see if there is any additional info i would use the cursors since the FW is build into the rack so no need to look.

    If you have additional questions: feel free!

  • Hi all, I have managed to install the latest XG v18 onto my SG230 Sophos appliance with XG Home Edition and it works great, you are just limited on the CPU cores and memory based on the XG home license. If you want to following JimtheITGuy on YouTube, he does the exact same thing.