XG Firewall on Openstack gives ERROR: firstboot failed: swapon /dev/swap

Hi,

I just tried to boot the latest version (as of writing build: 16_05_2160) of XG firewall on a public Openstack cloud. I uploaded the qcow image and started the VM. The VM has 1GB of RAM and 32GB Disk.

The KVM hypervisor boots the image with 1 local disk for the OS to partition and no separate SWAP or extra DISK. After the boot procedure it errors after:

I can acces the console but no luck after that. This issue also exists in the firstboot question on the community forum but it does not work for the latest version i guess.

How can I boot this image with the correct swap size?

  • HI SanderKoorneef, 

    Could you increase the ram to 2GB and try again and the minimum requirement is 20 GB , as for the VM you could try using our recommended Virtual environment . 

    Supported virtualization platforms

    Virtual appliances provide the same functionality as the standard UTM hardware platform.
    You can install UTM v9 within the following virtual environments:

    • VMware ESX 5.1
    • VMware ESX 5.5-6.5
    • Microsoft HyperV 2008 R2
    • KVM 1.0 kernel 3.2.0-29-generic (Ubuntu 12.04 LTS)
    • Citrix XenServer 6.0 Enterprise
    • HyperV 3.5 2012 R2

    All supported VM platforms undergo QA testing to ensure installation from ISO image and proper operation. UTM performance in a VM environment can vary widely due to various hardware differences, allocated resources, type of storage, etc.

    Known VM platform limitations

    • Microsoft Hyper-V: legacy network adapters are not supported.

    • VMware: Do not use flexible NICs. Use e1000 for gigabit or lower connection speeds or VMXNET3 for faster connections. It is not recommended to add or remove vNICs after installation as this can result in changes in NIC order.

    • Xen: 32-bit version of Xen is not supported, only 64-bit Xen is supported.

    Resolving installation issues on a KVM (Kernel-based Virtual Machine)

    If you experience problems installing the UTM on a KVM, try the following steps:

    1. Start up the KVM.

    2. Interrupt the automatic boot.

    3. You will now see the boot: prompt.
      Type default no-kvmclock

    Reference : http://sophos.com/kb/119230 

  • In reply to Aditya Patel:

    > Could you increase the ram to 2GB and try again and the minimum requirement is 20 GB , as for the VM you could try using our recommended Virtual environment . 

     

    • The server we are using is running with 4GB RAM and 32GB disk.
    • KVM under the hood running on Ubuntu 16.04 LTS

     

    Options when booting:

    Option 0:

    Option 1:

    As you see i don't have an option to get a prompt to fill in: default no-kvmlock. Can you advise any more steps?