Problem installing SF OS on a new SG230 Rev2 appliance

I'm trying to install SF OS on a brand new SG230 Rev2 appliance (wrongly ordered). As stated per KB this should be simple as re-imaging the device with the HW SF OS .iso on a USB stick (https://community.sophos.com/kb/en-us/124588). 

However when booting from the USB the following error appears on console:

 

Using the SW ISO results in a error that the installer detects a appliance and stops (as expected).

It seems the new SG230 Rev2 is still not compatible with the installer. 

 

Does anyone has a work around or do we just need to wait for Sophos to fix the HW installer?

  • Hi Bart,

     

    firmware v17 is still in BETA don't use this in production.

    Sophos added support for the new SG230 whitin 16.5 MR8, maybe it is currently not included in the v17 beta firmware.

     

    NC-19915 [Base System] Add support for newer SG210,SG230,SG310,SG330,SG430,SG450,SG550 and SG650 models in SFOS.

     

    please try the Hardware Installer 16.5 MR8

    please note the upgrade from 16.5MR8 to 17 Beta is currently not supported.

     

    Yours Lukas

  • In reply to lna:

    Hi Lukas,

     

    This would make sense. I tried v16.05 MR7 and v17.00 Beta, but both didn't work. I'll try v16.05 MR8 next week and let you know.

     

    Thank you for the fast reponse

    With kind regards,

    Bart Hunik

  • In reply to Bart Hunik:

    MR8 should work in your case. I have installed MR8 with my SG310 rev2

  • Hi All,

     

    Just tested the new MR8 image on the SG230 Rev2 and this works. Because I had to wait a few days for the image, I also tested v17 Beta2 and this image also works on the newer devices (like the SG230 Rev2).