XG85 Webadmin Internal Server Error


I've actually problems to connect to the Webadmin and Userportal of two of our customer XG85. I always get this message in the browser:

Internal Server Error

The services worked till a few days. On one machine there is Firmware 7.5.8 on the other 7.5.11, auto hot fix is enabled. The SQL-hot fix was applied and all passwords changed on 04/25. ssh to both machines is possible.

Maybe some bad side effect with the new Sophos hot fix (captchas)?

  • In reply to Jasmin:

    I have [70] XG85W with this problem.

    Do we have any idea when will it be fix?

  • Hello Josef,


    It seems they have pushed down a fix to the affected XG 85 devices. I can now access my devices without the "Internal Server Error" coming up.




  • In reply to juan mora:

    Hello Juan,


    Have you tried in the last two minutes? My device are coming back up without this error so I believe they are pushing down a fix to affected devices.





  • In reply to Brandon Roy:

    Nothing yet on mine




    **fix confirmed after receiving hot fix**

  • In reply to Brandon Roy:


    I checked a few boxes and I can access then now.

    Thanks ,


  • Hi guys,


    I can acces my boxes now.



  • In reply to Devanir Silva:

    Some of our equipment is already with standard access.

    I believe that now for the others it is only the update time to happen so that everyone can be OK.

  • In reply to Jasmin:

    Ok thanks my XG85s are back accessible via Webadmin.

    But now they enforce me to a password reset on all admin accounts. I've changed all passwords (including admins) in the night from April 25 to 26! This is really annoying.

  • Hello,

    Sophos has released a hotfix to affected devices to resolve this issue NC-59728.

    You can confirm if the patch has been downloaded/applied by running the following commands from the Advanced Shell of the XG (5>3):

    #cd /log

    #grep NC-59728 u2d.log


    console> system diagnostics show version-info

    Firmware Version: SFOS 17.5.11 MR-11.HF050620.1

    Check for 050620.1

  • In reply to emmosophos:

    Hello Friend,
    I did the procedure according to your instructions and my firewall keeps giving the error. "Internal Server Error"
    The version updated according to your orientation

    Follows data from my firewall

    Serial Number:                 
    Appliance Model:                SFVH
    Firmware Version:               SFOS 17.5.10 MR-10.HF050620.1
    Firmware Build:                 620
    Firmware Loader version:        0x00000005
    HW version:                     XV01
    Config DB version:              17.318
    Signature DB version:           17.318
    Report DB version:                17.318
    Webcat Signature version:
    Web Proxy version:              compiled
    SMTP Proxy version:             1.0
    POP/IMAP Proxy version:
    Logging Daemon version:
    AP Firmware:                    11.0.012
    ATP:                            1.0.0296
    Avira AV:                       1.0.407474
    Authentication Clients:         1.0.0019
    IPS and Application signatures: 9.17.06
    Sophos Connect Clients:         1.4.001
    RED Firmware:                   2.0.019
    Sophos AV:                      1.0.15571
    SSLVPN Clients:                 1.0.007
    WAF:                            1.0.0006
    Hot Fix version:                14

  • In reply to Anderson Dias:

    Make sure Auto Update is enabled.
    So you can be sure that the box will receive the necessary updates.

  • In reply to Devanir Silva:

     Yes. It is enabled
  • In reply to Anderson Dias:

    Hello Anderson,

    If the issue still happening.

    Could you please send me by PM the S/N of your device.