XG Firewall Home Edition on SG Hardware


is it possible the XG Firewall Home Edition run on a SG Hardware Appliance?


  • In reply to KennethHolmqvist:

    Sounds great!

    But no chance for the internal AP Crying

  • In reply to Nemo:

    Where can we get SW-SFOS_15.01.0-376.iso now that Sophos has removed images from their FTP site?  The newest revision throws errors on SG hardware saying to use the HW version.

  • In reply to EdJohnson1:

    If you first reinstall the SG HW device with a SG HW ISO and then configure it to just be able to reach the console, you can then rename or remove the file: /etc/asg  and right after that it is possible to overwrite the device with SW version of XG (version 16)

  • In reply to apijnappels:

    By version 16 the software version of SFOS is now possible to install on SG/XG Hardware(I guess it's only on the smaller appliances, I can install the SW version on my SG105, but not on my SG125)

    Deleting the asg file in UTM9 has no influence since the harddrive is being formatted during SFOS installation.

  • In reply to KennethHolmqvist:

    I just did the same on a SG105. First time it wouldn't install because appliance found. I then deleted /etc/asg and could then overwrite with SW XG 16.

  • In reply to apijnappels:

    I tried deleting the /etc/asg file on my SG125 but it still required the HW version of SFOS during install.

    So i took the SSD from the SG125 and installed it in my SG105 and then installed the software version of SFOS on it (had to do the same with my XG105). So i guess there's something magical about that SG105..

  • In reply to KennethHolmqvist:

    So I've got an XG85 unit. Can I install XG Home Edition on that?

  • In reply to Hale221:

    It is possible yes, but it's not easy. I managed to install the software version of SFOS on an XG105 appliance

  • Hi

    Ive been following this thread, and the feature request, but it dosn't seem clear as to where this is at

    I have a Sophos SG125 appliance that came with UTM 9 installed and an expired license that i am wanting ever so badly to run the XG Home on.

    I removed the SSD in the UTM and put in a fresh new SSD and an additional 2gb memory and tried the following

    1) Installed SFOS Hardware version, installs without a drama, but i was not able to apply my home license, in my instance there was already a serial applied, and the only option i had was to migrate that serial to XG (which must be the expired utm9 serial), or do a 30 day trial.

    What gets me though is how, when i removed the original HDD did it know about that serial?

    2) Then tried to install SFOS software version on a fresh ssd, upon booting of the ISO i immediately get "Detected Sophos Physical Device. Please get proper installation source."


    So with that in mind i gather

    1) You cannot install the software ISO (which is strange given that i put in a new SSD and it is effectively intel hardware anyway)

    2) You can install the Hardware ISO, but not apply the XG Home license.

    Anyone who has had success with this 

  • In reply to buzurk:

    Strange, I've done this numerous times on appliances.  

    Trick has always been to blow out the partitions first, then run the software installer.  So for instance I will boot up gparted, blow out the partitions by creating a new volume, then boot up the software installer and off it goes.

  • In reply to axsom1:

    So would I be correct in assuming that with my XG85 I can take the ssd out, wipe it and replace, then install the software version of the Home edition whilst monitoring the process over the console cable?
    The XG85 doesn't have a VGA port and that is where I've been stuck. I'm concerned about bricking the unit with no way to access it.




  • In reply to axsom1:

    I know, i tried it on a fresh SSD - i got the software one to install, when i enter my serial it registers but cannot sync license


    this is a real shame, i chose to buy an SG for home to run xg home on

  • In reply to axsom1:

    This is great news!

    How would i go about blowing out the partitions? I have an xg85w.

    I've tried booting the gparted live usb and writing a new mbr, but when i boot the SW_SFOS installer it still complains about it cannot be installed on an appliance. These are the devices I have (the memory seems to be soldered onto the board (mmcblk), not a removable SSD).

    The mmcblk0 (memory card block device) I can reset the mbr, but the boot0, boot1 and rpmb i cannot touch.

    I saw that there was a possibility of removing /etc/asg and the SW_SFOS would then accept it as a non-appliance install. How would I go about getting r/w permission in the file system on the 85?

    Has anyone succeeded in getting Sophos Home to run on an xg85?

  • In reply to apijnappels:

    Thanks, this looks promising"

    "and then configure it to just be able to reach the console"

    How would I go about doing that?