Port forwarding for Qnap OpenVPN server

Hi. I know XG 135 have an OpenVPN server builtin, but I wan't to use a Qnap NAS as OpenVPN Server.
I configured OpenVPN Server on Qnap, and I forwarded port 1194 from Wan interface to Lan (IP of Qnap); the connection from my PC to the VPN works perfectly, but I can't reach any device of the Lan.
Where is the problem? Is there other firewall rule I have to set? Thanks for your support!

  • Massimiliano,

    check the XG logs to understand if other ports are required. Make sure that the routing table on the vpn client has the remote vpn network correctly populated.

    Regards

  • Hi  

    Please remember that when you are forwarding VPN services to another device, the XG will have no affect on the traffic.  The reason for this is that its encrypted.

    The only time the XG will have an effect on the traffic, is if the QNAP server is on another subnet.  You may need a static route on the XG for VPN pool to point back to the QNAP server and zone based rules.

    Thanks!

  • In reply to KingChris:

    KingChris

    Hi  

    Please remember that when you are forwarding VPN services to another device, the XG will have no affect on the traffic.  The reason for this is that its encrypted.

    The only time the XG will have an effect on the traffic, is if the QNAP server is on another subnet.  You may need a static route on the XG for VPN pool to point back to the QNAP server and zone based rules.

    Thanks!


    Hi Chris and thanks for your attention. You're right, the problem is the VPN client: I tried to connect to the VPN from another client (Windows instead of Linux) and it perfectly works! Sorry!