XG v18 SSL/TLS inspection interfering with Veeam Cloud Provider Replication

Hey everyone,

we're using Veeam and replicate backups from remote sites to our main site. Since deploying v18, we started having issues with the replication failing. After working with Veeam Support, the solution was to completely disable SSL/TLS inspection on the firewall at the main site. Not sure why it's causing issues, but at this point, I can't turn inspection on because the backup replication will fail. How can this be resolved? We're not even decrypting, and I don't think there's a way to turn off inspection for specific connections.

The issue seems to exist only from one site that is also running XG v18. The other ones on v17.5.9 are fine, even with inspection turned on at the replication target site - very strange.

How to troubleshoot and fix this?

Anyone else having this issue?

Thanks!

  • Hi,

    try turning the on the web proxy and then create exceptions for the site.

    What restrictions do you have in your firewall rule the VEEAM application or traffic?

    Ian

  • In reply to rfcat_vk:

    Hmm, yeah I guess, but I think my ultimate goal would be to use the new DPI engine (and not have it break things ;) ). The firewall rule just looks at the port number, not the application.

  • In reply to Bjoern Freiherr:

    Hi Bjoern,

    because the backup is a streaming connection, DPI will not be able to touch it and you will need an exception in the DPI setup.

    Ian

  • In reply to Bjoern Freiherr:

    Bjoern,

    Please share the firewall rule used. While the issue is occurring, please take a packet capture on XG.

    Decrypting backups don’t not make sense and I understand how even slower the backup can go if decryption occurs (when it works!).

    Regards

  • In reply to lferrara:

    The rule is very basic, just source IPs, services (using the TCP port), nothing else.

  • In reply to Bjoern Freiherr:

    This is strange as DPI does not scan traffic from WAN to LAN. Check IPS if it is blocking something.

  • In reply to lferrara:

    Oh, really? Wasn't aware of that. But somehow it's doing something.

    I checked all the logs and there was absolutely nothing being denied etc. from the source where I'm having the issue :( That's why it lead me to try turning off the SSL/TLS inspection as it was the last resort of what it could be. I noticed I was rejecting SSL compression and SSL 2.0 and 3.0. I doubt that Veeam would use those, but I set them to allow and not decrypt and turned inspection back on. We'll see if that makes a difference. I don't expect it to.

  • In reply to Bjoern Freiherr:

    So you access via DNAT your Veeam Infrastructur? 

    Or does your Veeam build up the Connection?

    In Log Viewer - TLS, you do not see matching connections of this Client?

    Could you show your TLS Rules? 

  • In reply to LuCar Toni:

    Yes the remote site establishes the connection to the replication target at the main site. I don't see anything logged under TLS for the remote site IP address, which makes sense if inspection only happens on outbound connections.

    I don't have any TLS rules as I'm not doing any decryption currently.

    Still leaves the question why turning off TLS inspection fixes the connectivity issue if it's not even scanning inbound connections.

  • In reply to Bjoern Freiherr:

    There is an Issue still open in XG, which maybe could be also causing this issue.

     Could this be the same as the Camera Issue?

     

    Do you see any packets with source IP of the Veeam Solution? 

     

    Also + Advice to open a Case to get this logged. 

  • In reply to LuCar Toni:

    Related to this topic, I wanted to mention the great post that Michael published:

     I'd suggest to take a look here as well before raising a case.

    If you do end up raising one, please share the number with me.

    Thanks,

  • In reply to LuCar Toni:

    In the firewall logs I do, but not in the SSL/TLS logs.

    I'll call a ticket in next week when I have some time. I can also pretty easily test this so traffic can be captured.

     

    Thanks for your help so far!

  • In reply to Bjoern Freiherr:

    Perfect! Please let us know.

    As I said, DPI should not be responsible for this traffic unless it is a bug.

    Regards

  • In reply to lferrara:

    Hey guys, I opened a case: #9744383

    We've just been testing this with multiple different combinations of settings and nothing but disable SSL/TLS has worked so far. Even when the DNAT firewall rule is set to use the Proxy rather than DPI engine it still doesn't work.

    We upgraded to the latest release of v18 also.

  • In reply to Bjoern Freiherr:

    Hi,

    please upgrade to the v18 SR2 which will enable you to disable SSL/TLS on your specific rules and hopefully overcome your issue.

    Ian