4G Telstra Dongle (Huawei E8372) and disabling NAT

Hi, I have a Huawei E8372 and which is working, but I have the issue of double natting. Telstra has put the codes on the SIM to stop the DNAT but the dongle is still natting the connection. Does anyone have any suggestions on how to remove the nat on the dongle or if there is another dongle I can use instead please?

  • Hi  

    I would request you to contact your service provider for more information.

    You may check the article for Sophos 3G/4G Module – Supported 3G/4G providers

  • Don't have a E8372 at hand to try but I can confirm that a Telstra (rebadged Neatgear) AirCard 320U works with the XG Firewall and the telstra.extranet APN, as I had to get something working for a client yesterday after a rat chewed through their NBN fibre lead-in.

    Got it working by loading the recommended configuration for the device (DHCP), adding the SIM PIN, setting telstra.extranet as the APN and adding AT+CGDCONT=1,"IP","telstra.extranet" as an Initialisation String. Without this last step the WWAN interface would connect using the telstra.internet APN for some reason (possible bug in the connection code maybe?).

    You could try the above steps on the E8372 if it allows for a similar configuration.

    Also worth confirming with Telstra that the GPTEXB3 code has indeed been applied to the service and testing the connection on a PC first. I find that troubleshooting APN-related connection issues is less time consuming on a PC before attempting a connection on a router that has poor or obfuscated logging capability.