Netflix not working despite - Knowledge base is wrong?

I have followed this  https://community.sophos.com/kb/en-us/125061

and still I can't get netflix to work, why? only works when I disable web scanning in the rule number 6

  • What rules do you have above your netflix rule?

    Please post a full screenshot of your netflix rule, not just the top part.

    Ian

  • In reply to rfcat_vk:

    Here they are

      

     

     

  • In reply to l0rdraiden:

    Seems like your "Netflix" object is not correct. Can you show us the content? 

  • In reply to LuCar Toni:

    Here it is, I have added more domains since it wasn't working

     

  • In reply to l0rdraiden:

    I am not able to stream Netflix as well. I have a new install (SFOS 17.1.3 MR-3) that has only one additional firewall rule beyond the defaults. That is the Netflix rule found in community.sophos.com/.../125061. I am trying to stream thru a Roku. I can select Netflix and enter the app with no problems. When I attempt to select a movie, it issues an error msg telling me to try later. Ditto for all Netflix movies I attempted to watch. My rule looks the same as above.

     

  • It looks like KB is wrong, is there an official way to report bugs?

  • In reply to callengodfrey:

    Can you check the logs and see what IP's / websites its hitting and add an exception or add to a higher FW rule?

    Check Web and Application.

  • In reply to M8ey:

    Nevermind, I have no time to troubleshoot bugs that Sophos doesn't even care.

    I have excluded the TV's IPs from any web filtering, since the method described in the KB doesn't work.

    At least they should delete or update the Knoledge base article.

  • In reply to M8ey:

    I would be glad to help out with this problem as long as the folks from Sophos will assist me over the phone. I am a total noob with XG Firewall, having just loaded the software this week. As soon as I ran into this problem I just returned to Untangle and continued to watch Netflix. I can be available most any time.

  • In reply to callengodfrey:

    I got the same error message here.

     

    Since v17 I use the "netflix" FQDN object. With version 17 to 17.1 it works. But since 17.5 there are sometimes problems. 

    For 2 days it worked with the firewall rule "netflix". So sometimes it works, sometimes not. Seems to depend on coincidence.

     

    I think there are some new streaming servers not adressed in the netlix FQDN object, so i think the objects needs to be updated. Hmm

  • In reply to TheBalmasque:

    Would be nice to find any reference on changed objects. Maybe you find something on the netflix page? OR in the logviewer? 

  • In reply to LuCar Toni:

    I filtered the log using my ROKU IP address and then exported it to a CSV file. When I attempted to insert the CSV file into this post, I received an error. No explanation, just the work ERROR.

  • In reply to callengodfrey:

    Please try drag and drop.

    Ian

  • In reply to LuCar Toni:

    Hi,

     

    yesterday i got some time to look in the logviewer. There are several ip-adresses being scanned by the proxy. (Allowed)

    So i added a new IP-Host object "Netflix-IPs". Type: IP-List

    I put in the following ips: 45.57.74.131, 45.57.78.136,45.57.78.141,45.57.75.172,45.57.74.157,45.57.75.175

    Then I put the "Netflix-IP" object in my "Netflix" (same like in the Sophos KB) rule. After that, the movie streaming works. But only for one movie...

    For another movie i had to put in some more adresses... Maybe i should try to exclude an ip-range. Smile 

  • In reply to TheBalmasque:

    Problem solved:

     

    I defined 3 IP-Range objects "Netflix Range 74,75,78" and put it in the destiantion network list. (For all ranges from 45.57.*.100 - 45.57.*.200)

    The network rule is only for my Panasonic TV and no other devices. I hope this works for you too. Cool