SMTPPolicy Configuration parameters validation failed.

hello

 

i got 

<SMTPPolicy transactionid="">
<Status code="501">Configuration parameters validation failed.</Status>
<InvalidParams>
<Params>/SMTPPolicy/DomainList/DomainName</Params>
</InvalidParams>
</SMTPPolicy>

 

and used API (latest) example:

<SMTPPolicy> <Name>Postman.local</Name> <DomainList> <DomainName>Postman.local</DomainName> </DomainList> <RouteBy>Static Host/DNS Host</RouteBy> <DNSHostName>hostname</DNSHostName> <SpamProtection> <SpamProtectionStatus>ON</SpamProtectionStatus> <Checkforinboundspam>Enable</Checkforinboundspam> <Checkforvirusoutbreak>Disable</Checkforvirusoutbreak> <Checkforoutboundspam>Enable</Checkforoutboundspam> <UseGreylisting>Enable</UseGreylisting> <CheckForSPF>Disable</CheckForSPF> <CheckforRBL>Enable</CheckforRBL> <SpamAction>Drop</SpamAction> <ProbableSpamAction>Warn</ProbableSpamAction> <RecipientVerification>WithCallout(Recommended)</RecipientVerification> <RBLList> <RBLName>Premium RBL Services</RBLName> <RBLName>Standard RBL Services</RBLName> </RBLList> <SpamMarker>[SPAM]</SpamMarker> </SpamProtection> <MalwareProtection> <MalwareProtectionStatus>ON</MalwareProtectionStatus> <MalwareScanning>Dual Anti-Virus</MalwareScanning> <AntivirusAction>Drop</AntivirusAction> <NotifySender>Disable</NotifySender> <QuarantineUnscannableandEncryptedContent>Enable</QuarantineUnscannableandEncryptedContent> <DetectZero-dayThreatswithSandbox>Enable</DetectZero-dayThreatswithSandbox> <ScannedFileSize>10</ScannedFileSize> </MalwareProtection> <FiletypeFilter> <FiletypeFilterStatus>ON</FiletypeFilterStatus> <BlockFileTypes> <FileType>Video Files</FileType> <FileType>Audio Files</FileType> </BlockFileTypes> <MIMEWhiteList> <WhiteList>video/msvideo</WhiteList> <WhiteList>video/x-msvideo</WhiteList> <WhiteList>video/quicktime</WhiteList> <WhiteList>application/smil</WhiteList> </MIMEWhiteList> <DropMessageGreaterThan>0</DropMessageGreaterThan> </FiletypeFilter> <DataProtection> <DataProtectionStatus>ON</DataProtectionStatus> <ActionOnRuleMatch>Accept with SPX</ActionOnRuleMatch> <NotifyOnMatch>Enable</NotifyOnMatch> <DataProtectionPolicy>Postal addresses</DataProtectionPolicy> <DataProtectionSPXTemplate>Default Template</DataProtectionSPXTemplate> </DataProtection> <Action>Accept</Action> <SPXEncryption>None</SPXEncryption> <RouteList> <HostName> <routingid>10.198</routingid> <routingorder>0</routingorder> </HostName> </RouteList> </SMTPPolicy>

 

any idea?

when i remove DomainList still got the same.

Verison: SFOS 17.5.8 MR-8

  • Hi  

    I had to manually create an Email address/domain Address Group and add my domain in that first. Once I did it, I was able to use API by calling the Name of the Address group.

    10.201.208.32:4444/.../APIController passwordform="plain">I'mnotwritingmypasswordhere</Password></Login><Set Operation="add"><SMTPPolicy><Name>jjg.local</Name><DomainList><DomainName>postman.local</DomainName></DomainList><RouteBy>DNS Host</RouteBy><DNSHostName>utm.jjg.local</DNSHostName> <SpamProtection><SpamProtectionStatus>ON</SpamProtectionStatus><Checkforinboundspam>Enable</Checkforinboundspam><Checkforvirusoutbreak>Disable</Checkforvirusoutbreak><Checkforoutboundspam>Enable</Checkforoutboundspam><UseGreylisting>Enable</UseGreylisting><CheckForSPF>Disable</CheckForSPF><CheckforRBL>Enable</CheckforRBL><SpamAction>Drop</SpamAction><ProbableSpamAction>Warn</ProbableSpamAction><RecipientVerification>WithCallout(Recommended)</RecipientVerification><RBLList><RBLName>Premium RBL Services</RBLName><RBLName>Standard RBL Services</RBLName></RBLList><SpamMarker>[SPAM]</SpamMarker></SpamProtection><MalwareProtection><MalwareProtectionStatus>ON</MalwareProtectionStatus><MalwareScanning>Dual Anti-Virus</MalwareScanning><AntivirusAction>Drop</AntivirusAction><NotifySender>Disable</NotifySender><QuarantineUnscannableandEncryptedContent>Enable</QuarantineUnscannableandEncryptedContent><DetectZero-dayThreatswithSandbox>Enable</DetectZero-dayThreatswithSandbox><ScannedFileSize>10</ScannedFileSize></MalwareProtection><FiletypeFilter><FiletypeFilterStatus>ON</FiletypeFilterStatus><BlockFileTypes><FileType>Video Files</FileType><FileType>Audio Files</FileType></BlockFileTypes><MIMEWhiteList><WhiteList>video/msvideo</WhiteList><WhiteList>video/x-msvideo</WhiteList><WhiteList>video/quicktime</WhiteList><WhiteList>application/smil</WhiteList></MIMEWhiteList><DropMessageGreaterThan>0</DropMessageGreaterThan></FiletypeFilter><DataProtection><DataProtectionStatus>ON</DataProtectionStatus><ActionOnRuleMatch>Accept with SPX</ActionOnRuleMatch><NotifyOnMatch>Enable</NotifyOnMatch><DataProtectionPolicy>Postal addresses</DataProtectionPolicy><DataProtectionSPXTemplate>Default Template</DataProtectionSPXTemplate></DataProtection><Action>Accept</Action><SPXEncryption>None</SPXEncryption><RouteList><HostName><routingid>10.198</routingid><routingorder>0</routingorder></HostName></RouteList></SMTPPolicy></Set></Request>

    For the sake of simplicity, I called my address group postman.local and selected route by DNS host.

    Hope this helps.