Client authentication agent

Hi everyone.

I have an issue with the "Client authentication agent", after a few minutes that i got connected it disconnected itself and shows me the following message:

its spams me until i get logged and its really annoying.

I really need to know how to fix this problem.

 

Thank you all.-

  • Hi  

    As per the error message, the administrator has disconnected the user.

    Can you please check the authentication logs in log viewer for this specific user and check the message?

    Are you facing this issue with a specific user or any random user?

  • In reply to Keyur:

    Hello Keyur,

     

    i checked the message and it says "administrator disconnected you" and its a random issue for any user.

     

  • In reply to hernan valenzuela:

    Hi  

    Are you using Sophos XG Firewall or Sophos UTM 9 firewall?

  • In reply to Keyur:

    I´m using Sophos XG firewall

  • In reply to hernan valenzuela:

    Hi  

    Can you please check the authentication logs in log viewer for this specific user and check the message?

    I would recommend you to contact technical support and open a service request.

  • In reply to Keyur:

    It is working fine if you installed CAA in administrator account & keep using it as administrator.

    If you installing the CAA in non-admin user account,

    Work Around I did & which worked for us is:

    1. Uninstall the CAA if it is installed in the users profiles.

    2 . Login with an administrator account. Install CAA.

    3 . Copy the Shortcut of CAA in non-admin user's profile (ie: Desktop)

    4 . In the shortcut, ⟹ Rightclick ⟹ properties ⟹ compatibility ⟹ enable run as administrator for all users.

    5 . Provide write permission to the C:\Users\SSAP\AppData\Local\Sophos -  Folder  for the user account. So that user can access this folder which is created in administrator profile

    6 . logout administrator account & login users account.

    7 .  Create a VBScript using a text editor 

     Set WshShell = CreateObject("WScript.Shell" ) 
      WshShell.Run """C:\Users\SSAP\AppData\Local\Sophos\Client Authentication Agent\CAA.exe""", 0 'Must quote command if it has spaces; must escape quotes
      Set WshShell = Nothing


    note : C:\Users\SSAP\AppData\Local\Sophos\Client Authentication Agent\CAA.exe ⟹ change the path as per your environment.
    Make sure it is from administrator user profile;

    Save it as "CAA.vbs" . "" is must while saving.


    8 . place the VBScript in the startup folder:

    %AppData%\Microsoft\Windows\Start Menu\Programs\Startup
    

    Or, alternatively, access the startup folder  by Win+R ⟹ type  shell:startup ⟹  Enter

     
  • In reply to Arun Pradeep:

    This is a workaround. For non-admin, it should work by default, isn't it?

  • In reply to lferrara:

    Yes.  It resolved the issue & the Sophos client login is stable for non-admin users.

  • In reply to Arun Pradeep:

    Hi  

    Thank you for sharing this, it would help fellow community members.