STAS Live User werden in XG nicht angezeigt

Hallo zusammen,

 

folgendes Problem: Ich habe meine STAS Infrastruktur wie beschrieben konfiguriert. Leider funktioniert die synchronisierung der User auf die XG nicht.

Unter dem Bereich Live-User, wird mir nichts angezeigt.

Auf allen 3 DCs habe ich STAS installiert, wobei einer DCs an die XG meldet. Live Users werden mir auf allen 3 STAS Instanzen angezeigt.

Auf dem STAS Client habe ich unter Troubleshooting alle relevanten Tests ausgeführt. Alle gaben "successful" zurück.

 

Ein kurzer TCP dump auf Port 6060 ergibt folgendes:

 

console> tcpdump 'port 6060'
tcpdump: Starting Packet Dump
22:29:08.935585 Port1, IN:  In 00:0c:29:1f:a4:42 ethertype Unknown (0x0012), length 66:
        0x0000:  0000 0800 4500 0027 09b0 4000 8011 4bba  ....E..'..@...K.
        0x0010:  c0a8 1201 c0a8 120a e456 17ac 0013 54c3  .........V....T.
        0x0020:  6731 3100 0007 0436 3637 3700 0000 0000  g11....6677.....
        0x0030:  0000                                     ..
22:29:08.935589 Stack, IN:  In 00:0c:29:1f:a4:42 ethertype Unknown (0x0012), length 66:
        0x0000:  0000 0800 4500 0027 09b0 4000 8011 4bba  ....E..'..@...K.
        0x0010:  c0a8 1201 c0a8 120a e456 17ac 0013 54c3  .........V....T.
        0x0020:  6731 3100 0007 0436 3637 3700 0000 0000  g11....6677.....
        0x0030:  0000                                     ..
22:29:08.935590 Stack.18, IN: IP 192.168.18.1.58454 > 192.168.18.10.6060: UDP, length 11
22:29:38.950838 Port1, IN:  In 00:0c:29:1f:a4:42 ethertype Unknown (0x0012), length 66:
        0x0000:  0000 0800 4500 0027 0b07 4000 8011 4a63  ....E..'..@...Jc
        0x0010:  c0a8 1201 c0a8 120a e456 17ac 0013 54c3  .........V....T.
        0x0020:  6731 3100 0007 0436 3637 3700 0000 0000  g11....6677.....
        0x0030:  0000                                     ..
22:29:38.950841 Stack, IN:  In 00:0c:29:1f:a4:42 ethertype Unknown (0x0012), length 66:
        0x0000:  0000 0800 4500 0027 0b07 4000 8011 4a63  ....E..'..@...Jc
        0x0010:  c0a8 1201 c0a8 120a e456 17ac 0013 54c3  .........V....T.
        0x0020:  6731 3100 0007 0436 3637 3700 0000 0000  g11....6677.....
        0x0030:  0000                                     ..
22:29:38.950842 Stack.18, IN: IP 192.168.18.1.58454 > 192.168.18.10.6060: UDP, length 11


^C
6 packets captured
6 packets received by filter
0 packets dropped by kernel

 

 

https://community.sophos.com/kb/en-us/123154

 

Log des STAS Clients:

ERROR    [0xa88] 17.07.2019 23:41:25 : GETTING (USERINFO) FROM QUEUE
DEBUG    [0xa88] 17.07.2019 23:41:25 : list_remove_head: list is Empty
DEBUG    [0x590] 17.07.2019 23:41:25 : userdb_insert_userinfo: UserInfo Successfully Inserted
DEBUG    [0x590] 17.07.2019 23:41:25 : list_add_tail: first element added
DEBUG    [0x590] 17.07.2019 23:41:25 : dca_insert_userinfo_db: userinfo enqueued in XG Update Queue
DEBUG    [0x590] 17.07.2019 23:41:25 : dca_add_userinfo_dcaclient: DCA Client IO succeded
DEBUG    [0x590] 17.07.2019 23:41:25 : threadpool_finishnotify: Thread ID: 0x590
DEBUG    [0x590] 17.07.2019 23:41:25 : threadpool_finishnotify: Reset Event
DEBUG    [0x123c] 17.07.2019 23:41:25 : userdb_handle_duplicate_userinfo: select query: SELECT * FROM UserInfo WHERE wrkst_ip=='192.168.18.10';
DEBUG    [0x123c] 17.07.2019 23:41:25 : userdb_handle_duplicate_userinfo: User 'lumen.local\tse' found on '192.168.18.10'
DEBUG    [0x123c] 17.07.2019 23:41:25 : userdb_handle_duplicate_userinfo: userinfo matched
DEBUG    [0x123c] 17.07.2019 23:41:25 : userdb_insert_userinfo: matching userinfo found
DEBUG    [0x123c] 17.07.2019 23:41:25 : dca_add_userinfo_dcaclient: CA Client IO succeded
DEBUG    [0x123c] 17.07.2019 23:41:25 : threadpool_finishnotify: Thrad ID: 0x123c
DEBUG    [0x123c] 17.07.2019 23:41:25 : threadpool_finishnotify: Reset Event
ERROR    [0xa88] 17.07.2019 23:41:25 : USERINFO WAITING INFINITE
DEBUG    [0xa88] 17.07.2019 23:41:25 : list_remove_head: last eleent removed
MSG    [0xa88] 17.07.2019 23:41:25 : SSOclient_thread: got userinfo: USER: lumen.local\tse <-> Flags: 5
ERROR    [0xa88] 17.07.2019 23:41:25 : GETTING (USERINFO) FROM QUEUE
DEBUG    [0xa88] 17.07.2019 23:41:25 : list_remove_head: list is Empty
MSG    [0xffc] 17.07.2019 23:41:38 : SSO_client_update_heartbeat: cr_node:10.0.52.254 is_active:0
DEBUG    [0x10cc] 17.07.2019 23:41:45 : threadpool_run: Submitting Function 0x40a830
DEBUG    [0x10cc] 17.07.2019 23:41:45 : threadpool_run: adding function at tail
DEBUG    [0x10cc] 17.07.2019 23:41:45 : list_add_tail: first element added
DEBUG    [0x10cc] 17.07.2019 23:41:45 : threadpool_run: get free thread: ThreadID: 0x590
DEBUG    [0x10cc] 17.07.2019 23:41:45 : dca_enqueue_userinfo: callback submitted
DEBUG    [0x10cc] 17.07.2019 23:41:45 : process_event: userinfo enqueued to dca processor
DEBUG    [0x10cc] 17.07.2019 23:41:45 : threadpool_run: Submitting Function 0x40a830
DEBUG    [0x10cc] 17.07.2019 23:41:45 : threadpool_run: adding function at tail
DEBUG    [0x10cc] 17.07.2019 23:41:45 : threadpool_run: get free thread: ThreadID: 0x123c
DEBUG    [0x10cc] 17.07.2019 23:41:45 : dca_enqueue_userinfo: callback submitted
DEBUG    [0x10cc] 17.07.2019 23:41:45 : process_event: userinfo enqueued to dca processor
DEBUG    [0x590] 17.07.2019 23:41:45 : threadpool_threadproc: New Function added
DEBUG    [0x590] 17.07.2019 23:41:45 : threadpool_get_threadproc: Function 0x40a830
DEBUG    [0x590] 17.07.2019 23:41:45 : threadpool_threadproc: Executing Function 0x40a830
DEBUG    [0x590] 17.07.2019 23:41:45 : dca_filter_wellknown: User 'HELIOS5$' represent Workstation, so Filtered-Out
DEBUG    [0x590] 17.07.2019 23:41:45 : threadpool_finishnotify: Thread ID: 0x590
DEBUG    [0x590] 17.07.2019 23:41:45 : threadpool_finishnotify: Reset Event
DEBUG    [0x123c] 17.07.2019 23:41:45 : threadpool_threadproc: New Function added
DEBUG    [0x123c] 17.07.2019 23:41:45 : list_remove_head: last element removed
DEBUG    [0x123c] 17.07.2019 23:41:45 : threadpool_get_threadproc: Function 0x40a830
DEBUG    [0x123c] 17.07.2019 23:41:45 : threadpool_threadproc: Executing Function 0x40a830
DEBUG    [0x123c] 17.07.2019 23:41:45 : dca_filter_wellknown: User 'HELIOS5$' represent Workstation, so Filtered-Out
DEBUG    [0x123c] 17.07.2019 23:41:45 : threadpool_finishnotify: Thread ID: 0x123c
DEBUG    [0x123c] 17.07.2019 23:41:45 : threadpool_finishnotify: Reset Event

 

Firmware der XG: SFOS 17.5.7 MR-7

 

 

Hat jemand eine Idee, wo ich zur weiteren Fehlerbehebung ansetzen kann?

 

 

  • Wenn du einen Dump auf Port 6677 durchführst, siehst du auf der XG Traffic? 

    Wenn nicht, könnte 6677 blockiert werden vom DC selbst. 

     

     

    Dann schau noch, ob der AD Server korrekt konfiguriert wurde.

    Wichtig ist die Domäne dort. 

  • In reply to LuCar Toni:

    Die Firewall habe ich auf dem DC zu Testzwecken deaktiviert. Traffic auf 6677 vom DC ist vorhanden, wenn auch nur sehr sporadisch. Ca. 30 Pakete pro Minute.

    Bei der Konfiguration des AD Servers fällt mit auch kein Fehler auf. Auf der XG direkt hat der Sync von Gruppen auch prima funktioniert.

  • In reply to Tobias Seitz:

    Ich würde vermuten, dort liegt ein Fehler in der AD Config.

    Zeig mal den AD Server auf der XG.