PureMessage Scanner service terminated unexpectedly

Hi,

I'm getting the following errors constantly in the event log of my Exchange 2010 SP3 Update Rollup 4 CAS/Hub Transport server.

------------------------

Log Name: System
Source: Service Control Manager
Date: 01/08/2014 10:54:16
Event ID: 7034
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: SRV-NL-CAS-01.hammonds-uk.com
Description:
The Sophos PureMessage Scanner service terminated unexpectedly. It has done this 99 time(s).
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
<EventID Qualifiers="49152">7034</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2014-08-01T09:54:16.394227700Z" />
<EventRecordID>140210</EventRecordID>
<Correlation />
<Execution ProcessID="608" ThreadID="14024" />
<Channel>System</Channel>
<Computer>SRV-NL-CAS-01.hammonds-uk.com</Computer>
<Security />
</System>
<EventData>
<Data Name="param1">Sophos PureMessage Scanner</Data>
<Data Name="param2">99</Data>
<Binary>50004D005300630061006E006E00650072000000</Binary>
</EventData>
</Event>

-----------------------

Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 01/08/2014 10:56:16
Event ID: 10010
Task Category: None
Level: Error
Keywords: Classic
User: NETWORK SERVICE
Computer: SRV-NL-CAS-01.hammonds-uk.com
Description:
The server {0821DE67-185A-47A2-9B26-891E850E7255} did not register with DCOM within the required timeout.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10010</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2014-08-01T09:56:16.373215600Z" />
<EventRecordID>140211</EventRecordID>
<Correlation />
<Execution ProcessID="772" ThreadID="7452" />
<Channel>System</Channel>
<Computer>SRV-NL-CAS-01.hammonds-uk.com</Computer>
<Security UserID="S-1-5-20" />
</System>
<EventData>
<Data Name="param1">{0821DE67-185A-47A2-9B26-891E850E7255}</Data>
</EventData>
</Event>

----------------------

They always show up together and have only started appearing since installed Update Rollup 3 and 4 for Exchange 2010 SP3.  Puremessage is version 3.1.3.

Around the same time I also get the following in the Application event log:

--------------------------------------------

The execution time of agent 'PmE12Transport' exceeded 90000 milliseconds while handling event 'OnRoutedMessage' for message with InternetMessageId: 'Not Available'. This is an unusual amount of time for an agent to process a single event. However, Transport will continue processing this message.

&

Failed to connect to the PureMessage scanner service while processing message '<AB5D944BC1CC7F458FB7FFE8F4C9463E27E35EDC@SRV-NL-MBX-01.hammonds-uk.com>' (error: '0x80080005')

--------------------------------------------

Any help would be great.

Thanks!

:52363