Wordpress Permalinks %postname%

Hi there,

as for now I am publishing a wordpress blog via Sophos UTM Webserver protection. I am redirecting https://blog.domain.de/ via SNI to my real server https://ip:8443/

That'll work just great (rewriting html and cookies), when using the wordpress permalink scheme simple which means the urls will look like https://blog.domain.de/?p=140

For reasons of using caching plugins and for prettyness I do want to use the permalink scheme %postname%, which means urls will look like https://blog.domain.de/super-intresting-post

But if I do that the webserver protection would need a site path rule for every single post and page and tag and category I use within my wordpress blog, which makes it pretty much unusable.

Is there any possible configuration (site path rules, request redirection, something else) which I could use to solve this issue?

Thanks in advance,

Patrick

  • What exactly isn't working? It should be enough to just use the default site path route created for "/" for this to work.

    Just to make sure:

    • Create a real webserver for IP address "ip", type HTTPS and port 8443
    • Create a virtual webserver for domain blog.domain.de and type HTTPS
    • Select the real webserver for this virtual webserver
    • Enable the virtual webserver

    That's it.

  • Hallo Patrick,

    I'm confused by your use of SNI and of a numeric IP in a redirect.  Normally, multiple Virtual Servers can listen on port 443, but the only one that answers a browsing request is the one for blog.domain.de that shows the certificate for your domain.  The Real Server associated with this Virtual Server does not need to do HTTPS although it can.  What are you doing differently?

    Cheers - Bob

  • In reply to ewadie:

    Well that's about exactly what I did. I am running 9 services like mail.domain.de, blog.domain.de, cam.domain.de, ....

    All are running great except the blog. I will try to collect some log entrys and error messages and post it in reply to Bob below.

  • In reply to BAlfson:

    Hi Bob,

    yes. I know. That might sound strange. Let me try to explain to you what I am doing with a table.

     

    That's the reason why I use SNI (with Let's Encrypt).

    But nevertheless that does not explain why the wordpress blog is not working as expected.

    I tested the following settings.

    1. wordpress permalinks simple (?p=140) - works
    2. wordpress permalinks %postname% - does not work
    3. wordpress permalinks %postname% with site path routing for one blog post - does not work either.

    It looks like the utm might not be the problem... :(

    I will keep you posted.

  • In reply to Patrick Hener:

    Well nevermind. I forgot AllowOverride All, and Options FollowSymLinks for the Directory Config in Apache2