PPTP Error 619 from WinXP

Hello All! 

I have tried to set up a PPTP to be able to connect to my private network from work. I can not get it to work nomatter what I do. I get error 619 at the client after it has tried to verify the username and password for quite some time. I have trie to connect from the internet and from inside my LAN both with WinXP. I have tried different types of passwords and with different strenght of the encryption. From the inside LAN I allow any kind of traffic to any destination. From the Internet I dont accept any connections.

The livelog in Astaro reads like following:

Nov  9 09:23:03 fw01 pppd[9559]: pppd 2.4.0 started by (unknown), uid 0
Nov  9 09:23:03 fw01 pppd[9559]: Using interface ppp0
Nov  9 09:23:03 fw01 pppd[9559]: Connect: ppp0  /dev/ttyp0
Nov  9 09:23:33 fw01 pppd[9559]: LCP: timeout sending Config-Requests 
Nov  9 09:23:33 fw01 pppd[9559]: Connection terminated.
Nov  9 09:23:33 fw01 pppd[9559]: Exit.

Does anybody have an Idea what to try? 

Thank you in advance!!

Hakan
  • Don't know much about XP. First thing I usually try when troubleshooting is that the host is reachable. You many need to turn on ICMP temporarily. If reachable, then try to use "telnet host 1723" to see if you can get a TCP socket connection to the host. If you are behind a LAN then it may be the firewall/proxy not handling the protocol 47 (GRE) stuff.

    Check client setup:

        http://support.real-time.com/windows/vpn/windows_xp_vpn.html

    Make sure CHAP2 is enabled. Etc.

    The 619 errors I rx'd on Win 2k were usually due to password problems... I think. Though could be many other things.

    Hope that helps.
  • In reply to loudman:

    I have the same problem i w2k...error 619 when trying to connect from my laptop to my FW. on vpn.

    I dont think this is a password problem!

    Anyone??  Smile
  • In reply to Raptor34:

    hello,

    we have the same problems with clients (W2k/XP) behind a ASL 3.211 and to an ASL3.211

    look at this from the logs:

    > pptp_nat_expected: we have a connection!
    that looks good with the correct IP`s

    > tcp_help: pptp packet too short
    > tcp_help: entering
    > tcp_help: Not touching dir REPLY at hook POSTROUTING
    > tcp_help: entering
    > tcp_help: Not touching dir ORIG at hook PREROUTING

    what means this????

    Thank`s for help

    Torsten Schuchort
  • In reply to tschuchort:

    I solved my problem concernig the 619.

    First of all I thought it has something to do with capital letter passwords as you can read earlyier in this board.

    But the final problem was that I connected from a University Subnet which blocked the GRE protocol on port 47. So might wanna check that can access the www via port 47 from your work aswell.

    Apparently another problem is that some NAT devices between you and the WWW cant translate GRE properly.
  • In reply to matbehns:

    Hello, tschuchort 

    you may have tried this already - have you enabled Roadwarrior PPTP access? I realize it is designed for incoming PPTP connections, but I was getting the EXACT same error messages as you  When I enabled Roadwarrior PPTP, I was able to connect to my VPN at work. 

    If this helps, or you want further config info. please respond.

    Regards,
  • In reply to mcrabbitman:

    Quick clarification:

    I am using Astaro at home. (My W2K workstations are MASQ'd thanks to ASL)

    I am connecting to a W2K PPTP VPN server at work.

    I was unable to connect from home to work until enabling Roadwarrior PPTP on my ASL box at home.

    Seems strange to me - I thought RW PPTP was for inbound connections only.
  • In reply to mcrabbitman:

    I also had this problem with my XP pro workstation.  I was able to eliminate it (almost) by changing the redial options in the VPN connection properties.  It seems that if you just keep retrying eventually it connects.  I set my redial tries to 50 and time between to 1 sec.  Usually after 3 or 4 tries it connects.  Also in the networking tab set PPTP instead of automatic, this also helps the number of retries.
  • In reply to viix:

    I know this thread is solved but thought I would throw in my 2 cents.  I had this problem and found that Windows XP SP 2 firewall was the culprit.  I went into services and disabled it, rebooted and everything was fine.  It had a glitch that was making it start 1/2 way, even though I had it set to off anyway. I am running Trend Internet Security 2005 for firewall and it works well.
    Good luck!