Reset or reflash RED10 like an APxx

Today one of our RED Devices suddenly stopped working (no firmupdate or something else - just PLOP -> dead).

Now just the power LED (and the LAN Led if connected) are on and nothing happens. I disconnected everything from the RED, waited a hour and plugged in just the powersupply but nothing happens - just the power LED is on.

According to the blinkcodes sheets the unit isn't booting anymore.
Is there a way to reflash a RED just like an APxx or is there an other way to 'hardreset' such a unit?.

Regards
Manfred

Btw. Best thing about it is, that the warranty ended a month ago .. but that so typical for electronic devices.
  • Hi, Manfred,

    This just happened to one of my customers.  Contact Astaro support.

    Cheers - Bob
  • Hi Bob,

    I already contacted the support with an RMA request but they denied it and told me to contact the sales department as I asked for a good will solution. I understand that there must be rules/deadlines but I hoped on a little good will or accommodation (I don't know the correct word for 'Kulanz').

    I will contact my reseller tomorrow and see if he can do something else than selling me a new device :-).

    Regards
    little angry Manfred ;-)
  • In reply to Hallowach2:

    Does the device pull an IP address from DHCP?  If so... here's a technique I've used to reset one that went awry once (taken from a combination of support info and things I did):

    There is one way to completely blow the configuration from the RED and force it to go out the provisioning server to pull a new config, as just using the unlock code may not work since the RED always goes back to the its previously connected ASG and if it finds that, it will be happy and not go out to find a new config.

    The way I have it setup here is I just created a new interface on a spare NIC on our Astaro. Then create 2 PF rules:

    1.) NETWORK -- ANY -- RED.ASTARO.COM -- AlLOW
    2.) NETWORK -- ANY -- ANY -- DROP

    You could do it by the IP the RED gets as well but we just do so many here I found it easier to just create a new network for our lab.

    Then just plug the REDs WAN port into that interface and let it sit, watch the PF log and watch it drop a few times then it will be back to its factory state and will go out to the provisioning server next time.


    --- If it's not pulling an IP or trying to "phone home" ... there's probably a way to reflash it using that tool that was posted in the Wireless Forum, but you'd need a firmware file -- if you've got nothing to lose you could try to find the firmware file on your ASG installation. -- do this at your own risk.  I did a cursory search on a local ASG for anything resembling a firmware file for a RED and found nothing -- found the wireless AP firmware though.

    Barring all that, though... it may not even be possible to re-flash it -- it may be "dead."
  • From what I understand, Rev.1 cannot be reflashed.

    Cheers - Bob
  • In reply to BAlfson:

    You may be right.  I did find something that looks like a Rev. 2 flash image over at http://www.astarosupport.org/Downloads ... but I'm not sure that's what it is.
  • Hi Bruce,

    thank you for your detailed suggestions - but the device does not pull an IP address (in fact there is zero traffic on the interface - tested it with an old autosensing hub and wireshark) - I think that part of the device is dead. Maybe I can use it as a 250eur-unmanagedfourportswitch.. ;-)

    I've also found that astarosupport.org site and used the 'redalert.exe' tool and found the bin file - but i think thats for a rev.2 device. But I will remember the redalert tool to check the RED-ability of a problematic site next time :-).

    What I've found out is the RED v.1 seems to be based on something that is called Intel IXP435 platform. I found a manual the looks very close to the ingrediences of my RED but I can't understand enough of the content so that doesn't help me.

    Regards
    Manfred
  • In reply to Hallowach2:

    Sounds like someone let the magic smoke out... probably time for a replacement, unfortunately Sad

    Note that you can purchase a 2-year warranty extension for a new unit rather inexpensively, and it also gives you next-day advanced replacement -- check with your reseller (I know this is available in the U.S. -- many of my customers buy it, but not sure of your locale and what is available there).
  • Yeah - I think the magic smoke (nice word - didn't know that one) has left the building. 

    As the device failed and support rejected the rma request, I remembered the line in the offer to buy additional warranty for small bucks - a kicked myself somewhere where it hurts badly that I didn't buy it. If I had bought it the device would never ever have failed.

    Anyway - I think I will buy a new one .... maybe with extended warranty this time ;-)

    Regards
    Manfred
  • In reply to Hallowach2:

    Ah... I realized you were in Germany (or thereabouts)... in reference to the origin of the "magic smoke" reference --- when something shorts out, or blows out, due to overload, etc. -- that's the "magic smoke" that's escaping the device.  Smile
  • I had found another nice translation for 'magic smoke': 
    "A mythical substance which is supposededly vital to the functioning of electronic equipment. Therefore when the magic smoke leaks out, the equipment stops working."
  • In reply to BrucekConvergent:

    You may be right.  I did find something that looks like a Rev. 2 flash image over at http://www.astarosupport.org/Downloads ... but I'm not sure that's what it is.


    I uploaded that file for Rev2 devices and Alan posted it, it can be used with the Wireless AP flash tool for Rev2/3 RED10's.
  • In reply to peterkieser:

    Is/will there be an image for Rev. 1 REDs? We have two bricked Rev. 1's.
  • I was told that Rev.1 units cannot be flashed.  Maybe you could use them for bookends? Wink

    Cheers - Bob
  • In reply to quasar3c279:

    Is/will there be an image for Rev. 1 REDs? We have two bricked Rev. 1's.


    Doubtful, the method for flashing them requires dis-assembly at present Surprise
  • In reply to peterkieser:

    OK - as my 'defective' RED is out of warranty an alredy replaced by a new one I would give the disasseble method a try (if disassemble is meant physicaly dismount the cover/case).

    Regards
    Manfred