UTM 9.601 - RED issues!

Since upgrading all our customers to 9.601, a bigger part of them are complaining about RED's re/disconnection in a no-pattern way.

It started for all of them just the night we upgraded to 9.601, and they all are on different ISP's and located different places around the country.

Been with Sophos support for 2 hours today, and now they escalated it to higher grounds.

Will return with an update....

Suspicious entries in the log - but all connected REDs do this before connection:

2019:03:06-15:15:38 fw01-2 red_server[17509]: SELF: Cannot do SSL handshake on socket accept from 'xxx.xxx.xxx.xxx': SSL connect accept failed because of handshake problems

2019:03:06-15:15:46 fw01-2 red2ctl[12420]: Missing keepalive from reds3:0, disabling peer xxx.xxx.xxx.xxx

I know the last line is written before the tunnel disconnects, because there was no "PING/PONG" answer...

One customer has 2 x RD 50, one 1 100% stable and the other fluctuates in random intervals - we replaced this with a new RED 50, but the same thing occurs.

  • In reply to BAlfson:

    ...it seems to be a timing issue... When i disable the RED for 5 minutes on the UTM it works fine shortly after reenabling it again.

    No 'stabelizing peers' and such in the log - just 'tunnel -up' -> PING PONG, PING PONG

    Tunnel is stable until the DSL-Line does its 24h reconnect then.
    This brings it out of 'sync'...

    Then until i disable and reenable the RED i can see -> boot -> stabelizing peers -> 5 ICMP Packets go through the tunnel (yay!) -> unstable peers -> reboot (oh no!)
    ... over and over again ...

  • In reply to William Fraley:

    Hi all,

     

    Sorry for the delay, been on vacation for a week - my nerves cound not stand it anymore ;-)

    I also did the "cc set red use_unified_firmware 0" before I left, and can confirm it solved ALL MY ISSUES.

    Had one customer with two RED 50s, one was very unstable and another was completely offline, we have setup temporary SG115's with IPSEC just to keep the customer running.

    After I have disabled the new unified firmware, both RED 50's are back and 100% stable!

    Sophos Support claims that there are no issues with this, but please, keep refering to this community string, so they can see, that there actually are problems.

    I have enabled RED debugging with suppoort, and inserted USB key for debug logging into the red 50, but nothing important was shown.

    We have the unified firmare enabled with several other customers, which have no issues with it, so it's odd, I think it looks like some ttl, ips issues, with the different ISP.

    EDIT:

    Some other issues have been located, and it seems like Sophos it looking into it:

    community.sophos.com/.../9-601-5-update-killed-red-50-home-site-dns-resolution

  • We had the same issues, same errors with RED-50's after updating to 9.601, we have two, one worked fine the other would randomly disconnect our users. Tech Support rolled back firmware on both Red's and so far so good.

  • Just a quick update from support, which I got back today:

    This issue is going to be resolved in 9.602 which is the upcoming firmware. But I do not have any ETA for that yet. You may follow our community thread: community.sophos.com/.../utm-blog for the release notes and update information.

  • Reporting same issues here. (2) RED50s in our setup. One in same USA state as main UTM, but different ISP. One in Hyderabad, India

    Both were working fine after upgrade to 9.601 on 2019-03-10.

    Then, as of 2019-03-30, the USA RED50 dropped offline. Troubleshooting the issue showed all of the same symptoms as reported here.

    Log:

    2019:03:30-19:51:23 astaro red_server[11907]: A34XXXXXXXXXF19: command '{"data":{"key1":"GwQ1b43erVLU4RzintYPM\/T1lczqkZWvfag7yHSQBVo=","key_active":0},"type":"SET_KEY_REQ"}'
    2019:03:30-19:51:23 astaro red_server[11907]: A34XXXXXXXXXF19: Sending json message {"data":{},"type":"SET_KEY_REP"}
    2019:03:30-19:51:24 astaro red_server[11907]: A34XXXXXXXXXF19: No ping for 30 seconds, exiting.
    2019:03:30-19:51:24 astaro red_server[11907]: id="4202" severity="info" sys="System" sub="RED" name="RED Tunnel Down" red_id="A34XXXXXXXXXF19" forced="0"
    2019:03:30-19:51:24 astaro red_server[11907]: A34XXXXXXXXXF19 is disconnected.
    2019:03:30-19:51:24 astaro red_server[4803]: SELF: (Re-)loading device configurations
    2019:03:30-19:51:25 astaro red2ctl[4813]: Overflow happened on reds2:0
    2019:03:30-19:51:25 astaro red2ctl[4813]: Missing keepalive from reds2:0, disabling peer 24.x.y.63
    2019:03:30-19:51:28 astaro red2ctl[4813]: Received keepalive from reds2:0, enabling peer 24.x.y.63
    2019:03:30-19:51:40 astaro red2ctl[4813]: Missing keepalive from reds2:0, disabling peer 24.x.y.63

    2019:03:30-19:52:25 astaro red_server[12523]: SELF: Cannot do SSL handshake on socket accept from '24.x.y.63': SSL connect accept failed because of handshake problems

    2019:03:30-19:53:06 astaro red_server[12528]: SELF: Cannot do SSL handshake on socket accept from '24.x.y.63': SSL wants a read first

     

    further on:

    2019:03:30-19:58:52 astaro red_server[13844]: SELF: New connection from 24.a.b.162 with ID A34XXXXXXXXXF19 (cipher RC4-SHA), rev1
    2019:03:30-19:58:52 astaro red_server[13844]: A34XXXXXXXXXF19: connected OK, pushing config
    2019:03:30-19:59:23 astaro red_server[13844]: A34XXXXXXXXXF19: No ping for 30 seconds, exiting.
    2019:03:30-19:59:23 astaro red_server[13844]: id="4202" severity="info" sys="System" sub="RED" name="RED Tunnel Down" red_id="A34XXXXXXXXXF19" forced="0"
    2019:03:30-19:59:23 astaro red_server[13844]: A34XXXXXXXXXF19 is disconnected.

    It then went silent.

    The LCD screen shows unit going through a similar procedure reported above by Twister5800:

    Network Setup
    ID A34xxxxxxxxxxxx
    Network Setup
    Try wan1
    Try wan2
    Firmware update 1/6 downloading
    Try Prov. Server
    Network Setup
    Try wan1
    Try wan2
    Firmware update 1/6 downloading
    Try Prov. Server
    Shutting down…

     

    We replaced the problematic RED50 with a backup RED10 and it is stable thusfar. Not sure if the RED10 uses the Unifies firmware or not? I checked our config from the console and it does show "red use_unified_firmware=1"

    We have no issue so far with the India RED50 unit. Keeping our fingers crossed and waiting for the new firmware.

  • In reply to garth1138:

    Hi everyone,

     

    we have the same exact behaviour with one of our RED50, started exactly after the update to 9.601-5. Strangely we saw that the disconnects only happend during office hours, apperently without much traffic the RED was stable...
    We found a different and hopefully supported workaround, although I do not understand, why it works.

     

    Someone told us that sometimes the RED does not get the new firmware correctly, and you would have to force a firmware update. Either by changing some settings on the RED, forcing a reboot, or - his suggestion - changing the MTU on the RED interface to 1400 until the firmware is downloaded.

    I did that - our RED has two used interfaces with different VLAN configurations (one for data, one for VOIP network). I set the MTU on the data interface to 1400, and there were no more disconnects. I thought that now I can go back to default, so I swiched the MTU back, and the disconnects started again. I then tried different MTU values down to 1450, without success. Since a week now, we are at 1400, and not one disconnect since then.

     

    Maybe this is not at all related to the RED bug, but since it started with the update... I will see when the patch is applied - if I still cannot go back to the default MTU, there was another problem. But I still wanted to share this, since it is easier to change the MTU then changing something on the console...

     

    Regards,

     

    Tobias

  • In reply to _Tobias_:

    Hi All,

    Just a quick update, had this issue on a RED 15w today in a remote site office connected to a UTM SG330 running 9.601-5.

    Receiving logs as;

    2019:04:03-12:44:54 uaejltfw red_server[7052]: SELF: Cannot do SSL handshake on socket accept from 'hidden': SSL connect accept failed because of handshake problems
    2019:04:03-12:45:31 uaejltfw red_server[7066]: SELF: Cannot do SSL handshake on socket accept from 'hidden': SSL wants a read first

    I tried disabling the RED tunnel and waiting for the reconnect, then enabling it again - no success.

    I then did as Tobias stated above and changed the MTU on the interface to 1400 - no success yet.

    I then disabled the RED tunnel again, then re-enabling it again - SUCCESS.

    So it looks like the MTU 1400 change fixed it for me after the RED tried to re-connect after a timeout.

    Please note, I have NOT disabled the unified firmware in the shell as suggested above, this was going to be my last resort.

    Kind Regards,

    James.

  • In reply to somi:

    I have had the same issues described.

     

    I was issued an RMA and got a new RED50 box.

     

    it bricked again within 12 hours.

  • Hi,

    we have the same problem but a little bit different ;)

    We have two SG135 Firewalls in H/A Cluster mode. The RED Connection is only DOWN when we do a takeover from Master to Slave.

    our workaround is to switch back with a second takeover back to the first Firewall again where the RED is connects again to our SG135.

    we opened a Case, i hope 9.602 is available soon...

    greetings from Austria
    Greg

  • In reply to _Tobias_:

    Hi Tobias

     

    Had this exact problem yesterday after updating to 9.601-5 the single RED 50 that was connected to the appliance started flapping. The appliance has several RED 10 and RED 15's connected, none of them had the problem.

     

    Fortunately I stumbled on this article, so it was a quick fix. What did it for me was setting the MTU to 1400. This solved my problem immediately. Thanks for posting.

     

    I must say I am slightly shocked that this known problem hasn't been fixed by Sophos. Very frustrating!

     

     

    Ivan

  • In reply to somi:

    Hello Bob,

    i am trying to connect a RED 15 to our UTM with 9.6.01 Firmware (SG115) the first time now and get the same error now:

    SELF: Cannot do SSL handshake on socket accept from 'xxx.xxx.xxx.xxx': SSL connect accept failed because of handshake problems.

    Do you know when Sophos will fix this and release a new Firmware fot UTM and RED?

    Regards, Reinhold

  • In reply to dlohnier:

    Hallo Reinhold,

    Did you try James Stoy's solution above - switch to MTU1400 and disable/enable the RED?  If that didn't work Sophos may want to RMA the 15.

    Cheers - Bob