Cable Modem + DHCP + HA = Not working

We have two 220's setup as a hot standby HA set.  The T1 link has been working fine.

Recently we decided to add a backup Internet link and had a cable modem installed from Cox Communications.  I setup the new link, but I cannot get DHCP to configure an IP address when it is connected to the 220's.  I have the cable modem plugged into an HP switch, along with port eth4 from the 220's.

However, if I plug the cable modem directly into 1 of the 220's (the active one), it will get an IP address and route packets.  But as soon as I connect it through the HP switch to both 220's, DHCP stops working.

I also tried plugging in a laptop to the cable modem and that also works.

I have all of the used ports on the 220's connected to the same HP switch with static VLAN's setup.  Here's a list of the ports on the 220's and what they are used for:
eth0: LAN
eth1: T1
eth2: DMZ
eth3: HA
eth4: New Cox link
eth5-7: not used

I've tried looking through the logs, but I haven't found anything that seems useful.
  • That sounds like there's a glitch in the HP switch config, doesn't it?
  • In reply to BAlfson:

    Yes it does.  Since my last post I've plugged the two 220's and the cable modem into a little linksys switch, just to eliminate the HP switch as the problem.  I got the same result.

    Here's about all I can find in the logs:
    2009:05:04-17:11:43 astaro-2 dhcpc-sh: DHCP client not running - starting now...
    2009:05:04-17:11:43 astaro-2 dhcpcd[8798]: broadcasting DHCP_DISCOVER
    2009:05:04-17:12:43 astaro-2 dhcpcd[8798]: timed out waiting for a valid DHCP server response
    2009:05:04-17:12:43 astaro-2 dhcpc-sh: Sleeping 60 seconds
  • In reply to jimd:


    is it a gigabit switch?
    Please try a cross cable to connect Modem to switch or if it is already a cross cable try a normal one.

  • In reply to maygyver:


    I actually use Dell switches but occasionally see similar symptoms.

    On the Dell switches (3024 & 3324) you have to join the port to the VLAN and also choose a default VLAN for the port.  This needs to be the port over which DHCP will pass - never quite got to the bottom of why since it as so easy to rectify.  Might be worth a shot as both the HP and Dell may ell have the same Chinese firmware Smile

    May be a red herring but offered on the offchance !
  • In reply to Bridport:

    Bet I can tell you why....

    DOCSIS cable modem's only permit/bridge the FIRST mac address they see to request a DHCP ip addy from a dhcp server, if they are only configured for 1 CPE. 3 CPE would permit 3 mac addreses.

    I had this EXACT same issue when using a Cisco 2924XL switch, and it was because of this:

    Switches have MAC addresses on them. As soon as the switch port is active, the cable modem sees the MAC of the switch, and nothing else will ever get a DHCP address.

    You will need to confirm with your provider the number of CPE that the cable modem is configured for, and ask them which MAC address they see in the modem.

    Your other option, albeit horrible, is to use a hub, since they are dumb and do not have MAC adddresses.
  • In reply to ReD-MaN:

    That MAC address on the switch makes sense and explains what I'm seeing.  For now I have put an old Linksys firewall between the cable modem and the 2 Astaro's.  It's not great but it works.  At least the cable modem only sees the 1 MAC address.
  • In reply to jimd:

    I'm bumping this thread again because I still have the same problem and I'm wondering if anyone else has tried this.

    Since my last post I've replaced the HP switch with a Cisco SG300.  That gave the same result - no IP address.

    I also tried it with a dumb Netgear FS605 switch, which as far as I can tell, doesn't have a MAC addrsess.  In that configuration, the the ports going to both 220's flash continuously about 2 times per second, and the 220's never get an IP from the Cox DHCP server.  I'm wondering why both 220's seem to be talking to the cable modem at the same time.

    For now I'm sticking with using a cheap firewall/router between the 220's and the cable modem.
  • a dumb Netgear FS605 switch, which as far as I can tell, doesn't have a MAC addrsess
    All switches have mac addresses on each port, otherwise they wouldn't know which data needs to go to which port (arp table).
  • What ASG version do you use?

    Maybe your Cable Modem doesn't like, that both nodes have
    the same MAC address. You can disable the Virtual MAC
    address feature via command line as root:

    /usr/local/bin/confd-client.plx set ha advanced virtual_mac 0

  • In reply to da_merlin:

    These are 220's running 8.202.  But the same problem has been true going back several versions.
  • Jimd, are you saying that da_merlin's suggestion did not resolve your issue?

    Cheers - Bob
  • In reply to BAlfson:

    No.  I haven't tried his suggestion yet.  Have to get back into the customer office to try it.
  • You should setup VPN to save yourself the travel.
  • Just to close out this thread - we ended up getting a static IP from the ISP to get around the DHCP problem.  We never did figure out what was wrong.