Help with IPv6 on new ISP

 

Hopefully I haven't redacted too much info above...

Basically I've changed ISPs, and I can't get my UTM to:

  1. forget the old Delegated Prefix from my previous ISP (2001::/56)
  2. recognize the /56 or /64 assigned by my new ISP and allow prefix delegation using the new assigned range (2401::/56 or /64)

At the moment I get a single global unicast assigned to my WAN and that's it.  I've tried fiddling with the renumbering tab, but I'm not sure how that would work given I haven't received the /56 or /64 subnet on the WAN connection.

If anyone can give me some advice, I'd appreciate it!

  • Hello Charlie,

    Would you try deleting the IPv6 configuration(only if it's feasible) and reboot the appliance and configure the new one from your ISP? That should clear the old delegated prefix and should be able to recognize the new mask.

  • In reply to Jaydeep:

    When you say “delete”, do you mean just turning off the IPv6 globally, rebooting, and re-enabling? I have tried this without success....

  • In reply to Charlie E:

    Yes, I meant turning off the IPv6 globally. You should access the UTM as root and then enter Confd command-line client using cc and then enter ipv6 which should give you the configuration option for IPv6 from there. It would look something like this:


    From here, you should try to configure the new prefixes and see if that takes place in GUI or not. Hope this helps.

  • In reply to Jaydeep:

    Sorry, but the old delegated prefix remains, but is not configurable from the Confd command-line client, as far as I can see.  The prefixes@ option is for managing the internal prefix advertisements; not for resetting or deleting the delegated prefix.  I've turned the IPv6 on and off from the command-line but that's about all I can do there.

    Does anyone know where that delegated prefix is stored?  Perhaps I can delete the config and force it to refresh??

  • In reply to Charlie E:

    Hi,

    you need to delete all your DHCPv6 servers, remove the information from the RA tab, then disable IPv6 on the network tab and the menu.

    Make sure you have not configured your interface with a static IPv6 address.

    Power off the UTM, wait a short time and them start over, power on, enable IPv6 on the networks menu, then enable IPv6 on your WAN interface. Hopefully all will work from there?


    Ian

  • In reply to rfcat_vk:

    Yeah, no joy.

    I’ve got no DHCPv6 configured; and no prefix advertisements configured. I turned off IPv6 globally; shutdown for a few hours, turned off the modem too.

    Booted up, turned on IPv6 and immediately the old delegated prefix showed up even before the WAN IPv6 configured itself.  The old delegation is clearly stored somewhere in the config, and I’m just guessing that it’s blocking the new delegation coming through from my ISP.

    There’s gotta be a config file to delete or a global IPv6 reset (outside a clean install)?

  • In reply to Charlie E:

    One last suggest, try changing the WAN interface type, but experience tells me this will not work.

    Ian

  • In reply to rfcat_vk:

    It didn't work, however:

    Had a brainwave overnight and figured I could try using a spare, unused interface. 

    1. So, started from scratch with IPv6 off, setup the new interface - OK. 
    2. Enable IPv6... connectivity NONE.  D'oh.
    3. Manually configured an IPv6 address inside the ISP assigned /64 - accepted the settings but no connectivity. 
    4. Switch back to dynamic IPv6, turn IPv6 off and on again... bingo, it's up (although the IPv6 address detected at ipv6-test.com does not match the address displayed on the UTM).
    5. Still no delegated prefix, so manually added Prefix Advertisements to the UTM matching the delegated prefix from my ISP... IPv6 address appear on my devices. 
    6. Retest - 10/10 connectivity on test-ipv6.com.  ping -6 also working. :)

    So ultimately didn't get the prefix delegation working, but worked around it.  I may go back and do DHCPv6 manually, but we'll see.  Overall I get the impression IPv6 is still 'beta' on UTM, and from what I've read, maybe XG too. 

    Thanks everyone for your help.