Comcast Business IPv6

OK, the more I learn about iPv6, the more confused I get. Comcast Business tells us on our account page that our IPv6 Delegated Prefix is a /56 that looks like:

2001:0db8:2468::/56

But when I turn on IPv6 on our Sophos UTM, it tells me this:

Native over External (WAN): xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx
Subnet: 2001:0db8:2468::/64
Delegated Prefix: 2001:0db8:2468:20::/59

Does that make sense? Note that the UTM tells me I have a /59, not a /56, for the delegated prefix. And if the delegated prefix starts with 2001:0db8:2468:20, then how can the subnet start with 2001:0db8:2468:0000 ?

If I want the UTM address on the IPv6 LAN to be the first address in the range, do I set the address to 2001:0db8:2468::1 with a netmask of /64, or 2001:0db8:2468::1 with a netmask of /56, or 2001:0db8:2468:20::1 with a netmask of /59? Or is it something else? I will admit that I've tried all three, but I haven't yet been successful in getting IPv6 to work on our network. Can anyone help?

  • Replying to myself to correct an error in my previous message. If the /59 delegated prefix starts with 2001:0db8:2468:20, then the full fourth group in the address is "0020", not "2000", as in "2001:0db8:2468:0020::/59". Nonetheless, the assigned subnet of 2001:0db8:2468:0000::/64 is not within the range of the /59 delegated prefix. It is, however, within the range of the 2001:0db8:2468::/56 delegated prefix. So I still don't understand what's going on.

  • In reply to BruceGiles:

    The UTM appears to be reporting what it sees in the network responses spoken that would indicate that Comcast has setup your account incorrectly in their DHCP server.

    Ian