The Sophos Community will be offline for scheduled maintenance this Saturday, May 27th, at 13:00 UTC for approximately 1 hour. Apologies for any inconvenience caused.


"Wanna" ransomware outbreak. Please see this Sophos article for advice on how to protect your organization. Immediate action recommended.

Sophos UTM 9.5 released - let's share experience :-)

https://community.sophos.com/products/unified-threat-management/b/utm-blog/posts/utm-up2date-9-500-released

 

What’s new in UTM 9.5?

  • WAF Enhancements

WAF URL Redirection gives you the ability to redirect traffic for a WAF protected URL to a different backend system or URL.

Configure minimum allowed TLS version to improve security.

WAF protection and authentication policy templates were added for common Microsoft services for protection and authentication.

True File Type Scanning to be able to block uploads based on MIME type.

WAF Proxy Protocol Support to use the client IP info inside the ProxyProtocol header to make policy decisions and improve logging.

  • Sophos Sandstorm

Datacenter location selection for Sophos Sandstorm without relying on DNS based location detection.

Scan exceptions for Sophos Sandstorm to exclude specific filetypes from being sent to Sophos Sandstorm analysis.

  • REST API

RESTful API to configure Sophos UTM 9.

  • Base System

Certificate Expiration Notification 30 days before expiration date via WebAdmin and e-Mail to be able to react early on certificate renewal.

Support Access with SSH is extending the existing Support Access feature.

64-bit PostgreSQL Database to generate reports with big datasets faster. Existing database will be migrated without loosing any data.

SNMP Monitoring of full filesystem to integrate UTM filesystem monitoring in regular SNMP based monitoring solutions.

Download all UTM logs in a single archive.

Up2Date Information

News

  • 9.5 Release
  • Features
  • WAF URL redirection
  • WAF configurable TLS version
  • WAF true file type detection
  • WAF templates
  • Sophos Sandstorm configuration of data center
  • Sophos Sandstorm file exceptions
  • RESTful API to configure UTM
  • AWS CloudWatch Logs Agent
  • 64-bit PostgreSQL database
  • Email notification for expiring certificates
  • Support Access for SSH
  • SNMP monitoring of the file system

Remarks

  • System will be rebooted
  • Configuration will be upgraded
  • Connected REDs will perform firmware upgrade
  • Connected Wifi APs will perform firmware upgrade

Bugfixes

  • NUTM-6646 [AWS] REST API panic when unlocking unlocked mutex
  • NUTM-6657 [AWS] Configure AWS profiles via WebAdmin
  • NUTM-6696 [AWS] Configure CloudWatch support via WebAdmin
  • NUTM-6708 [AWS] Cloud update not working with conversion deployments
  • NUTM-6814 [AWS] Rest API is accessible with default password if basic setup has not completed
  • NUTM-6887 [AWS] REST API panic when inserting into node which is not of type array
  • NUTM-7032 [AWS] SignalException not handled for SecurityGroupsManagement#update
  • NUTM-7055 [AWS] queen_configuration_management / aws_resource_management SIGUSR1 handling
  • NUTM-7056 [AWS] LocalJumpError
  • NUTM-7057 [AWS] aws_set_sd_check AWS::EC2::Errors::RequestLimitExceeded
  • NUTM-7061 [AWS] Connection refused - connect(2) for "localhost" port 4472
  • NUTM-3194 [Access & Identity] incorrect SSH logins trigger backend authentication requests
  • NUTM-3222 [Access & Identity] RED10/50: DNS port open on WAN interfaces
  • NUTM-3260 [Access & Identity] User Portal - IPsec Windows Support
  • NUTM-4149 [Access & Identity] [RED] Use Sophos NTP pool servers
  • NUTM-4323 [Access & Identity] NULL pointer deref in red_nl_cmd_tunnel_dump
  • NUTM-4705 [Access & Identity] Don't use DNS server from the RED branch as an ISP forwarder
  • NUTM-4852 [Access & Identity] [RED] flock() on closed filehandle $fhi at /</var/confd/confd.plx>Object/itfhw/red_server.pm line 563.
  • NUTM-4994 [Access & Identity] STAS creates users even if automatic user creation is disabled
  • NUTM-5134 [Access & Identity] [OTP] User Portal should recommend Sophos Authenticator
  • NUTM-5925 [Access & Identity] [RED] prevent configuration for VLAN for Split modes
  • NUTM-6387 [Access & Identity] HTML5 VNC connection not disconnecting
  • NUTM-6641 [Access & Identity] [OTP] user can select algorithm for automatic tokens
  • NUTM-6668 [Access & Identity] [IPsec] L2TP/Cisco policy changes do not update ipsec.conf
  • NUTM-6749 [Access & Identity] RED15w does not send split DNS traffic over RED tunnel
  • NUTM-5965 [Basesystem] Sensors command on SG125w doesn't show hardware fan RPM
  • NUTM-6468 [Basesystem] BIND Security update (CVE-2016-9131, CVE-2016-9147, CVE-2016-9444)
  • NUTM-6718 [Basesystem] Update NTP to 4.2.8p9
  • NUTM-6846 [Basesystem] Linux kernel: ip6_gre: invalid reads in ip6gre_err() (CVE-2017-5897)
  • NUTM-6847 [Basesystem] BIND Security update (CVE-2017-3135)
  • NUTM-6902 [Basesystem] Linux kernel: ipv4 keep skb->dst around in presence of IP options (CVE-2017-5970)
  • NUTM-7048 [Basesystem] Implement software workaround for Intel CPUs
  • NUTM-7067 [Basesystem] Update OpenSSH to openssh-6.6p1
  • NUTM-7370 [Basesystem] Bootsplash still shows 9.4 instead of 9.5
  • NUTM-7653 [Basesystem] Internal SSL certification verification broken
  • NUTM-5658 [Confd] Stripped restore unaccessable if default internal interface is removed
  • NUTM-3062 [Email] Mails From mail spool gets quarantined because of "500 Max connection limit reached" in cssd
  • NUTM-4753 [Email] Support recipient verification with multiple AD servers
  • NUTM-5350 [Email] Per user blacklist does not apply until smtp service restarts
  • NUTM-5823 [Email] Scanner timeout or deadlock for all mails with a .scn attachment
  • NUTM-5892 [Email] SMTP Exception doesn't allow '&' sign within the email address
  • NUTM-6135 [Email] DLP custom expression doesn't get triggered if the email body contains certain strings
  • NUTM-6355 [Email] Email not blocked with expression list
  • NUTM-4474 [Kernel] Kernel panic - not syncing: Fatal exception in interrupt
  • NUTM-6358 [Kernel] Kernel: unable to handle kernel NULL pointer dereference at 0000000000000018
  • NUTM-4969 [Network] Uplink does not recover from error state
  • NUTM-5314 [Network] 10gb SFP+ flexi module interface fails when under load
  • NUTM-5428 [Network] Bridge interface can not acquire Dynamic IPv6 address correctly. This interface repeats up/down.
  • NUTM-5831 [Network] Changing static IP on interface does not take effect immediately
  • NUTM-5861 [Network] IPv4 static address gets deleted from confd (and WebAdmin) once IPv6 on the same interface fails to obtain dynamic address
  • NUTM-6077 [Network] Static route on bridge interface disappears after rebooting the UTM
  • NUTM-6807 [Network] SSL VPN not being redistributed into OSPF
  • NUTM-6901 [Network] Eth0 is removed while configuring bridge interface
  • NUTM-2420 [WAF] Remove session management from basic authentication
  • NUTM-5603 [WAF] Issue with expired lifetime of WAF connections without any hint
  • NUTM-5628 [WAF] WAF - Provide import and export options for HTTPS domain list
  • NUTM-5640 [WAF] GUI issue when adding wildcard certificate into Virtual Webservers
  • NUTM-6156 [WAF] UTM still fails scan for CVE-2016-2183 (SWEET32) after update to 9.408
  • NUTM-6294 [WAF] WAF - Naming collisions for default profiles
  • NUTM-6522 [WebAdmin] SMC Test failed after Settings are applied
  • NUTM-6788 [WebAdmin] Add support for SG105W, SG135W and SG230 in WebAdmin
  • NUTM-7337 [WebAdmin] Fix appliance picture for SG105w N9
  • NUTM-6467 [Web] FTP connection fails when using transparent FTP Proxy
  • NUTM-6732 [Web] Certificate issue with transparent Web Proxy - "unable to get local issuer certificate"
  • NUTM-6876 [Web] Remove insecure RC4 from default cipher list for Web Protection HTTPS scanning on upgrade to 9.5 or restore of pre-9.5 backup
  • NUTM-7586 [Web] Chrome v58 and higher fail verification with HTTPS scanning enabled
  • NUTM-5638 [WiFi] RED15w - integrated AP isn't shown as pending in transparent / split mode
  • NUTM-5786 [WiFi] RED15w - if more then one SSID is configured only one is working correctly
  • NUTM-6215 [WiFi] Issue when roaming between wireless with some clients
  • NUTM-6335 [WiFi] VLAN fallback not working for integrated AP from RED15w
  • NUTM-6448 [WiFi] AP55 stuck as inactive
  • NUTM-6511 [WiFi] AP does not get IP address on 100 Mbit ethernet link

Download

While the release is in soft-release phase, you can find the up2date package on our FTP server at:

File size: ~301MB

  • In reply to jag2000:

    Try posting the DHCP log here? :-)

  • In reply to twister5800:

    i will have to do that later. i had to move my network over to my Meraki MX64 because its impacting work.

  • In reply to twister5800:

    How does this occur ? Does it happen directly after an upgrade? Or does it occur after a period of time? Would this affect a fresh install of 9.5?

    Also was the fix permanent or did the issue resurface?

    How many virtual hosts did this customer have? Was this a big deploymemt of WAF? Have any of your other customers had issues with waf or is this customer the biggest?

    I'm about to deploy waf for 300 websites with 5 back-end hosts, and we are starting fresh with 9.5 on a pair of sg430. So I want to understand thr circumstances behind how your issue happenend.

  • WAF Exchange Server 2003

    Hi after the upgrade on a SG135 UTM Outlook Web access stopped working.

    Ther Exchange server is part of SBS 2003. after the upgrade we get this message

    Proxy Error

    The proxy server received an invalid response from an upstream server.
    The proxy server could not handle the request GET /exchange.

    Reason: Error reading from remote server

    2017:05:17-22:54:00 COLORFOTO-UTM01 reverseproxy: [Wed May 17 22:54:00.575738 2017] [proxy_http:error] [pid 19032:tid 3836775280] (103)Software caused connection abort: [client 5.249.34.179:54811] AH01102: error reading status line from remote server 10.0.11.1:443
    2017:05:17-22:54:00 COLORFOTO-UTM01 reverseproxy: [Wed May 17 22:54:00.575775 2017] [proxy:error] [pid 19032:tid 3836775280] [client 5.249.34.179:54811] AH00898: Error reading from remote server returned by /Microsoft-Server-ActiveSync
     
    I know its a pretty old server and we are in the process of upgrading to 2016, but meanwhile everyone stopped to get email on their mobiles and tablets.
    This just happend after the upgrade.

     

    Thanks in advance

     

    Paulo

  • In reply to StealthyM:

    It did occur 4 days after upgrade, have not seen this on fresh installs.

    As I did implement the fix yesterday, I am not sure if it's permanent yet :-)

    They have 10 sites and 5 webservers behind WAF and are not the biggest.

    I will make a support case today to make them look at it :-)

  • In reply to JamesGolden:

    JamesGolden

    Was that something that 9.5 turned on or was something I may have turned on before but didn't see any issues with? 

     

    The default setting is "Off", so it looks like you may have made the change. We're still looking into the root cause for this and it seems to only happen for systems that have received a fair amount of up2dates. With a fresh install this issue is not reproducible.

  • In reply to HeikoHund:

    Heikohund, that's not entirely true.

    In the start uf UTM 9 (i think) the Default was "Auto" and i assume if you upgrade the appliance and never do a reinstall this setting will be kept.

     

    So maybe, JamesGolden, you have an older Installation and because of that the setting is "Auto".

     

    Regards,

    Michael

  • In reply to HeikoHund:

    I haven't upgraded to 9.5 yet, but have had the UTM for a while and only ever done up2dates, no fresh install.

    I've never been into HA but went in to have a look, mine was set to Automatic Configuration.  This must at some point have been the default configuration.

  • In reply to steveatkinson:

    That the same on our UTM.

    The UTM is now 2,5 years old and has all the time only be updated.

    This feature must be on Auto since then.

    Nevertheless it is important that there is a workaround.

    Everything else they can correct for the next update. 

  • Still only seeing this being offered to 1 of my 4 UTM's, I guess this is a very staged/slow rollout??

  • In reply to maxsecobj:

    I haven't seen it on any of the UTMs I manage yet. For mine, I downloaded the up2date file and installed manually.

  • Hi Guys,

    Regarding NUTM-7586. Does certificate has to be recreated and pushed to endpoints after we upgrade the firmware to 9.500?

  • In reply to Andrzej Zakrzewski:

    Does it allow you to do a fresh install on a machine that doesnt have a VGA connection available?

  • In reply to Jeff Siegel:

    Anyone experienced the same problem as described here?

    http://www.edugeek.net/forums/internet-related-filtering-firewall/184334-sophos-utm-9-500-9-bug.html#post1579014

    Keen to update to 9.5 but very wary given the reports of issues.