ASG 8.102 on Toshiba Magnia SG30

Well after installing 7.502 on my SG30 about a year ago I figured it was time to move up to v8 and see how well this old box could handle a little bigger load.  I went into it wanting to fix a few things that didn't make me happy that may have stemmed from how ASG was installed on the hard drive.

If you just want to get to the download and install it without reading the technical babble of what was involved, skip down near the smiley face towards the bottom and go for it!  Otherwise..... Read on for the rest of my messy, boring, nerdy post....

Instead of installing this from outside the SG30 I decided I wanted to run the installer from a modified CD on the SG30 itself, via a remote serial console.  Here's a rough outline of what was required to make that happen.

NOTE: If you don't already have a serial cable for your SG30, this is the one I picked up and I can say it works great with a null modem cable between the DB25 and the computer: Mac serial cable from Monoprice

The installer is based off the asg-8.102-2.1.iso with some modifications to make it usable on the SG30. For starters the syslinux boot loader has been modified to work with a serial console. (All serial communications are set at 115200,8,N,1)  All of the modifications to boot the installer properly were done to the "initramfs.gz" and "isolinux.cfg" file in the "isolinux" folder on the installer CD.  "Intro.txt" was also modified to reflect how to send F1 & F3 over the serial connection.

The onboard LCD should display some information to the user as to where it is in the installation process, "Running Astaro Installer" being the last thing displayed before the reboot occurs.

Support for the ethernet devices is already baked in but needed some modules loaded for them.  This was as simple as adding the e100 and 8139too modules at boot time, they'll also be loaded on the installed system then.

There are also several other modifications of the CD boot process that allow the installer to work over a serial redirected console. In the middle of the boot process before the installer starts it actually drops you to a bash prompt so you can make any modifications you'd like before launching the installer.  If you just want to continue on normally, type "exit" and enter and it will start the installer.

In the installer on a regular console you can switch between virtual terminals for the log and a shell prompt.  These are the ALT-F2 and ALT-F4 functions in the installer and the modifications I made render those screens unusable. By dropping to the shell prompt before launching the installer it will allow users to copy those files and others to make any other changes before going into the installer. 

After it's installed on first boot I've inserted a script that will setup the rest of the system. The /etc/init.d/rc3.d/S00boot.sglcd file is responsible for setting the system up for use and displaying the boot message on the LCD screen at startup. The other file to go along with the script is the tar archive: /home/login/magnia-lcd-support-files.tar.gz

S00boot.sglcd and the tar archive are the only files that are injected into the installed file system by the Astaro installer. These files were injected into the "install.tar" file located in the "install" folder on the CD. Basically at boot S00sglcd.boot quickly checks for 3 files on the system and if they're not there, it performs the needed action to install them. It does this at each boot so if Astaro makes changes, it should be able to recover itself after a reboot. 

One of the things is checks for is the existence of the /sa2 folder, if it's not found, it extracts the tar archive to /sa2 on the file system. Inside that folder are all the files required for LCD support along with other support files.  After the /sa2 folder is populated, start up scripts get copied and linked in /etc/init.d to handle the boot changes for the SG.  It's important to note that I focused on NOT modifying ANY of Astaro's preexisting bootup scripts this time.  I placed the links in the proper locations to give LCD feedback on the boot process and make the booting process as smooth as possible.

The included files and extras take up total about 4-5MB on the hard drive so space shouldn't be an issue.  There's also a customization PDF, and some other files some might be interested in rummaging through in the /sa2 path...

After your booted up you'll notice the LCD displaying the time and date, you can also press the soft button to get a switch view showing active ports on the back panel. The power button is also functional and will power the system off safely. When a power off is requested from the web admin portal it will send the needed commands to the LCD controller to power the box off as well. The LCD will show things like restarting and shutdown sequences, nothing crazy but it's not just sitting there displaying "BIOS POST!" the whole time.

Some of the boot process and LCD usage is logged, the front power button being a notable one. When a shutdown is initiated from the panel it places an entry in the Device Agent log. (Accessible from web admin) Also a few other things are logged there at startup, basically what the scripts see as the system comes to life.  Mostly this is just a "wait" state in the startup script to make sure the NICs are alive before reporting on the LCD that the system is "up."  I noticed a few times that the IPsec / L2TP daemon reported it wasn't running if the scripts didn't look for the NICs to be alive, easy fix for the problem.

After it's up and alive you should have a fully working ASG v8 system on your Toshiba Magnia!  I've been quite happy with it's performance with 1GB of ram on the box (maxed).  CPU usage hovers around 5-10% usage when just dealing with traffic and packet inspection,  nothing but update tasks get the cpu above 40-50%.

If you load this up, PLEASE come back and report your findings here!! Big Smile

You can get the CD image here: Toshiba Magnia Astaro v8 Install CD
(The image is across 3 RAR files that have recovery records with them, use WinRAR to repair them if recovery is needed)

If you're interested in any of the other SG related files I have: HaTaX's SG30 Files



Other thoughts on the SG30 running/installing ASG v8:

Someone posted how to make a bootable flash drive to install astaro from. I gave it a quick shot and didn't have much success with it on the SG30. It does support the boot from it so I'd guess with a little work it could be done. People may want to try and monkey with this, so the shell before the installer will allow you to get around the lack of being able to ALT-F2 inside the installer.  This might work better keeping in mind the ehci-hcd issue I had with the 3G modem.

I've been playing around with the 3G modem feature on the SG30 and it seems it will work quite well with just a few simple modifications.  I'll look into rolling these into a new installer soon.  Namely the ehci-hcd module is causing problems and made my system hang up at boot with my MiFi 2200 plugged in.  I added a script to run just before Astaro's S15 script that performs the usb_modeswitch on the device, and it looks like it resolves the issue and I can see it in the web interface.

Had an issue with v7 on the SG30 that would randomly come up with I/O journal errors and lock the system up.  I am hoping installing it directly on the hardware with all of the "stock" items loading correctly and functioning will help with this issue.  Most of the time this means a bad HDD, but I tried 3 different drives of which I know 2 are definitely good.  Just a reboot every week got around this so we'll see how v8 being properly installed helps make it over 7-10 days.
  • Well, I've got an update for the install CD that some people may appreciate!

    I was able to entirely automate the installation of ASG on the Magnia SG30.  I had to create a new CD image for it, and ultimately this will probably be the only disc I make going forward.  When you boot from it you're presented with the same startup menu but the default now is to start a completely automated install.  There is a timer that kicks off the automated install if you don't press anything within 30 seconds, as well you only have 5 minutes to input a choice before the automated install kicks off on its own.  I put the 5 minute total timer in there just in case someone has sent some errant keys to the console by accident or a noisy serial connection.  BE WARNED, when that 5 minutes counts down it's going to be formatting the HDD in that box within 30 seconds or so.

    Otherwise the automated installer will reboot when its done, and you should have a fully working ASG v8 setup on your Magnia!  The system defaults to 192.168.0.1 on the internal (7 port switch) NIC, and you can finish the setup of it once booted.

    This should allow the users out there without a serial console setup to install this on their boxes.  Now as far as getting it to boot from the CD I'm not 100% sure of all the options out there.  I do know that if you were to open it up, and move the power supply out of the way, you could plug in a PS2 keyboard to the PS2 port that is next to the power supply.  Then while booting just keep hitting the "D" key and it will boot from a USB cd-rom.  This is kind of messy to do, but not too terrible, and you only need to move the PSU out of the way, not completely remove it from the case.  Otherwise I *think* there is a pattern of buttons you can hold / press at boot that tells it to boot from USB, but I'm not 100% on this one.  I'll look into it.......

    I'll most likely make the "SG-asg-8.102-2.1-Automated" my primary and only image as you can launch the same manual installer that was present in the first disc image I provided.  At the "boot:" prompt from the CD you can type "default" or "manual" to do a manual install, and the "debug" and "classic" options also boot the manual installer.  Just pressing enter or entering "auto" will kick off the automated installer right away.  The manual installer still has the drop to a bash shell just before starting the installer,  nothing changed in the process.

    Also, this new image contains my USB fix for 3G modems!!  I added another script to the startup of the system that checks for an Astaro supported 3G usb modem, if one is found it does some work with the loaded modules and then continues on to the Astaro setup of the 3G modem.  Works with my MiFi 2200 quite well even if it is only USB 1.1,  I did notice some funkiness with disconnects but think it's more related to Verizon's eagle eyes on private traffic over their networks.  If you have a 3G modem, please give this a shot and let us know how it works for you!

    You can get the new image in the same location as the other CD, it's the one labled "SG-asg-8.102-2.1-Automated."
    Toshiba Magnia Astaro v8 Install CD
  • Just thought I would give a follow up post now that it's almost been a full month since I did the install.

    Previously with the v7 install I would get a journal entry error on the screen every 7 days or so and it would lock the system up and require a hard reboot.  Not sure if this stemmed from it being installed on a netbook with a USB adapter, but it sure was irritating.  I went through 4 different hard drives to make sure it wasn't an actual hardware issue, and never really bothered to track down what was going on as I was planning to move to v8 anyway.

    Good news is, uptime is now over 24 days and I haven't seen that issue pop back up since!  Looks like I can finally rely on it without needing a weekly reboot. Smile

    Hardware usage on it is quite low, CPU has averaged about 10% over the last 3 weeks and memory has hovered around 30%.  

    Overall I'm pretty happy and confident that this little box has got a few more years of life in it with ASG v8.  Thanks again to the great software engineers at Astaro! Big Smile
  • Just another update to this lonely thread. Smile  I got a 16GB compact flash setup for the hard drive in the SG30 for nice and cheap and I used the same image I posted up here, worked perfect!  Seems like writing is slower so the boot up time got a little longer, but once it's up, browsing the web interface is really quick and responsive.

    This thing does a bang up job as a firewall!  And happy to report that I had 60+ days of uptime before bringing it down to move over to the CF setup.  Backup and restore worked perfectly and the whole moving process took about 45 minutes before I was 100% back up.
  • In reply to HaTaX:

    I just got through installing ASG 8.102 on my SG30, and setup was a snap!  Great work on pulling this together...the LCD support is especially welcome.   The only issue I seem to have run into is with the Astaro license.   Astaro support emailed me a "home use" license, but every time I try to apply it, I end up with an "invalid license" error.   Have you ever run into this issue?

    Thanks again!

    sg_astaro_fan
  • Hi, if you're west of Germany or England (GMT), try again after enough time has passed to catch up on the time difference (e.g. 8 hours if in w. US).

    Barry
  • In reply to BarryG:

    Well, I received the license file at 8:12pm EST on Sunday evening, and it still isn't working as of 8:07pm EST today (Tuesday).   I even tried the command line approach:  cc -stdin set licensing license 
  • And you installed the ASG software ISO, not the hardware/appliance ISO, right?

    Barry
  • In reply to BarryG:

    Yes, it says "ASG Software" under "Model" on the dashboard.
  • In reply to sg_astaro_fan:

    I finally got it to work by going through "myastaro.com" and upgrading my license to the "new licensing model."   I was then able to apply the new license file to my 8.103 installation.
  • I have a SG30 and the hard drive is bad so need a image or CD. The link you give for them  http://www.mediafire.com/?aiev3pm81p56a wants $90 a year and I just need to download 1 file.

    Is there any place else to download the rescue CD or a image?

    I think I like the rescue CD because want to have a SSD in this can get like a 500GB SATA SSD for about $50 today. But need a SATA to IDE and I have that. Just need to install the OS on it now.

    -Raymond Day

  • In reply to Raymond Day:

    Found out can download one at a time. I did not know each file was in the folder and downloading the folder would cost $. I did download them and put them to a ISO and on a CD-R and can get the SG30 to go in one time turning on the LED light on the USB CD ROM. But I did not have this disk in it then. Never got it again to turn on the LED light of the USB drive. But I did get the LCD screen to show that it was booting from it but it was not and after a few minutes it rebooted to BIOS POST! I guess that just means no OS and only in the BIOS that can't see.

    Have to hold down the LCD button to get it in this mode as you turn it on. But it seems like it's a hit or miss.

    Started to download the Ubuntu image and it's a lot of parts and it stop at at 22 files I guess have to wait 24 hours to download the rest. Then I guess use another PC to install it and put the hard drive in the SG30.

    -Raymond Day 

  • In reply to Raymond Day:

    The 2nd post says can remove the power supply to plug in a PS2 keyboard and I did. I press D on boot up and I can see the LED flash some on the USB CD-ROM drive but it don't stay going.

    Do I have to press something else on the keyboard too?

    -Raymond Day

  • In reply to Raymond Day:

    Hi Raymond and welcome to the UTM Community!

    That link contains the ISOs for a software version 8 - probably not what you want.  If you have an SG appliance, you will want to choose an ssi (hardware) version from UTM Support Downloads.  If you are having problems with the hard drive in your SG, do not open the case!  Doing so will void the warranty.  I would urge you to contact your reseller immediately.

    Cheers - Bob

  • In reply to BAlfson:

    I got the SG30 from eBay said it did not work. The hard drive in it does not spin. Seems like it tries to spin but don't.

    I have a old image on a CD-R named ""SG30_Build_us_3.1.0-74.tib" I put it on a WD BLUE 500GB 3D NAND SATA SSD with a SATA to IDE.

    It just will not boot on the SG30. I don't have a recover CD and it will see a old USB CD ROM drive I have.

    But wow I put the SG30 image on a SG20 and it booted from the SSD. I set it up with a IP.

    It worked.

    Put it in another system to run Gparted on it. To make the last partition full size of the drive. I messed it up some how now says file system bad something like that.

    All so I guess I have to run a "sensors-detect" on it in the SG20. It thinks the voltage is to high on one of the cores of the CPU.

    Something a SG30 image works on the SG20 the LCD display even works.

    But I love to get it to work on the SG30. I put that SSD wile it still worked in the SG20 on the SG30 and it just boots to BIOS POST! I guess have to wait till I get the RS232 for this in the mail and then maybe can set the BIOS to boot from the SSD drive.

    Any one know the right way to make it the full size of the drive?

    -Raymond Day

  • In reply to Raymond Day:

    The link to down load the files for Linux after you down load about 25 files or so, it locks you out at lest for 24 hours so maybe a week or month or year. Can some one else download the rest for me and put them on like your google drive or something. I got to SG30-Ubuntu-Server-910.img.part21.rar so need 22 on. Elase you have to pay like $100 a year.

    You can make a free server too just look up "google cloud" and can ssh to it to upload download from there. It take a google account and a credit card but they give you $300 to start with and if it don't get a lot of traffic it only cost like $0.17 a month. You are limit a year I guess.

    I made a Google cloud server and put it at 500GB and it took it I am not sure what it's limit is.

    -Raymond Day