USB Stick Install Solved

I have been reading the forums here for awhile, and decided to figure it out.


  • Download and install 'Universal USB Installer' - Universal USB Installer – Easy as 1 2 3 | USB Pen Drive Linux
  • Download Astaro ASG v8 iso -
  •  Open the Universal USB Installer,  for Step 1: Select the last option, 'Try Unlisted Linux ISO (New Syslinux)'
  •  For Step 2: Select the Astaro ISO
  •  For Step 3: Select your USB Key. I used a 512MB U3 Kingston
  •  Click 'Create', Eject the USB Key and Boot your soon-to-be Astaro Box
  •  Press  to Start the Installer 
  •  On the First Screen, hit Alt-F2.
  •  Follow this sequence:
  •  bash-3.2# mount /dev/sdb2 /mnt
  •  bash-3.2# cd /install
  •  bash-3.2# mkdir install
  •  bash-3.2# cd install
  •  bash-3.2# cp -a /mnt/install/* .
  •  Hit Alt-F1


  •  Finish the Installation, Reboot and Enjoy.


Please post questions, experiences etc. This has worked for me, but it's my first experience with Astaro, so I thought I'd share in hopes others can benefit.


  • @Mast:  SSI ISO is for Sophos/Astaro branded hardware appliances.
  • In reply to Scott_Klassen:

    @Mast:  SSI ISO is for Sophos/Astaro branded hardware appliances.

    i thought that you could use the regular ISO for the appliances as well
  • Hi, Mast,

    The home-use license only works with the software version.  To install the software version on a Sophos/Astaro appliance, you have to delete the file that identifies the device as an appliance.

    Cheers - Bob
  • I have just repeated this.  I have no Unix knowledge but it went OK.

    I used Rufus and it worked without issue. No renaming or anything.

    I booted from the USB key (I needed to change the device boot order in the BIOS) and started the install.

    Once the hardware was identified and the disk format began I switched to the console by pressing ALT + F2

    Then I remounted the installation media by typing mount /dev/sdb1 /install

    After the mount successful message I pressed ALT + F1 to return to the install and waited for it to complete ( remove installation media and reboot message displayed)

    None of the above is new.  All credit goes to those who have gone before in this post, but hopefully it corrects a couple of typos (unix experts would just know it was wrong - those like me do not!)  It also confirms it works with 9.306 which is the version available for download in Feb 2015
  • Just ran into this problem, and the /install mounting trick worked perfectly for me as well! I did it directly after the hardware detection.

    Version: 9.310-11.1
    Hardware: Intel D2500CC (using the 64-bit kernel)

    Used the excellent Rufus for iso -> usb-key.
  • I tried many, many times without success. Tried with Universal USB Installer, and UNetbootin- all failed. Switched to Rufus and it worked first time.
  • In reply to Astaphos:

    Just ran into this problem, and the /install mounting trick worked perfectly for me as well! I did it directly after the hardware detection.

    Version: 9.310-11.1
    Hardware: Intel D2500CC (using the 64-bit kernel)

    Used the excellent Rufus for iso -> usb-key.

    I have to agree/recommend the same. Use Rufus and mount into /install. 9.314-13 (re)installed that way, and autorestoring the configuration when it rebooted as I put a backed up config file on the USB stick
  • In reply to pclov3r:

    I thought I'd pitch in to the community to help

    After many hours of trial and error I found the solution. 

    Mount /dev/sdb1 to /install to install AFTER the hardware detection runs. The hardware detection is what is causing it to be unmounted. 

    So once you get a report of the hardware installed get into the shell by running ALT+F2 than run the mount command and it should work from there.

    Thank you so much to  pclov3r . After two hours I found your tip and you make my day.

  • In reply to Tony Rivero:

    Well, 6 years after this thread was initially established and it's still going strong!  Why Sophos don't give us a 21st century solution to this issue I do not know.  Anyway...

    I have just purchased an SG135 and I am attempting to install UTM 9.5 on it via a USB flash drive.  I have followed all recommendations in this thread, but I am still getting the 'install.tar' error.

    Is there a new trick with later versions of UTM 9 which I need to be aware of?

    One question I have however is assuming you get the install media booting and arrive at the install screen, does it matter which method you use to get there?

    Also, could someone please provide me with an answer on which version of the ISO to use?  There seems to be only the Hardware/SSI and Software versions now.  Given that I have a fully stock Sophos hardware appliance I am assuming the SSI version is what I should be using?  I have not been able to find clear directions regarding this so far.

  • In reply to SamFickling:

    ...and to answer my own question:

    Yes, it does matter which method you use to boot the ISO.  Switching to Rufus resolved my issue. :)

    Also, the SSI ISO appears to work fine with my stock SG135 box.

  • In reply to CharlesErrington:

    Thanks everyone! 

    After some hours trying diffrent methods I found this thread.

    To check what sdb number the installation media is just flick to Alt-F4 View Log at the first screen. You can see it there.

    I used asg-9.502-4.1.iso on a Dell Optiplex 790 with Intel i350 T2.

    Had problems with the file names, as other people, until I switched to Rufus.

    Did the mount /dev/sdb1 /install after the hardware check as suggested and it worked fine after that.

  • In reply to Tomas Bengtsson:

    It's work for me in SG115w. Good job! ;-)

  • In reply to darnoK:

    still an issue, i'm afraid.  thanks for the help.


    fwiw, another way to get the list of drives from the shell is w/ 


    that will list all your found partitions and you should be able to tell which is which.

    a bit suprising this is still an issue 6 years on... 

  • In reply to Erin Jones:

    I had a problem with mounting, but I tried a solution where USB is mounted to the upper port and the keyboard to the bottom.
    Probably all you do well, only sdb1 that you want to mount is just the port on top.

    mount /dev/sdb1 /install (when bootable USB stick is mounted to the upper port)

    Please, try this solution.
  • In reply to darnoK:


    I was able to use the work around in the thread to get it working.  The primary purpose of my post was to note that you can you 'blkid' to help identify the name of your install partition that needs to be mounted.