*Unofficial* Hardware Compatibility List (HCL)

The OFFICIAL Sophos / Astaro UTM HCL is currently at http://www.sophos.com/en-us/support/knowledgebase/118185.aspx
As it does not contain all possible hardware, I've created this thread...

Please don't post questions like "will X work?" here. Open a new thread if you have a question about buying hardware not already mentioned here.
Open a new thread if you have an installation or other question.


Update: This thread is for system configurations. If you'd like to mention a single component such as a NIC or RAID controller, please post in https://community.sophos.com/products/unified-threat-management/astaroorg/f/52/t/27166

If you are having trouble with installation, please open a new thread unless you are sure that the hardware is incompatible, and if it is incompatible, be specific, e.g. "fails to detect disk", etc. Know how to use ALT-F3 etc. Ask questions in a new thread if you're not sure.


I propose that we post here with our tested system configurations, Astaro versions, and success or problems, using this template:

Template for copying/pasting:
Status: [Working|NOT Working], currently using at [Home|Work|Client]
Astaro Version(s) tested: 
System OR Motherboard: 
BIOS version: 
CPU:
RAM: 
Disk Controller 1: 
Disk Controller 2: 
Network Interfaces: 
VLAN support: (unknown|untested|no|working)
Video Controller: 
Hard Disk: (optional but please at least specify SATA/PATA/SCSI/SAS)
Optical Drive: (optional)
Case/Chassis: (optional)
Power Supply:  (optional)
What's not working: e.g. SATA doesn't work but IDE does
Total Power Consumption (in Watts, if known): [measured|estimated based upon...] please do not use the power supply rating
Total Cost: (optional, please specify currency, retail|used, and date)
Comments / Notes: (please include your Internet connection speed)


Note I used 'lscpi' to get the controllers information.
Note that one can EDIT their post later to add changes/corrections instead of posting a 'correction' post.

Also see IPS Throughput benchmarks at: https://community.sophos.com/products/unified-threat-management/astaroorg/f/52/t/29110


Please don't post questions like "will X work?" here. Open a new thread if you have a question about buying hardware not already mentioned here.


Thanks!
Barry

  • Status: Working currently using at Home
    Astaro Version(s) tested: 9.351-3
    System OR Motherboard: Dell OptiPlex 7010
    BIOS version: A20
    CPU: Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz
    RAM: 8GB DDR3 1600
    Disk Controller 1: 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode]
    Disk Controller 2:
    Network Interfaces: eth0 Intel Corporation 82574L Gigabit Network Connection
    Network Interfaces: eth1 Intel Corporation 82574L Gigabit Network Connection (Ethernet Bridge)
    Network Interfaces: eth2 Intel Corporation 82579LM Gigabit Network Connection (Ethernet Bridge)
    VLAN support: Untested
    Video Controller: Built In.
    Hard Disk: SATA 120GB OCZ-AGILITY3 SSD
    Optical Drive: HL-DT-ST DVD+-RW GT80N
    Case/Chassis: SFF
    What's not working: none
    Total Power Consumption unknown
    Total Cost: About £40-£50 quid for 2 LAN cards, the rest I had laying around and unused for a few years.
    Comments / Notes: Sky Fibre 80/20(Mbps)

  • Status: Working: Home Stable overall
    Astaro Version(s) tested: 9.350, 9.352-6
    System OR Motherboard: Intel NUC NUC5PPYH
    BIOS version:
    CPU: Intel N3700, 2.4Ghz Quad Core
    RAM: 4Gb DDR3L SODIMM
    Disk Controller 1: SATA 3
    Disk Controller 2:
    Network Interfaces: 1 Internal Realtek Gb / 1 USB Realtek Gb
    VLAN support: working
    Video Controller: Intel HD Graphics
    Hard Disk: SATA 64Gb SSD
    Optical Drive: None
    Case/Chassis: NUC
    Power Supply: External
    What's not working:
    Total Power Consumption (in Watts, if known): 8 - 13 watts depending on load
    Comments / Notes: Total cost: $210; Initial setup used an Anker Unibody Aluminum USB 3.0 to RJ45 Gigabit Ethernet Adapter Supporting 10/100/1000 Mbps Ethernet [RTL8153 Chipset] that had random disconnects after about 3 weeks of use. Anker NIC ran very hot before failure. Currently using Fenvi Unibody Aluminum USB 3.0 to RJ45 Gigabit Ethernet Network Adapter Supporting 10/100/1000 Mbps Ethernet for Windows and MAC System [RTL8153 Chipset]. Fenvi appears to run much cooler. Using Unifi access point with a few VLANs including a Sophos Guest portal and a few wired Gb VLANs. Hopefully, the USB NIC will survive long term. If current configuration is stable long term, the cost is minimal for all the features available. Minor issues installing from USB Stick.
  • Status: Working-stable, using in home environment
    Astaro Version(s) tested: UTM Home 9.3550-1 plus several earlier versions
    System OR Motherboard: SuperMicro X10SLM+LN4F-O
    BIOS version: R 3.0
    CPU: Intel Core i3 4170 (SilverStone NT07-115x Super Slim Profile CPU Cooler)
    RAM: 32GB 8GBx4 Crucial(Micron) CT2KIT102472BD160B
    Disk Controller 1: onboard
    Disk Controller 2: onboard
    Network Interfaces: Quad Intel i210AT
    VLAN support: Yes, not using
    Video Controller: BMC integrated Aspeed AST2400
    Hard Disk: Samsung SATA SSD
    Optical Drive: Pioneer-temp only for Sophos installation
    Case/Chassis: SilverStone ML04B
    Power Supply:  SeaSonic SSR-360GP 360W
    What's not working: So far everthing I've used is working
    Total Power Consumption (in Watts, if known): Going off memory, but I think 30-40 watts, roughly
    Total Cost:  $600+ retail, late 2015
    Comments / Notes: Solid as a rock after proper setup/burn-in.  Overkill for my use case and the hardware use/graphs reflect that, but it was purchased with expansion in mind.  I'm writing this up well after the fact, but I recall the Sophos installation being seamless and not having run into too many hurdles getting this going.  My internet connection speed is 100/10Mbit and I get every bit of that as far as I've seen, most features enabled.  Runs super quiet, but had to set fan thresholds via IPMI tool.  Added 2 Noctua NF-R8 fans to the case for airflow.

  • Status: Working, currently using at Home
    Astaro Version(s) tested: 9.355-1
    System OR Motherboard: SuperMicro E200-9B containing X11SBA-LN4F Mainboard
    BIOS version: 1.0
    CPU: Intel® Pentium® Processor N3700 (SOC), Quad-Core (6W, 4C); Socket FCBGA 1170
    RAM: 2 x Kingston KVR16LS11/4 RAM 4 GB 1600 MHz DDR3L Non-ECC CL11 SODIMM 1.35 V, 204-Pin Memory Module
    Disk Controller 1: SATA 3.0 (6Gbps) from Intel® SoC
    Disk Controller 2:
    Network Interfaces: Quad Gigabit Ethernet LAN ports, Intel® I210-AT
    VLAN support: unknown
    Video Controller: Aspeed AST2400 BMC
    Hard Disk: Plextor PX-128M6M 128GB mSata Solid State Drive
    Optical Drive: None
    Case/Chassis: CSE-101S Mini-ITX (19.5cm wide x 19.5cm deep x 4.5cm high)
    Power Supply: DC-DC board with external 60W DC Power Supply
    Total Power Consumption: Estimated 10 - 15 Watts
    Total Cost: £424.63 (Bare E200-9B = £350, RAM = £29.24, mSATA = £45.39 all retail)
    Comments / Notes: This Server/Board has a dedicated IPMI interface (similar to HP ILO) in addition to the 4 NICs.
    Install of UTM was done remotely using IPMI console redirection with virtual media pointing to local ISO on remote machine.
    All hardware was recognised with no issues.
    Broadband Line Rate - Upstream: 9999 Kbps, Downstream: 39999 Kbps

  • Asrock H110m-ITX does not work with UTM 9.2,9.3 or 9.4 but does work XG 15.

    Fails after the NIC detection, just sits.

    I also have an MSI 150 that does the same thing. Rats another upgrade fails.

  • Status: [Working], currently using at [Home]
    Astaro Version tested: 9.404-5.1 & 9.405-5
    Motherboard: Gigabyte GA-N3150N-D3V (88€)
    BIOS version: F3
    CPU: Intel Celeron N3150 (4* 1.6GHz - 2.08GHz) onboard
    RAM: 8GB DDR3L Transcend TS1GSK64W6H (31€)
    Disk Controller: Intel Corporation Device 22a3 (said 'lspci', need to look at 'lshw' output closer)
    Network Interface 0 WAN: Realtek RTL8111/8168/8411 onboard
    Network Interface 1 LAN: Realtek RTL8111/8168/8411 onboard
    VLAN support: (unknown|untested|no|working) untested
    Video Controller: Intel HD Graphics onboard
    Hard Disk: Kingston UV400 120GB SSD (42€)
    Case/Chassis: inter-tech Q-6 Silver (incl. PSU) (61€)
    Power Supply: 60W
    What's not working: nothing
    Total Power Consumption: [measured] 13.5W

    Total Cost: 222€ (88€+31€+42€+61€)
    Shipping: 7€ (6€+1€)
    Comments / Notes: Setup problems using a USB-Key (needed to "mount /dev/sdb1 /install" and complete the names of 6 files in /install/rpm/)

    EDIT1: added BIOS & Disk Controller; EDIT2: added Power Consumption (0.12kWh in 9 hours) & added costs for components and shipping; EDIT3: dropped WLAN & changed SSD & corrected Power Consumption after longer measurement; EDIT4: added tested Version

  • Status: [Working|, currently using at [Home]
    UTM Version: 9.404-5

    Motherboard:    Gigabyte GA-J1900N-D3V (Mini ITX)
    Processor:     Intel Celeron J1900 (2.0 GHz) (On-board)
    RAM: Corsair 8GB (2x4GB) 1600MHz PC3-12800 204-Pin DDR3
    Network Interfaces:    Onboard RTL8111/8168/8411 + RTL8169 PCI
    VLAN support: Yes, currently 3 working
    Hard Disk: Seagate SSHD (SATA)
    Comments / Notes: Comcast xFinity Blast Pro, Redundant information not listed because it's on-board (graphics, sata controller)

  • Status: Working, currently using at Home

    Sophos Version(s) tested: UTM 9.4x
    System OR Motherboard: Zotac Zbox CI323 Nano
    BIOS version: 1.0
    CPU: Intel N3150 Quadcore with AES-NI
    RAM: 4 GB (use only 1 DIMM!!!)
    Disk Controller 1:  Intel Corporation Device 22a3 (rev 21) (SATA)
    Disk Controller 2: Intel Corporation Device 2294 (rev 21) (SD Card)
    Network Interfaces: 2x  Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
    VLAN support: working
    Video Controller: Intel HD Graphics (in CPU)
    Hard Disk: 32 Gb SSD
    Optical Drive: no
    Case/Chassis: passive cooling
    Power Supply:  external
    Total Power Consumption (in Watts, if known): ~10 Watt estimated based upon CPU TDP (6 Watt) and CPU load

    Total Cost: ~200 Euro, Retail, Q1/2016

    Comments / Notes: WIFI not tested. Internet Bandwidth 120 MBit/s, CPU is with all options on (IPS,...) at around 20-30% maximum at full download speed
    THere are problems reported, if both DIMM slots are used (intermittendly crashes)

  • Status: Working, currently using at Home
    Astaro Version(s) tested: 9-408
    System OR Motherboard: Fujitsu D3400-B     70.-€
    BIOS version: R1.13.0
    CPU: INTEL Celeron G3900 2,8GHz  40.-€
    RAM: Kingston 8GB DDR4   60.-€
    Disk Controller 1: 
    Disk Controller 2: 
    Network Interfaces: internal Realtek + INTEL PRO/1000 PT Dual Port  20.-€
    VLAN support: untested
    Video Controller: 
    Hard Disk:KingDian S200 60GB SSD   26.-€
    Optical Drive: (optional)
    Case/Chassis: AeroCool cs-101 Slim M-ATX  39.-€
    Power Supply:  Leicke 12V 5A  20.-€ + picoPSU-90   33.-€
    What's not working: normal installation (see comments)
    Total Power Consumption (in Watts, if known): measured  ~16W
    Total Cost: (optional, please specify currency, retail|used, and date) ~310€ incl. all shipping
    Comments / Notes: (please include your Internet connection speed)

    Installation always stops at: "Detecting other devices".
    Board has only display port and DCI, so I bought a VGA-adapter that didn't help.Finaly I installed on another computer and changed SSD and nics.

    Works perfect. I have only slow DSL, but all features enabled. CPU-load around 4%.

  • Status: Currently building, getting this reserved for tomorrow when I inevitably run into problems :)
    Astaro Version(s) tested: 9.409
    System OR Motherboard: Gigabyte GA-H170N-WIFI Rev v1.0
    BIOS version: 
    CPU: Core i3-6100
    RAM: 2x 4GB G-SKILL DDR4 2133 (PC4 17000)
    Disk Controller 1: Onboard SATA
    Disk Controller 2: 
    Network Interfaces: 2x Intel Onboard 10/100/1000 NICs (1 isn't compatible), 1x Intel i350 T4V2 4-Port GbE Adapter
    VLAN support: unknown
    Video Controller: 
    Hard Disk: Kingston SSDNow UV400 120GB
    Optical Drive: LG SATA Blu-Ray Burner (only stays in case build sticking doesn't work, then is moving to my main computer)
    Case/Chassis: RAIDMAX Element ATX-101B
    Power Supply: Thermaltake Litepower 350W
    What's not working: Cannot detect both onboard Intel NICs
    Total Power Consumption (in Watts, if known): What is the best way to measure?
    Total Cost: $457 + $20 for expedited shipping
    Comments / Notes: I'm hoping that processor - went with the i3 for the higher clock speed since I know Snort rules are single-threaded - will deliver solid speeds for my 1Gbps home connection, FTTP. If it fails to deliver, I'll jump all the way to a Core i7.

    UPDATE: The install wouldn't work because it can't recognize one of the two onboard NICs. I tried to make sure the motherboard I chose had Intel NICs, but it's just freaking impossible to find out exactly which specific chip is running the NICs. It turns out, the Gigabyte board I chose had two different chips and one isn't compatible. The Intel i350 T2 and T4 cards come up consistently as winners in this list, so I'm just getting one of them. Ebay has them for FAR cheaper than you'll find them elsewhere. Once it arrives, I'll try again!

    UPDATE 2: I finally got everything to work by just installing over ESXi. It's running fairly smoothly, but it limits me to about 300 Mbps from the 600 Mbps - 800 Mbps I could get without anything in place. That's obviously not the end of the world, but I was hoping that before I actually started doing full monitoring I would be getting almost the full pipe and it would only slow down after I started turning on more features.

  • Status: Working, being configured for use at Home
    Astaro Version(s) tested: 9.411-3
    System OR Motherboard: JETWAY JNF592-Q170
    BIOS version: [A01]. Initial BIOS
    CPU: i3-6100
    RAM: Crucial 8GB CT102464BF160B
    Disk Controller 1: Onboard Intel
    Disk Controller 2:
    Network Interfaces: 1 x Intel I219-LM PHY Gigabit LAN, 7 x Intel I211-AT integrated Gigabit LAN
    VLAN support: Have not tested
    Video Controller: Onboard HDMI (See notes below for installation hack)
    Hard Disk: SATA - 500GB WD Blue 2.5" (Left over from an old laptop)
    Optical Drive: None (See notes below for installation hack)
    Case/Chassis: Inwin Chopin brushed aluminum w/included 150W power supply
    Power Supply:
    What's not working: Intel I219-LM (nic #1) not recongized by UTM
    Total Power Consumption (in Watts, if known): During boot approx 16w, idle around 10w. Haven't had a chance to measure under full load yet.
    Total Cost: Parts purchased new in Feb 2017. Total build cost $525 USD.
    Comments / Notes: This build is to replace an older system that was built from left over parts in late 2015. It still works now and is still in use until this new build is configured and ready. Setup of the new build didn't go as smooth as the first system but I can say it's fully functional now has a lot more to offer now that I have 7 working nics. The first nic wasn't recognized by the installer but 7 is more than enough for my home needs.

    Numerous failed attempts were made initially to install UTM 9, each ending with the much talked about freezing at the 66% detecting devices. Several posts mentioned HPET, HDMI, and the Q170 chipset as possible causes. I was able to determine HPET wasn't the cause by looking over the boot messages and seeing references to HPET and a device ID found. Next step was getting around the HDMI issue. The motherboard only has a header for HDMI video so it wasn't possible to try another video output from the board. The board also does not have a standard pcie slot but does have a x4 slot for Jetway's network daughterboards. Since it was only a x4 slot, I had to buy a x1 to x16 conversion kit (< $10 on Amazon) to allow me to plug a x16 pcie video card with a VGA output. Once I did this I got past the device detection and installation continued. The next problem I encountered was the end of installation/first boot. It appeared as if the installation completed but when it rebooted I got nothing but a flashing cursor. Thinking it could have been an issue with the HDD I tried another install on a different disk but had the same result. It's worth noting that all attempts were made by installing from a bootable USB drive created with RUFUS from the ISO. I yanked an old SATA DVD drive from a desktop I had in my office closet and wired it up with a freshly burned DVD and the installation ran all the way through. First boot came up fine and I was up and running.

    I'm still in the process of configuring the rules, hosts, services, etc but I did do some throughput tests and initial results are impressive. I haven't tested with IPS enabled or over IPsec but firwall throughput is basically wire speed. CPU hasn't broke past 1% yet and RAM consumption is hovering around 8% but I expect those to change once it's in place and loaded.

  • Status: Working, currently using at Home (with Home License)
    Astaro Version(s) tested: 9.13 9.358 9.409 9.411
    System: Jetway Computer JBC200F9N-E4IN-B (Barebone w/mini-ITX board w/4 x Intel 82574 NIC (ADE4INLANG) daughterboard and Celeron N2930CPU installed, without RAM)
    BIOS version: BF9NAA01 (10/20/2014)
    CPU: Intel Celeron N2930
    RAM: Mushkin Enhanced Blackline 8GB(2 x 4GB)204-Pin DDR3 SO-DIMM DDR3L 1600 1.35V Model 997177
    Disk Controller 1: Onboard Intel SATA I and II capable
    Disk Controller 2: Onboard Intel SATA I and II capable (blocked by the included SATA connector w/unique power wiring and shared with an mSATA slot on the motherboard)
    Network Interfaces: 1 x Intel 211AT and 4 x Intel 82574L
    VLAN support: (unknown|untested yet)
    Video Controller: Intel HD Graphics, 313MHz - 854MHz
    Hard Disk: OCZ Agility 60Gb FW Ver. 1.7 SATA(replaced 3/17 due to errors, may have been failing) SanDisk SSD Plus 120GB SATA
    Optical Drive: None
    Case/Chassis: JC-200S-B (included with Barebone system model number listed above)
    Power Supply: 60W AC-DC (12V) Adapter (included with Barebone system model number listed above)
    What's not working: Need to “ALT+F2” to shell during boot and “mount /dev/sdb1 /installin order to complete install, during installation received these user info bootstrap messages for eth1 through eth4 (the 82574 NICs) [eth1: is a "82574L Gigabit Network Connection" This fixup is applicable to your hardware Your eeprom is up to date, no changes were made]
    Total Power Consumption (in Watts, if known): 17W measured based upon Kill A Watt
    Total Cost: $300 (USD) Retail, 6/30/15 via Newegg
    Comments / Notes: Using Firewall, IPS, Web Filtering with Dual AV Scanning, on 50 Up / 50 Dn Connection with 3 to 4 users online, no issues hitting max internet connection during speedtest.

    Thanks to all those who have posted such valuable information for hardware selection. Also, I never would have been able to get the Sophos UTM software installed and configured correctly without the information provided in this forum.

  • Status: Working, currently using at Home (with Home License)
    Astaro Version(s) tested: 9.503004
    System: QOTOM Q355G4 
    BIOS version: As shipped in September 2017 (it is headless and installed in place)
    CPU: Intel Core i5-5200U  Processor 3M Cache, up to 2.70 GHz
    RAM:  8GB (1 x 8GB) 204-Pin DDR3 SO-DIMM DDR3L 1600 1.35V 
    Network Interfaces: 4 x Intel I211-AT- 10/100/1000 Controller
    VLAN support: (unknown|untested yet)
    Video Controller: Intel HD Graphics 5500
    Hard Disk: 30 GB miniPCIE card
    Optical Drive: None
    Case/Chassis: QOTOM Q55G4
    Power Supply: (included with Barebone system model number listed above) 
    What's not working: Nothing, though I needed to turn of XHCI support in Bios to get around the ISO not found error.  Also had an issue finding the install bits which was fixed w/ this thread. After that, install went in smoothly.
    Total Power Consumption (in Watts, if known): 15W as listed, not measured
    Total Cost: $323 (USD) shipped vi AliExpress September 2017
    Comments / Notes: Using Firewall, IPS, Web Filtering, Network Visibility , POP3 proxy, AV, Antispam, Antispyware.  80 Down / 20 up BT infinity connection, wired connections hit max speed easily.  Not using BT hub, UTM manages the PPPoE connection.  4 ports each on own LAN.  Generally 1-3 users online, seems solid.  Tried XG and while the hardware worked fine, setup was unintuitive enough to make me fall back to this after a few failed attempts.  Running for several days w/ some heavy test and normal load everything seems rock solid.  Probably could have gone w/ less CPU preferred to overshoot than undershoot.  Very happy with UTM and the hardware.

    CPU (Avg/Max) %: 1.96 / 17.40  
    RAM (Avg/Max) %: 22.66 / 24.58 

     

    Edit (22/9/17): after running for several weeks I am very happy with this device and it is definitely overkill for my 80/20 connection.  I rarely see it more that 1-3% CPU w/ everything turned on and I seem to be getting full speed.