Adding an additional network card NIC

I'm trying to add an additional network card via the CLI. All the old support for mentioned editing this file that doesn't exist on UTM 9.5

/etc/modules.conf

Does anyone have updated instructions on what to do?

If I do the following I see the 2nd module that I now need

# cat modules
e1000
r8169

Its just that the hardware doesn't show up in the webadmin. 

  • If you add a card that uses the same driver as an existing NIC, then the additional card should be recognized when the UTM boots.  If you need a different driver, you must re-install from ISO as the installation process only loads drivers for the devices it can "see."  Am I understanding your question?

    Cheers - Bob

  • In reply to BAlfson:

    So there is no CLI hack? :-(

     

    Strange because I put in another Realtek NIC and it showed up under hardware in the webadmin and allowed me to use it. But the r8169 I had didn't 

  • In reply to JLunch:

    the utm has no driver for the chipset r8169... if you put in a nic with a older realtek chipset it should be recognized.

  • In reply to zaphod:

    So there are a bunch of drivers in there by default and we don't need to reinstall to get them active? Is there a list somewhere? 

  • In reply to JLunch:

    the utm depends on a base linux system which is modified by sophos. 

    you can log in with ssh and use the basic commands to see which drivers are build in. something like lsmod 

    it depends on the linux kernel which is used.. 

    and... it is unsupported to manually add drivers..

     

    so newer chipsets will be supported when newer kernels are used. 

     

     

  • In reply to JLunch:

    There are no drivers installed during the loading of the UTM package except for the devices visible to the installer.  It's not plug-n-play.

    There's a Hardware Compatibility List (HCL) in the KnowledgeBase and an unofficial one at the top of the Hardware forum here.

    Cheers - Bob