Anybody with working optional wifi module for sg135w rev3?

Hi All,

I've just installed additional wifi card (XSGZTCH2W) into sg135w rev 3 with latest firmware and unfortunately it does not work with internal wifi card. I can see additional wifi as LocalWifi1 and internal card as LocalWifi0 in Access Point menu. My goal was to have one SSID with LocalWifi0 operating at 5GHz and additional card LocalWifi1 at 2.4GHz, but this is not working for me.

If both cards are associated with internal_wifi, my SSID disappearing and wifi in not working at all, but when using only one card (internal or optional) wifi is working.

What I'm doing wrong?

Is there anybody with working optional wifi module?

Thank you very much.

Ivan

2018:06:12-22:06:28 sg135w awed[5118]: 1 main::getCurrentWirelessStats

2018:06:12-22:06:28 sg135w awed[5118]: 2 main::appendAweLocalStats

2018:06:12-22:06:28 sg135w awed[5118]: 3 main::write_stats

2018:06:12-22:06:35 sg135w hostapd: Configuration file: /var/run/hostapd-phy0.conf

2018:06:12-22:06:35 sg135w hostapd: Configuration file: /var/run/hostapd-phy1.conf

2018:06:12-22:06:37 sg135w hostapd: wifi0: interface state UNINITIALIZED->COUNTRY_UPDATE

2018:06:12-22:06:37 sg135w hostapd: nl80211: Couldnotconfiguredrivermode

2018:06:12-22:06:37 sg135w hostapd: nl80211 driver initialization failed.

2018:06:12-22:06:37 sg135w hostapd: hostapd_free_hapd_data: Interface wifi0 wasn'tstarted

2018:06:12-22:06:37 sg135w hostapd: hostapd_free_hapd_data: Interface wifi0 wasn'tstarted

2018:06:12-22:07:01 sg135w awed[5118]: WARN -------------------------------------------------------

2018:06:12-22:07:01 sg135w awed[5118]: Use of uninitialized value $type in substitution (s///) at awed_ng.pl line 2295.

2018:06:12-22:07:01 sg135w awed[5118]: 1 main::getCurrentWirelessStats

2018:06:12-22:07:01 sg135w awed[5118]: 2 main::appendAweLocalStats

2018:06:12-22:07:01 sg135w awed[5118]: 3 main::write_stats

2018:06:12-22:07:01 sg135w awed[5118]: WARN -------------------------------------------------------

2018:06:12-22:07:01 sg135w awed[5118]: Use of uninitialized value in split at awed_ng.pl line 2297.

2018:06:12-22:07:01 sg135w awed[5118]: 1 main::getCurrentWirelessStats

2018:06:12-22:07:01 sg135w awed[5118]: 2 main::appendAweLocalStats

2018:06:12-22:07:01 sg135w awed[5118]: 3 main::write_stats

2018:06:12-22:07:11 sg135w hostapd: Configuration file: /var/run/hostapd-phy0.conf

2018:06:12-22:07:11 sg135w hostapd: Configuration file: /var/run/hostapd-phy1.conf

2018:06:12-22:07:12 sg135w hostapd: wifi0: interface state UNINITIALIZED->COUNTRY_UPDATE

2018:06:12-22:07:12 sg135w hostapd: nl80211: Couldnotconfiguredrivermode

2018:06:12-22:07:12 sg135w hostapd: nl80211 driver initialization failed.

2018:06:12-22:07:12 sg135w hostapd: hostapd_free_hapd_data: Interface wifi0 wasn'tstarted

2018:06:12-22:07:13 sg135w hostapd: hostapd_free_hapd_data: Interface wifi0 wasn'tstarted

2018:06:12-22:07:33 sg135w awed[5118]: WARN -------------------------------------------------------

2018:06:12-22:07:33 sg135w awed[5118]: Use of uninitialized value $type in substitution (s///) at awed_ng.pl line 2295.

2018:06:12-22:07:33 sg135w awed[5118]: 1 main::getCurrentWirelessStats

2018:06:12-22:07:33 sg135w awed[5118]: 2 main::appendAweLocalStats

2018:06:12-22:07:33 sg135w awed[5118]: 3 main::write_stats

2018:06:12-22:07:33 sg135w awed[5118]: WARN -------------------------------------------------------

2018:06:12-22:07:33 sg135w awed[5118]: Use of uninitialized value in split at awed_ng.pl line 2297.

2018:06:12-22:07:33 sg135w awed[5118]: 1 main::getCurrentWirelessStats

2018:06:12-22:07:33 sg135w awed[5118]: 2 main::appendAweLocalStats

2018:06:12-22:07:33 sg135w awed[5118]: 3 main::write_stats

  • Ahoj Ivan,

    You're the first person to report such a problem.  If multiple reboots doesn't resolve this, I would be interested in learning what Sophos Support says.

    Cheers - Bob

  • There is a known bug with using the same SSIDs on both bands. It is detailed on https://community.sophos.com/kb/en-us/131692. Change the SSID so that each band has a unique name. 

  • In reply to wvondrak:

    I'm aware of this bug, but it's not solving my issue.

    SOPHOS Support team is investigating this issue for more than month but nothing is solved yet.

    If you have access to SophServ you can have a look to Case 8171468 for details.

    Now new bug id (NUTM-10099) was created for this.

    Best regards,

    Ivan