anydesk Status: anynet_unknown UTM SG Firewall

Hallo,

ich habe ein Problem mit Anydesk im internen Netz.

Wenn ich mich per Anydesk von einem PC auf einen anderen schalte - per anydesk ID

dann bricht nach einer gewissen Zeit von ein paar Minuten die Verbindung ab mit dem Fehler:

Die Sitzung wurde beendet.

Status: anynet_unknown

Verbinde ich mich allerdings mit der IP Adresse des Clients anstelle der Anydesk ID, bricht die Sitzung erst nach 15-20 Minuten mit dem

selben Fehler ab.

unter Webfilter Profile habe ich eine Regel erstellt und alle Haken gesetzt

für die URL ^https?://([A-Za-z0-9.-]*\.)?anydesk\.com/

in der Firewall habe ich zum versuch eine Regel mit

"any Network" - port 6568 & port 7070 - "any Network" eingefügt.

dennoch ohne Erfolg

 

 

 

  • In reply to nd:

    Es gab eine Antwort vom Support:

    Eine Webfilter Ausnahme für den AnyDesk zusetzen ist hier das richtige vorgehen, da die Application Control nicht den Webfilter oder die Firewall Regeln umgehen kann.
    Die Application Control kann den Zugriff lediglich zusätzlich beschränken.

     

    Deshalb habe ich nun die Regel AnyDesk in der Application Control deaktiviert und weiterhin die Webfilter aktivert.

    Hierdurch wurde das Problem nicht gelöst. Das habe ich an den Support weiter gegeben und warte nun auf Rückmeldung.

  • In reply to Mich@:

    Genau das habe ich zuvor ja auch schon gestestet.

    - WebFilter Exception drin, Application Control komplett deaktiviert = keine Besserung

    - WebFilter komplett deaktiviert = Funktioniert

     

    Lieft definitiv am WebFilter und hat nix mit der Application Control zu tun.

     

    Was ich an dem ganzen Test interessant fand, wenn der WebFilter deaktivert war und ich dann z.B. eine halbe Stunde fehlerfrei verbunden war und hier dann während der aktiven Verbindung den WebFilter wieder aktiviert habe, dann blieb die Verbindung trotzdem bestehen - habe ich diese dann selber getrennt und erneut aufgebaut, dann brach die Verbindung wieder wie gewohnt alle paar Minuten einfach ab - ohne irgendwas in den LogFiles zu sehen.

  • Ich hatte den gleichen Fehler und hab diesen Thread verfolgt.

    Gestern habe ich meine bestehende Web-Protection Ausnahme für Anydesk auf  

    ^https?://([A-Za-z0-9.-]*\.)?anydesk.com/   geändert.  

    Hab gesehen, dass du bei   ^https?://([A-Za-z0-9.-]*\.)?anydesk\.com/  einen zusätzlichen Backslash vor dem Punkt zum Maskieren verwendest.

     

    Seit ich meine Freigabe in der UTM geändert habe, ist die Anydesk-Sitzung nicht mehr abgestürzt.

    Skip these checks:

    Authentication

    Extension blocking

    URL Filter

    Content Removal

    SSL Scanning

     

    Möglicherweise etwas zu viel, aber bei mir funktioniert es so.

    Einen Test ist es Wert!

    Grüße, Rainer

  • In reply to Rainer Meyer:

    Muss mich leider selber korrigieren. Nachdem es zunächst einen Tag nicht mehr zu Abbrüchen kam (ich war sogar die ganze Nacht durchgehend angemeldet), habe ich jetzt wieder nach einen paar Minuten den gleichen gleichen Fehler wie zuvor.

    Sorry !

  • In reply to Rainer Meyer:

    Ich habe eine Lösung bekommen. Nicht wie erwartet von Sophos, sondern von AnyDesk.

    Sophos direkter Support hatte mir empfohlen unter Web Protection > Filter Optionen > Sonstiges und dann beim ZIELHOST Anydesk.com einzugeben.

    Das funktionierte leider auch nicht.

    Nun hatte ich AnyDesk erneut angerufen und die Lösung lautet:

    Am Quell-PC unter Einstellungen-> Verbindung -> den Haken bei "direkter Verbindung erlauben" rausnehmen.

    und siehe da, es funktioniert intern ohne Probleme! Ich konnte von gestern Nachmittag bis eben eine Verbindung intern halten!

  • In reply to Mich@:

    Mich@

    Nun hatte ich AnyDesk erneut angerufen und die Lösung lautet:

    Am Quell-PC unter Einstellungen-> Verbindung -> den Haken bei "direkter Verbindung erlauben" rausnehmen.

    und siehe da, es funktioniert intern ohne Probleme! Ich konnte von gestern Nachmittag bis eben eine Verbindung intern halten!

     

     
    Kann ich bestätigen, hatten das gleiche Problem. Ohne den Haken funktioniert es ohne Unterbrechung von intern und extern.
    Mich würde es trotzdem interessieren was da genau die Probleme macht, da es ja bei deaktivierter Web Protection unabhängig davon funktioniert.
  • In reply to TheChris:

    Korrekt, das mit dem Haken löst das eigentliche Problem (dass die Sophos Firewall was block) ja nicht.

    Lösungsansatz vom Sophos Support:

    Wir haben eine Netzwerkgruppe mit diversen IP-Adressen und relay-DNS Namen welche auf Anydesk verweisen erstellt.
    Die Netzwerkgruppe dann in der Transparent Skip List unter "Filtering Options --> Misc" einfügen. Soweit läufts, ist für mich aber eher ein Workaround.

    Gruss

  • In reply to Dominik Meier:

    den Workaound habe ich auch bekommen, allerdings hat das bei mir nicht funktioniert. recht interessant das ganze.

    In den Logfiles ist auch nicht aufgeführt was / wann geblockt wird und mit anydesk zu tun hat.

    ein mysterium...