Uninstalling Endpoint Protection fails with "The MSI Terminated Unexpectedly".

I am in the trial period for Sophos Cloud Endpoint. I am trying to uninstall the client from a Windows 10 machine and the uninstallation fails with the following message:

 

"Uninstallation failed. The MSI terminated Unexpectedly"

 

Are there any logs that could help me determine why the MSI is failing? Has anyone else encountered this problem?

  • Hello Michael Smith2,

    the logs should be in %windir%\Temp\.

    Christian

  •  

    Is this the one that you see?

  • In reply to G33k:

    I too am running into this.  Was this ever resolved?

  • In reply to JimHuffman:

    The logs will go to %temp% as you are performing the uninstall.

    You will need to check them.

    Regards,

    Jak

  • In reply to JimHuffman:

    Jim, try a Google on

    site:community.sophos.com/kb uninstall endpoint win 10

    And, if one of those two articles doesn't help you, try one on:

    site:community.sophos.com/products/unified-threat-management/f uninstall endpoint win 10

    Please let us know what worked for you.

    Cheers - Bob

  • In reply to G33k:

    Hi G33k,

     

    1) First Turn off temper protection.

    2) Restart your machine.

    3) After restarting Goto services.msc and stop all sophos services.

    4) Goto control panel and uninstall Sophos Endpoint Agent.

     

    I tried this and successfully uninstall Sophos from my machine.

  • Because this is the first Google result for this issue, I'll post the solution here:

    First, disable tamper protection

    cd C:\Program Files\Sophos\Endpoint Defense\
    SEDcli.exe -TPoff <password>

    Then,

    net stop "SAVService"
    net stop "Sophos AutoUpdate Service"
    "C:\Program Files\Sophos\Sophos Endpoint Agent\uninstallcli.exe"