Lambda Node.js 6.10 EOL from AWS

Sophos Cloud Optix customers may have received an email from AWS regarding the upcoming EOL of support for Node.js 6.10 runtime for Lambda functions. The Sophos Cloud Optix solution used Node.js 6.10 until 24th April 2019.

We've already updated the Cloud Optix AWS on-boarding script, so new AWS accounts that you add to Cloud Optix will now use a newer version of Node.js.

If you added AWS environments to Sophos Cloud Optix before 25th April 2019, we have a script that will upgrade your setup to the new AWS Lambda version. Further information, and the script itself, is provided in the following article: https://community.sophos.com/kb/en-us/134039 

We recommend upgrading your environments before May 30, 2019. After this date, code updates to existing Lambda functions using node.js 6.10 will no longer be allowed by AWS.

  • I have now updated this post with a link to a Sophos knowledge base article, with access to a script that you can run in order to update the Sophos Cloud Optix Lambda functions in your AWS environments.