Sophos Central Endpoint Installation error

hi,

i successfully installed the software on about 50 windows 10 clients, but on a few the installer always fails. i opened a ticket a few days ago, but i havent got any response from sophos yet...

 

here are the lines of the install log file containing the words "WARN" and "ERROR":

2018-08-07T07:52:35.1134169Z WARNING : WinHttpGetProxyForUrl returned: 12180
2018-08-07T07:52:38.1824169Z WARNING : System Property Check: System PendingReboots - FAILED
2018-08-07T07:52:39.1564169Z WARNING : WinHttpGetProxyForUrl returned: 12180
2018-08-07T07:53:16.8894169Z INFO : Command 'CompetitorDetector' completed with success with reboot code '0' and error message ''.
2018-08-07T07:53:16.8944169Z WARNING : WinHttpGetProxyForUrl returned: 12180
2018-08-07T07:53:23.9664169Z WARNING : Proxy settings entered for installation do not match the proxy settings in Cloud.
2018-08-07T07:53:23.9684169Z INFO : Command 'Register' completed with success with reboot code '0' and error message ''.
2018-08-07T07:53:23.9854169Z WARNING : WinHttpGetProxyForUrl returned: 12180
2018-08-07T07:53:39.4214169Z INFO : SUL info: [WARN] cached_package_source::read_stream failed to load filelist from bulk/sdds.ixdata_slow.xml.zip: [DetailedException: Cannot open path C:/ProgramData/Sophos/CloudInstaller/AutoUpdatePreparation/data/Warehouse/bulk/sdds.ixdata_slow.xml.zip ]
2018-08-07T07:53:45.4314169Z INFO : SUL info: [WARN] cached_package_source::read_stream failed to load filelist from bulk/sdds.hips.xml.zip: [DetailedException: Cannot open path C:/ProgramData/Sophos/CloudInstaller/AutoUpdatePreparation/data/Warehouse/bulk/sdds.hips.xml.zip ]
2018-08-07T07:53:47.8434169Z INFO : SUL info: [WARN] cached_package_source::read_stream failed to load filelist from bulk/sdds.hmpa_data.xml.zip: [DetailedException: Cannot open path C:/ProgramData/Sophos/CloudInstaller/AutoUpdatePreparation/data/Warehouse/bulk/sdds.hmpa_data.xml.zip ]
2018-08-07T07:55:20.4444169Z INFO : SUL info: [WARN] cached_package_source::copy_from_upstream copy from upstream failed: 404 Not Found: d1.sophosupd.com/.../21f7a02afcdc1c6e0c88d0e65e9b3180x000.xml.zip
2018-08-07T07:55:23.5394169Z INFO : SUL info: [WARN] cached_package_source::copy_from_upstream copy from upstream failed: 404 Not Found: d1.sophosupd.com/.../fab96cd3811633b30abb262cfe88e236x000.xml.zip
2018-08-07T07:55:44.7094169Z INFO : SUL info: [WARN] cached_package_source::copy_from_upstream copy from upstream failed: 404 Not Found: d1.sophosupd.com/.../7fba8990d0bb342fb6d08e36e76fe3bex000.xml.zip
2018-08-07T07:55:52.3364169Z INFO : SUL info: [WARN] cached_package_source::copy_from_upstream copy from upstream failed: 404 Not Found: d1.sophosupd.com/.../c370726d6cd961c0463d7bacbd4d5c5ax000.xml.zip
2018-08-07T07:55:52.7774169Z INFO : SUL info: [WARN] cached_package_source::copy_from_upstream copy from upstream failed: 404 Not Found: d2.sophosupd.com/.../39715310853d35e7ed58d504405853f4x000.xml.zip
2018-08-07T07:59:33.6524169Z INFO : Command 'Download' completed with success with reboot code '0' and error message ''.
2018-08-07T07:59:33.6574169Z WARNING : WinHttpGetProxyForUrl returned: 12180
2018-08-07T07:59:34.0484169Z INFO : Command 'RetrievePolicy' completed with success with reboot code '0' and error message ''.
2018-08-07T07:59:34.5514169Z INFO : Command 'PrepareInstallation' completed with success with reboot code '0' and error message ''.
2018-08-07T08:00:41.4004169Z ERROR : SetupPluginCommand::onRun() failed with ComponentInstaller::InstallError: Installation failed
2018-08-07T08:00:41.4014169Z INFO : Command 'SetupPlugin' completed with failure with reboot code '0' and error message 'Installation failed'.
2018-08-07T08:00:41.4094169Z ERROR : Installation failed.
2018-08-07T08:00:41.4164169Z WARNING : WinHttpGetProxyForUrl returned: 12180
2018-08-07T08:01:44.2774169Z WARNING : WinHttpGetProxyForUrl returned: 12180
2018-08-07T08:01:44.6164169Z ERROR : Exception: Setup program failed with code: 1

 

these pcs are on the same network as the other ones and i cannot determine any special difference between these clients and the clients that worked. what can i do?

thank you.

  • Hello Josef Datz ,

    Sorry about the delays with Support. Can I please get the ticket number via DM?

    Regarding the issue:
    2018-08-07T07:52:38.1824169Z WARNING : System Property Check: System PendingReboots - FAILED

    Did you try rebooting your machine already?

    Also, check this registry key, if it exists, rename it to "OLD"  and re-try:
    Click on start --> Regedit
    Navigate to:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
    Rename PendingFileRenameOperations to OLD-PendingFileRenameOperations


    2018-08-07T07:55:20.4444169Z INFO : SUL info: [WARN] cached_package_source::copy_from_upstream copy from upstream failed: 404 Not Found: d1.sophosupd.com/.../21f7a02afcdc1c6e0c88d0e65e9b3180x000.xml.zip

    There are several 404 Not found errors in your log. Are these machines using a cache, and if so, are they able to access the server without issues?  
    Here's an article that will help ensure all settings are correct:
    Sophos Central Update Caches and Message Relays Frequently Asked Questions (FAQ)

    If you try installing Sophos off-network (WiFi guest or a hotspot), does it work?

    Regards,