Failed to install Sophos Anti-Virus for Windows: uninstalling an older product failed.

 Endpoint half un-insatlled... now I am just stuck in a loop...

The machine thinks nothing is there...

I can run the Installer again, it performs the 'Pre-Installation' and starts the Download and fails after 20 mins

How does one Remove Sophos Endpoint so I can re-install 

I have tried to stop what services are left available and REG Setting for Tamper Protection... still get no where

Sophos Central, Win10 Any help is greatly appreciated



  • Hi  

    If there are any components left from the older installer, you may check below registry and see if there are any leftovers keys for Sophos Anti-virus or. Please take reg backup before making any changes. 


    If you can provide installer logs from the temp folder, I can check about the component which is failing to get uninstalled. 

  • Hi Keiron,

    As the install is failing due to an uninstall of Sophos Anti-virus failing, could you post the Sophos Anti-Virus Major Uninstall log located in either %temp% or C:\Windows\Temp\?  This should help us determine why the uninstall is failing.

  • In reply to Shweta:

    Hi Shweta


    This is the Log file it spits out, by way of note the Log file requested by MEric 'Sophos Anti-Virus Major Uninstall' does not exist 

    Sophos Anti-Virus Uninstall 2019_09_07_05_18_36Z.log


    Sophos Anti-Virus Uninstall 2019_09_07_05_18_36Z.log

  • In reply to Keiron Crawford:

    Hello ,

    indeed there is never Major in the uninstall log's name, only for Install and Custom Actions. This is the log we're looking for and it shows a 1721 error. Please see this thread, it should help.


  • In reply to QC:

    That did the trick, cheers Christian