ssvmtool.exe "Unknown Error 1: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed"

We are getting an error on the "Sophos Central account details" screen of the ssvmtool.exe installer.    Unknown Error 1: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581)  (no proxy).  

 

2017-03-16 13:08:40,834 [ERROR][291012][ControllerValidator.exception]: ValidationException

File "C:\Build\modules\controller\base.py", line 125, in __call__

File "C:\Build\modules\controller\validate.py", line 1416, in op_cloud

ValidationException: Unknown Error 1: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581)

2017-03-16 13:09:18,046 [INFO][292580][SSVMInstallerWizard.OnWizardCancel]: <class 'gui.credentials.CloudCredentialsPage'>.OnWizardCancel()

 

  • Hello  

    We have not seen this issue before, would you mind contacting support so we can investigate further? 

    Easiest way is to use the link at the bottom on this page.

     

    Thanks 

    Mark 

     

     

  • We are encountering same issue. Was this resolved for you?

  • In reply to EnergySumm:

    Resolved, but do not have decisive resolution.  We were missing a couple of the domains on our Sophos firewall in the KB below.   Unsure if that resolved, or if it was another  GEO/DNS or service issue (I never saw a block on firewall).   The installer did eventually proceed.

     

    URL: http://sophos.com/kb/121936

  • I have the same problem. I did manage to install one SVE instance a couple of months ago - now I need to install another one on another VMWare cluster controlled by the same vCenter server and it won't work. I have re-downloaded the SVE package from Sophos Central just in case it had changed, but it still doesn't work. We are using a self-signed certificate on our vCenter and I already ticked the "Ignore this certificate" box. Is it the vCenter certificate it is complaining about or the Sophos Central certificate??
  • In reply to Dave Hill:

    Hi Dave,

    I've got the same problem like you describe in your post. We're you able to install Sophos VE in the end?

    Kind regards,

    Tijs

     

  • In reply to TijsKeijsers:

    Hi Tijs,

    I raised a ticket with Sophos and this is what they said:

    Hello,
    I believe the certificate is the one from Sophos Central.

    Try browsing to https://central.sophos.com within Internet Explorer on the machine where the SVE installation is being run from. This will cache the certificate on the machine.

    Then run the SVE installer and hopefully this error will not be an issue.

    Regards,
    Sophos Technical Support

     

    This did fix the problem.

    Dave

  • In reply to Dave Hill:

    That did the trick! Thanks